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	The Computer—An Overview

One LearnTouch

A.	 1. (a)		  2. (b)		  3. (a)			  4. (a)			  5. (c)
B.	 1. F		  2. F			   3. T			   4. F
C.	 1.	 impact		 2. webcam		  3. joystick			  4. pixels		  5. Microprocessors

ItLet's Do

A.	 1.	A computer is an electronic machine that accepts data given by user, process the data as per 
given instructions and produces results.

	 2.	A touch screen is a screen that is sensitive to touch and helps us to interact with computers 
by touching the areas on the screen.

	 3.	The motherboard is sometimes called the system board or main circuit board. Many electronic 
components are attached to the motherboard or are built into it.

	 4.	A Computer takes the data as input, processes and then gives result as an output.
B.	 1.	The three main components of CPU are:
	 	   ALU (Arithmetic Logic Unit):  Performs mathematical and logical operations.
	 	   CU (Control Unit): Directs all the operations of a processor.
	 	   Memory Unit: Stores data and instructions.
	 2.	Limitations of a Computer are:
	 	 • Lack of decision making ability
	 	 • Lack of intelligence
	 	 • Lack of feelings or emotions
	 3.	 Impact printers create an image on a paper by striking the paper with a metal.
	 	 Example: Dot matrix printer.
	 	 Non-impact printer create an image on a paper by spraying ink on the paper.
	 	 Example: Inkjet printer.
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Crack CodeThe

A.	 1.	 Input		  2. Output			  3. Input		  4. Input		  5. Output			  6. Input
B.	 1.	Plotters	 2. Joystick		  3. Speakers		  4. Microphone

Do yourself.

	Computer Memory

One LearnTouch

A.	 1.	(a)		  2. (c)			  3. (b)		  4. (c)
B.	 1.	Random Access Memory	 2. Read only memory		  3. Gigabyte		  4. USB
C.	 1.	Memory Card	 2. Hard disk		  3. Flash  drive			   4. DVD		  5. RAM

ItLet's Do

A.	 1.	Hard disk is  a secondary storage device that is used to store data permanently. 
	 2.	A memory card is a multimedia memory card that is used in mobiles and digital cameras to 

store data. 
	 3.	Type of CD’s are: CD ROM, CD-RW, CD-R
	 4.	Optical disc is an electronic data storage medium that can be written to and read using a 

low powered laser beam.
B.	 1.	There are two types of RAM:
	 	 (i) Static RAM		  (ii) Dynamic RAM
	 2.	Types of Computer Memory:
	 	 (a) �Primary Memory—It is the main memory of the computer that can be accessed by the 

CPU directly. It is fixed on the motherboard. There are two types of Primary memory. RAM 
and ROM

	 	 (b) �Secondary memory—It is the permanent memory that is not directly accessed by the CPU. 
I allows users to store data that may be easily retrieved. The secondary memory devices 
are Hard disk, CD’s , DVD’s and Pen drives.

	 3.	(a) �Pen drive—It acts as a portable hard drive and is easy to use as it is small and can be 
carried in a pocket and plugged into any computer with a USB drive.

	 	 (b) �Optical disk—An optical disc is an electronic data storage medium that can be written to 
and read using a low powered laser beam.

C.	 Hard disk    Memory card    Blu-ray disc			  4. Pen drive

2.
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Crack CodeThe

	 1.	Hard disk		  2. Pen drive		  3. DVD		  4. CD

Do yourself.

	Windows 7

One LearnTouch

A.	 1.	(a)		  2. (b)		  3. (a)			  4. (c)
B.	 1.	downloads				    2. folder		  3. subfolder		  4. Windows Explorer
C.	 1.	T		  2. T			   3. F			   4. T
D.	 1.	b		  2. d			   3. e			   4. a			   5. c

ItLet's Do

A.	 1.	Common folders provided by windows 7: 
	 	 • Documents    • Pictures    • Music    • Videos    • Downloads
	 2.	Organised files and folders help us to find the right files to use when we run a program. 
	 3.	When we copy and move a file, it is removed from its original location and appear a new 

location. 
B.	 1.	Difference between a folder and file is a folder is collection of various files and sub folders 

whereas a file is a collection of related information.
	 2.	Steps to delete a file or folder permanently: 
	 	 Step 1 Open the file or folder you want to delete. 
	 	 Step 2 Click on File or folder 
	 	 Step 3 Click on Organize 
	 	 Step 4 Click on Delete 
	 	 Step 5 Click on Yes 
	 	 Step 6 The file or folder will be deleted.
	 3.	To rename a file or a folder, follow these steps:
		  Step 1 Open Windows Explorer and locate the file to be renamed.
		  Step 2 Click on Organize command on the toolbar.
		  Step 3 Click on Rename option from the drop-down list.
		  Step 4 Enter a new name for the file or the folder.
		  Step 5 Press Enter key.

3.
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	Graphics in MS Word 2010

One LearnTouch

A.	 1.	(b)		  2. (b)		  3. (c)			  4. (c)
B.	 1.	Shapes		 2. Insert		  3. Add text		  4. ClipArt		 5. WordArt	 6. 3D
C.	 1.	Shapes		 2. WordArt	 3. Pictures	 4. Symbol
D.	 1.	T		  2. F			   3. F			   4. T			   5. F			   6. F

ItLet's Do

A.	 1.	Click on Insert tab- Shapes command- Choose designed Shape- Drag in the text area
	 2.	By clicking on the Fill command in the shape style group in Format tab.
	 3.	Symbols are punctuation or special characters generally not found on keyboard.
B.	 1.	To change outline colour—Click on Shapes present in Format tab- Click on shape outline in 

shape style group- Choose colour from the drop-down box of colours. 
	 	 To change the thickness—Click on Format tab- Shape effect command in shape style group- 

Bevel option- Select desired bevel effect. 
	 2.	WordArt allows us to create text effects that can not be inserted through text formatting. 

ClipArt helps us to insert pre-designed pictures to make our document look professional. 
	 3.	Place the cursor where you want to insert pictures- Click on Insert tab- Insert picture from 

illustrations group- Choose the desired picture- Click on Insert button and the picture will 
be inserted. 

Crack CodeThe

A.	 WordArt

Do yourself.

	Word Processor—Tabular Representation

One LearnTouch

A.	 1. (b)		  2. (b)		  3. (b)		  4. (a)
B.	 1.	Resizing	 2. Merge cells				    3. Layout			  4. Design		 5. Delete Rows 
C.	 1.	F		  2. T			   3. T			   4. F				    5. F

4.
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Do yourself.

Periodic Assessment-1
(Based on chapters 1 to 3)

A.	
Address bar SearchForward

Back

Toolbar

Status bar

Navigation
pane

File list
Pane

B.	 1.	(c)		  2. (d)			   3. (a)			  4. (b)
C.	 Pendrive
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	Graphics in MS Word 2010

One LearnTouch

A.	 1.	(b)		  2. (b)		  3. (c)			  4. (c)
B.	 1.	Shapes		 2. Insert		  3. Add text		  4. ClipArt		 5. WordArt	 6. 3D
C.	 1.	Shapes		 2. WordArt	 3. Pictures	 4. Symbol
D.	 1.	T		  2. F			   3. F			   4. T			   5. F			   6. F

ItLet's Do

A.	 1.	Click on Insert tab- Shapes command- Choose designed Shape- Drag in the text area
	 2.	By clicking on the Fill command in the shape style group in Format tab.
	 3.	Symbols are punctuation or special characters generally not found on keyboard.
B.	 1.	To change outline colour—Click on Shapes present in Format tab- Click on shape outline in 

shape style group- Choose colour from the drop-down box of colours. 
	 	 To change the thickness—Click on Format tab- Shape effect command in shape style group- 

Bevel option- Select desired bevel effect. 
	 2.	WordArt allows us to create text effects that can not be inserted through text formatting. 

ClipArt helps us to insert pre-designed pictures to make our document look professional. 
	 3.	Place the cursor where you want to insert pictures- Click on Insert tab- Insert picture from 

illustrations group- Choose the desired picture- Click on Insert button and the picture will 
be inserted. 

Crack CodeThe

A.	 WordArt

Do yourself.

	Word Processor—Tabular Representation

One LearnTouch

A.	 1. (b)		  2. (b)		  3. (b)		  4. (a)
B.	 1.	Resizing	 2. Merge cells				    3. Layout			  4. Design		 5. Delete Rows 
C.	 1.	F		  2. T			   3. T			   4. F				    5. F

4.

5.
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ItLet's Do

A.	 1.	 It is the intersection of rows and columns. 
	 2.	Table style is a collection of in built table styles.
	 3.	Shading enhances the look and feel of the table.
B.	 1.	To add a row, follow these steps:
	 	 Step 1 Select the row where you want to add another row.
	 	 Step 2 Click on the layout tab.
	 	 Step 3 Click on Insert Above or Insert Below command. A row will be added.
	 2.	To insert a table, follow these steps:
	 	 Step 1 Open the MS Word and click on the Insert tab.
	 	 Step 2 Click on the Table command in the Tables group.
	 	 Step 3 �Move the mouse over the squares to select columns and rows for the table. When 

you move the mouse over the squares, a sample table is visible in the document.
	 3.	Splitting cell refers to dividing one cell into two or more cells.
	 	 Merging cell refers to combining two or more cells in the same row or same column into a 

single cell.

Crack CodeThe

A.	 1.	 Insert above		  2. Insert below			  3. Delete			   4. Merge cells
B.	
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Do yourself.

Periodic Assessment-2
(Based on chapters 4 & 5)

A.	 1.	Shape outline		  2. Insert tab		  3. Design			  4. Cell 
B.	 1.	 Insert				    2. ClipArt			  3. Rows			   4. Symbols
C.	 1.	T		  2. F		  3. T			   4. False
D.	 1. (d)		  2. (a)		 3. (b)		  4. (c)
E.	 Table

Test Sheet-1
(Based on chapters 1 to 5)

Section A
A.	 1. (ii)		  2. (ii)			  3. (i)			  4. (iii)		  5. (ii)			  6. (ii)
B.	 1.	Pixels		  2. Platters	 3. Sub folder		  4. Format
C.	 1.	F		  2. F			   3. T
D.	 1.	(d)		  2. (c)			  3. (a)			  4. (b)

Section B
A.	 1.	Shape feature is used to insert various ready-made shapes in the word document. 
	 2.	� It is the main memory of the computer. CPU can directly access this memory. It is fixed on 

the Motherboard. 
	 3.	� Renaming a file means to change the default name of the file and give it a new name as per 

your choice
	 4.	Flatbed, Handheld, sheetfed. 
B.	 Long answer type questions. 
	 1.	Limitation of computers
	 	 •  Lack of decision making ability
	 	 •  Lack of intelligence
	 	 •  Lack of feelings or emotions
	 2.	Different types of printers. 
	 	 1. � Dot-matrix printer—It works like a typewriter. The printer head strikes the paper and  ink 

ribbon to print a character. It is an impact printer. 
	 	 2. � Inkjet printer—These are non impact printers. It prints line by line by spraying ink on a 

sheet of paper. These printers are much faster than dot matrix printer. These are expensive 
and consume more ink. 
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	 	 3. � Laser printer—These are also non impact printers. IT uses a laser beam to print on the 
paper. These re much faster than the inkjet printer and print quality of these printer is 
superior.

	More on MS PowerPoint 2010

One LearnTouch

A.	 1. (c)	 2. (a)		 3. (b)	 4. (c)
B.	 1. F	 2. F		  3. T		  4. T
C.	 1.	Slide	 2. Slide layout		 3. Reading		  4. Saved images		  5. Slide show
D.	 1.	Layout			  2. Slide Sorter			   3. Notes Page		
	 4. Reading View		  5. WordArt

ItLet's Do

A.	 1.	A slide layout is the arrangement of text, images, clipart and charts etc. on a particular slide.
	 2.	Normal view
	 3.	List, process and cycle
B.	 1.	To insert SmartArt, follow these steps:
	 	 Step 1 Insert tab.
	 	 Step 2 Illustration group.
	 	 Step 3 SmartArt command.
	 	 Step 4 Choose a graphic type form the left section of dialogue box.
	 	 Step 5 Choose design and click OK.
	 2.	WordArt allows you to create text effects that are not available through font formatting. You 

can insert WordArt in your slides also. To add WordArt to  a slide, follow these steps:
	 	 Step 1 Select the text to be converted to a WordArt style.
	 	 Step 2 Click on WordArt command in the Text group on the Insert tab.
	 		  A drop-down menu appears with different types of WordArt styles.
	 	 Step 3 Select the desired style. A textbox will appear in the document.
	 	 Step 4 Enter text in the textbox. 
	 3.	Normal view—This view is the default view of presentation. It shows current slide, outline 

and notespane. 
	 	 Outline view—This view displays the slide in outline format. 
	 	 Slide Sorter view—This view shows the miniatures of the slides and allows to change the 

order of the slides. 

6.
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	 	 Reader View—This view shows the presentation not in full screen but with simple controls 
to review the presentation. 

Crack CodeThe

	 1.	Slide show		  2. WordArt/Text box		  3. Notes pane		 4. Reading view

Do yourself.

	Introduction to MS Excel 2010

One LearnTouch

A.	 1. (c)		  2. (c)			  3. (b)		  4. (b)
B.	 1.	Name box	 2. Title		  3. Quick Access		  4. Formula		  5. Worksheet
C.	 1. F		  2. T		  3. F			   4. F			   5. F

ItLet's Do

A.	 1.	Cell range is a collection of two or more cells. 
	 2.	Ribbon is a bar that has tabs with groups of related commands displayed in it. 
	 3.	This is the currently selected cell that appeared highlights with a dark border.  
B.	 1.	Formula bar is used to edit and enter formulas. It is also used for entering and editing the 

cell contents. 
	 2.	A workbook is a collection of different worksheets. By default a worksheet contain 3 sheets 

whereas a worksheet is a single page in excel.

Crack CodeThe

	 1.	D3	 2. D5	 3. E4		 4. C4	 5. A4	 6. G4

Do yourself.

7.
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Periodic Assessment-3
(Based on chapters 6 & 7)

A.	 1. Placeholders		  2. Slide Sorter View			  3. Slides
	 4. Workbook			   5. Columns				    6. Name bar
B.	 1. F		  2. T			   3. F			   4. F			   5. T

C.	 Quick Access 
Toolbar

Title bar

Formula bar

Mouse pointer
Active cell

Status bar

Sheet tab

Name box

D.	 MS Excel 2010

	Programming in Scratch

One LearnTouch

A.	 1. (c)		  2. (b)		  3. (b)		  4. (b)
B.	 1.	Looks		  2. Forever	 3. Relational	 4. String
C.	 1.	T		  2. F			   3. T			   4. T			   5. T

ItLet's Do

A.	 1.	Variable blocks are used to hold values and strings.
	 2.	Pen up and Pen down
B.	 1.	Arithematic, Logical and Relational
	 2.	(a) Stamp—It duplicates sprites image on to the stage. 
	 	 (b) Hide—Makes sprite disappear from the stage
	 	 (c) Pen up—Puts up sprite’s pen p so that it won’t draw as it moves on the screen. 

8.
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	 3.	Write the difference between the following: 
	 	 (a) � Forever block runs the script continuously until stopped. Whereas if then else block 

checks the given condition. If the condition is true the then code inside the first space is 
activated else the code inside0 the second space is activated. 

Crack CodeThe

	 1.	Pen block		  2. Arithmetic Operator		  3. Looks block			  4. Variables block
	 5. Pen block

Do yourself.

	More on Internet

One LearnTouch

A.	 1. (a)		  2. (c)			  3. (b)		  4. (a)
B.	 1.	 information		 2. search engine	 3. downloading		  4. uploading
C.	 1.	F		  2. T			   3. T			   4. F
D.	 1.	(c)		  2. (a)			  3. (d)		  4. (b)
E.	 1.	Goggle chrome			   2. Internet Explorer			  3. Mozilla Firefox

ItLet's Do

A.	 1.	 Internet is a network in which millions of computers are connected one another to share 
information. 

	 2.	Facebook, Twitter and Instagram
	 3.	Getting data from the host computer to the client computer is called as downloading. 
B.	 1.	Uses of internet 
	 	 •  We can buy and sell goods online. 
	 	 •  We can search information on any topic.
	 2.	 ISP is a company that provides internet access to people on payment of a monthly fees like 

Airtel, Vodafone etc. 
	 3.	Telephone lines and cables, Modem, Computer System, web browser and ISP.

Crack CodeThe

	 1.	URL		  2. Surfing			  3. Telephone and Cable lines		 4. Internet/Web browser

9.
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Do yourself.

Periodic Assessment-4
(Based on chapters 8 & 9)

A.	 1.	Looks		  2. Looks		  3. Pen		  4. Operator		  5. If then else		  6. Forever
B.	 1.	(d)		  2. (a)			  3. (b)		  4. (c)
C.	 1.	 INFORMATION	 		  2. DOWNLOADING			
	 3.	ONLINE CHAT			   4. UPLOADING
D.	 1.	Arithmetic operator	 2. Relational Operator		  3. Logical Operator

Test Sheet-2
(Based on chapters 6 to 9)

Section A
A.	 1.	(i)		  2. (ii)			  3. (iii)		  4. (i)			  5. (i)
B.	 1.	Slides		  2. Slide Show	 3. Worksheet	 4. String
C.	 1.	T		  2. F			   3. F			   4. T			   5. F			   6. T
D.	 1.	(c)		  2. (d)		  3. (a)			  4. (e)		  5. (b)

Section-B
A.	 1.	 It is cell which have dark black border around it. 
	 2.	 It is an application software that helps us to access internet. 
	 3.	� Title bar, Ribbon, Name box, Quick Access toolbar, Formula bar, Cell, Rows and columns, 

sheet tabs, Scroll bars, Active cell, 
	 4.	Slide layout refers to the way of arranging objects on a slide.
	 5.	 Internet can be used to buy and sell thing online and send and receive messages.
B.	 1.	� Normal view—This view is the default view of presentation. It shows current slide, outline 

and notes pane. 
	 	 Outline view—This view displays the slide in outline format. 
	 	� Slide Sorter view—This view shows the miniatures of the slides and allows to change the 

order of the slides. 
	 	� Reader View—This view shows the presentation not in full screen but with simple controls 

to review the presentation. 
	 2.	Stamp block duplicates the sprite’s image on the stage. 
	 3.	Computer system, Telephone and cable lines, Web browser, ISP and Modem. 




