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	Computer Software

One LearnTouch

A.	 1.	 (c)	 2.	 (c)	 3.	 (b)	 4.	 (c)
B.	 1.	 T
	 2.	 F � Correct Statement: A computer system is made up of a number of hardware devices 

and software.	
	 3.	 F  Correct Statement: Virus scanner is used to scan files and folders for virus.
	 4.	 F  Correct Statement: DBMS is a general purpose application software.
C.	 1.	 instructions			   2.	 operating system
	 3.	 application software	 4.	 disk defragmenter
D.	 1.	 (d)	 2.	 (c)	 3.	 (a)	 4.	 (e)	 5.	 (b)

ItLet's Do

A.	 1.	 An electronic device that performs diverse operations with the help of instructions to 
process the data in order to achieve desired results. 

	 2.	 An operating system is the most important software that runs on a computer. It 
manages the computer’s memory, processes data and controls all its software as 
well as hardware. 

	 3.	 Multimedia software are used to combine the text with graphics, videos and sounds.  
	 4.	 Application software is a program designed to help users to perform specific tasks. 

MS Word, MS Excel and MS PowerPoint are application software.
B.	 1.	 System software is the most important component to operate a computer. System software 

can be classified into three categories:
	 (i)	 Operating System	 (ii)  Programming Software	 (iii)  Utility Software 
	 2.	 Application software can be of two types: 
	 (i)	 General purpose software: General purpose software are those which have not 

been developed according to the needs of a particular organization.
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	 (ii)	 Customised software: Customised software are those which have been developed 
according to the needs of a particular organisation or an individual. 

		  Some examples of application software are Microsoft Word, Microsoft Access, and 
Windows Movie Maker.

Crack CodeThe

A.	 1.	 Word Processors        2.   Antivirus        3.   Data Compression Program

Do yourself.

	Windows 7

One LearnTouch

A.	 1.	 (b)	 2.	 (c)	 3.	 (c)	 4.	 (a)
B.	 1.	 F  Correct Statement: Windows 7 was launched in 2009.
	 2.	 T	 3.	 T	 4.	 T
C.	 1.	 Taskbar			   2.	 Recycle bin
	 3.	 Notification Area		 4.	 Aero flip 

ItLet's Do

A.	 1.	 A jump list is a feature introduced in Windows 7 that allows you to view recent documents 
in a program that is pinned to the taskbar. 

	 2.	 The Disk Cleanup tool is used to search on the hard disk for files that can be deleted from 
your computer without affecting its functions or your personal files. 

	 3.	 Status bar shows various information about the file in which you are working. 
	 4.	 Five components of an active window are:
	 (i)	 Title bar	 (ii)	 Control Buttons	 (iii)	 Scroll bars
	 (iv)	 Work area	 (v)	 Status bar
B.	 1.	 Snap feature arranges two windows side by side exactly to fill half the screen each and 

Aero Flip feature shows you what is happening in all other open windows on the computer 
system. 

	 2.	 To open Control Panel:
		  Step 1  Click on Start button. 
		  Step 2  Click on Control Panel. 

2.
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	 3.	 To change date:
		  Step 1  Click on the Clock, Language, and Region option from the Control Panel.
		  Step 2  Click the Date and Time option.
		  Step 3  Click Change Date and Time button. 
	 	 Step 4  Select date and month from the calender.
		  Step 5  Click on OK button.
		  Step 6  Click on OK button.

Crack CodeThe

A.	 1.	 By changing Mouse setting from Right handed to Left handed in the Mouse Properties 
dialog box, the mouse is configured for left handed person.

	 2.	 By using the Disk Cleanup tool, junk files can be deleted from the computer. 
B.	
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Do yourself.

Periodic Assessment-1
(Based on chapters 1 & 2)

A.	 2.	 Disk Cleanup tool is used to delete temporary Internet files and Windows temporary files. 
	 4.	 The section at the right end of the Taskbar is called Notification Area.
	 5.	 Recording tab is available in the Sound dialog box. 
B.	 1.	 Word Processors software are used to create, edit and format text documents. Microsoft 

Word is an example of Word Processors software.
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	 2.	 Database Management System (DBMS) software are used to create, store, modify and sort 
data stored in a database. Microsoft Access is an example of DBMS.

	 3.	 Spreadsheet software are used to calculate, compare and analyse data and used to prepare 
different reports. Microsoft Excel is an example of Spreadsheet software.

	 4.	 DeskTop Publishing (DTP) software are used to create newspapers, magazines, brochures, 
still advertisements, etc. Adobe InDesign is an example of DTP software.

	 5.	 Presentation software are used to create presentations which include sound, music, video, 
charts and animation. Microsoft PowerPoint is an example of Presentation software.

C.	 1.	 Application software	 2.	 Calc	 3.	 Adobe InDesign		 4.	 Share
D.	 1.	 (c)	 2.	 (e)	 3.	 (a)	 4.	 (b)	 5.	 (d)

	More on MS PowerPoint 2010

One LearnTouch

A.	 1.	 (a, b, c)	 2.	 (c)	 3.	 (d)	 4.	 (b)	 5.	 (b)	 6.	 (b)
B.	 1.	 T	 2.	 T	 3.	 T
	 4.	 F � Correct Statement: To hide background graphics in the design theme, click the Hide 

Background Graphics. 
	 5.	 F � Correct Statement: You can change the order of the animation on an object, by clicking 

move earlier or move later commands. 
	 6.	 F  Correct Statement: To preview an effect from the animation pane click, Play button.
C.	 1.	 one or more			   2.	 presentations			   3.	 animation 
	 4.	 ribbon			   5.	 slide			   6.	 create
D.	 1.	 (d)	 2.	 (a)	 3.	 (b)	 4.	 (c)

ItLet's Do

A.	 1.	 A slide is a single page of a presentation.
	 2.	 Transition determines how your presentation moves from one slide to the next. 
	 3.	 Slide transition is applied on the slides and animation is applied on the objects of the slides.
B.	 1.	 To apply design themes: 
		  Step 1  Click on the Design tab. 
		  Step 2  Place your mouse pointer over any of the theme in the Themes group. 
		  Step 3  Click the design theme thumbnail when you find one that suits your needs. 
	 2.	 To insert Clip Art: 
		  Step 1  Click on Insert tab.
		  Step 2  Click on Clip Art command.
		  Step 3  Enter keyword in the Search for: text box in the ClipArt pane. 

3.
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		  Step 4  Click on the image you want to insert in a slide.  
		  To insert a picture: 
		  Step 1  Click on the Insert tab. 
		  Step 2 � From the Images group, click on the Picture command. The Insert Picture dialog 

box appears. 
		  Step 3  Select the desired image file and click on Insert button. 
	 3.	 a.  To insert a new slide:
		        Step 1  Click on Home tab on the ribbon. 
		        Step 2  Click on the New Slide button. Select the type of slide you want to insert. 
		  b.  To delete a slide: 
		        Step 1  Select the slide you want to delete. 
		        Step 2  Right-click on the slide and choose Delete Slide from the pop-up menu. 
		  c.  To rearrange the slides:
		       Step 1 � Click on Slide Sorter View command from the Presentation Views group in the 

View tab.
		       Step 2  Click and drag the slide which you want to rearrange.
	 4.	 To apply animation to text or objects:
		  Step 1  Click on the image or the text you would like to animate.
		  Step 2  Click Animations tab.
		  Step 3  You can either open the Animation pane or use the drop-down list.
		  Step 4  Select the animation effect you would like. 
		  Step 5 � Specify whether you want your animation to start On mouse click, After previous 

or With previous.

Crack CodeThe

A.	 1.	 By using Themes, Sumit can add a background to his presentation.
	 2.	 By using Animation, Pooja make the objects appear in a different way. 
B.	

		

1T M

2A

3S

4D

5S

T

T

EH

R

E S

IN I M A O N

F

I

H

L I D E H O W

N

I

IE S G N

O

N

T



Touchpad PRIME (Version 1.1)-VI (Answer Key)6

Do yourself.

	More on MS Word 2010

One LearnTouch

A.	 1.	 (a, b)	 2.	 (c)	 3.	 (a)
B.	 1.	 T	 2.	 T	 3.	 T
	 4.	 F  Correct Statement: Paragraph spacing can be changed in a document. 
C.	 1.	 page	 2.	 watermark			   3.	 footer
	 4.	 buttons	 5.	 page orientation 

ItLet's Do

A.	 1.	 Formatting refers to the layout of a paper and it is important to format a document to 
make it more understandable and attractive. 

	 2.	 Header is the text that appears at the top of each page of the document and Footer is the 
text like page number that appears at the bottom of each page of the document. 

	 3.	 Page margins are used to add blank space around the text of the document so it is easy 
to bind the papers. 

B.	 1.	 The Header or Footer are used to save time and effort of the operator to enter same text 
on each page. It also reduces chances of errors like missing to enter details on a page. To 
add a header or footer:

		  Step 1  Click on the Insert tab.
		  Step 2  Click on Header or Footer command from the Header & Footer group.
		  Step 3 � You can choose from various available header/footer templates or choose Blank 

option to enter text of your choice.
		  Step 4 � This will open the respective Header or Footer section of the page. You can type 

the text you want to appear on each page.  
	 2.	 The Mail Merge feature in MS Word is used to create personalised letters to be sent to 

many persons. It saves a lot of time, as you do not need to change the information for 
every person manually. 

	 3.	 To find a word: 
		  Step 1 � Click on the Find command on Home tab. This will open Navigation panel on the 

left side of the MS Word window. 
		  Step 2  Type the word or phrase in the text box. 
		  Step 3  Click on the Search icon on the right side of the text box or press Enter key. 

4.
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		  Step 4 � The lower part of the Navigation panel will display a list of occurrences of the 
required text or phrase. 

		  Step 5  Press Enter key to move to the required occurrence of the text. 
		  To replace a word:
		  Step 1 � Click on the Replace command on Home tab. This will open Find and Replace dialog 

box. 
		  Step 2  Type the existing word or phrase that is to be changed in the Find what text box. 
		  Step 3  Type the new word or phrase in the Replace with text box. 
		  Step 4 � Click on Find Next and Replace buttons for selective replacement of the text or click 

on Replace All button to replace all occurrences of the existing text with the new 
text. 

	 4.	 To insert mathematical equations:
		  Step 1  Click on the Insert tab. 
		  Step 2  In the Symbols group, click on the down arrow under the Equation command. 
		  Step 3  Click on the Insert New Equation. 
		  Step 4  A blank equation box saying ‘Type Equation here’ appears on the document. 
		  Step 5 � You can enter the equation using number keys on the keyboard and symbols on 

the ribbon under Design tab. 

Crack CodeThe

A.	 1.	 Mail Merge			   2.	 Watermark
B.	

		

6

1

4

4

2

3

E R

N7

8 O R

5

M T R

R

E

P

L

A

C

H A D E

F I D

T EF O

N

M

A

I

L

M

E

G

E

A

G

I

S A R A T

W

A

E

R

M

A

R

K

O

I

E

N

T

A

T

I



Touchpad PRIME (Version 1.1)-VI (Answer Key)8

Do yourself.

	Learning MS Excel 2010

One LearnTouch

A.	 1.	 (d)	 2.	 (a)	 3.	 (a, c)	 4.	 (c)
B.	 1.	 T	 2.	 T	 3.	 T	 4.	 T
C.	 1.	 Excel	 2.	 create	 3.	 program	 4.	 merge cells  

ItLet's Do

A.	 1.	 Spreadsheet is a program that allows you to store and analyse numerical data.  
	 2.	 The horizontal divisions on a worksheet are called rows and vertical divisions on a worksheet 

are called columns. 
	 3.	 AutoFill feature automatically fills a series of data in your worksheet. 
B.	 1.	 The data in the form of numbers or text can be entered by just clicking on a cell and typing 

with the help of a keyboard. You can type data directly into the cell, or you can enter data 
using the Formula bar. 

	 2.	 To set column width/row height:
		  Step 1  Select the column(s) or row(s) that you want to change. 
		  Step 2  Click on Format command in Cells group from Home tab. 
		  Step 3  Choose Column Width or Row Heights under Cell size from the drop-down list. 
		  Step 4  A Column Width or Row Height dialog box will appear. 
		  Step 5 � In the Column Width or Row Height box, type the value that you want your column 

or row to be. 
	 3.	 To apply cell border:
		  Step 1 � On a worksheet, select the cell or range of cells that you want to add a border to, 

change the border style on, or remove a border from. 
		  Step 2  Go to the Font group in the Home tab. 
		  Step 3  Click the arrow next to Borders command. 
		  Step 4  Click on the border style you would like.  

Crack CodeThe

A.	 1.	 By using the Wrap Text command present on the Alignment group in the Home tab, Sonia 
can make the text visible. 

5.
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	 2.	 By inserting a column, Anaya can create space to enter the marks.
B.	
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	 1.	 To add a row above fifth row:
		  Step 1  Select the fifth row by clicking on the row heading. 
		  Step 2  Click on Insert command in the Home tab. 
		  Step 3  Click the Insert Sheet Rows option.
	 2.	 To insert a column to the right of third column:
		  Step 1  Click and select the fourth column heading. 
		  Step 2  Click on Insert command on the Home Tab.
		  Step 3  Click on Insert Sheet Columns option.  
	 3.	 To fill roll numbers from 1 to 11:
		  Step 1  Enter the first two numbers 1 and 2.  
		  Step 2  Select both the cells containing the numbers you have entered. 
		  Step 3 � Position the mouse pointer over the bottom right corner of the last selected cell. 

The pointer changes to (+) sign. 
		  Step 4  Drag the mouse pointer over the cells you want to include in the series. 
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Periodic Assessment-2
(Based on chapters 3 to 5)

A.	 1.	 Ctrl + F			   2.	 Ctrl + H			   3.	 Esc	
	 4.	 Shift + F5			   5.	 Ctrl + X			   6.	 Ctrl + V

B.	
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Test Sheet-1
(Based on chapters 1 to 5)

Section A
A.	 1.	 (d)	 2.	 (b)	 3.	 (c)	 4.	 (a, b)	 5.	 (a)
B.	 1.	 presentation    2.  object    3.  orientation    4.  page    5.  create
C.	 1.	 Record button: It is used to start recording your voice. 
	 2.	 Preview Results: It is used to see the preview of mail merge. 
	 3.	 Orientation: It is used to define orientation of the page. 
	 4.	 Stop Record button: It is used to stop the recording. 
	 5.	 Border: It is used to set the border of a cell or text.
	 6.	 SmartArt: It is used to represent food chains or hierarchy series.
D.	 1.	 T	 2.	 T	 3.	 T	 4.	 F	 5.	 T
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Section B
A.	 1.	 Slide transition can be applied on the slides of a presentation whereas animation can be 

applied on the objects of a slide.
	 2.	 A slide is a single page of a presentation.
	 3.	 Page margin is the white space all around the printed area of the paper. 
	 4.	 The horizontal divisions on a worksheet are called rows and the vertical divisions on a 

worksheet are called columns. 
	 5.	 Spreadsheet is a program that allows you to store and analyse numerical data.
B.	 1.	 To insert Clip Art: 
		  Step 1  Click on Insert tab.
		  Step 2  Click on Clip Art command.
		  Step 3  Enter keyword in the Search for: text box in the ClipArt pane. 
		  Step 4  Click on the image you want to insert in a slide.  
		  To insert a picture: 
		  Step 1  Click on the Insert tab. 
		  Step 2 � From the Images group, click on the Picture command. The Insert Picture dialog 

box appears. 
		  Step 3  Select the desired image file and click on Insert button.
	 2.	 The Header or Footer are used to save time and effort of the operator to enter same text 

on each page. It also reduces chances of errors like missing to enter details on a page. To 
add a header or footer:

		  Step 1  Click on the Insert tab.
		  Step 2  Click on Header or Footer command from the Header & Footer group.
		  Step 3 � You can choose from various available header/footer templates or choose Blank 

option to enter text of your choice.
		  Step 4 � This will open the respective Header or Footer section of the page. You can type 

the text you want to appear on each page.
	 3 .	 The Mail Merge feature in MS Word is used to create personalised letters to be sent to 

many persons. It saves a lot of time, as you do not need to change the information for 
every person manually.

	 4.	 To apply cell border:
		  Step 1 � On a worksheet, select the cell or range of cells that you want to add a border to, 

change the border style on, or remove a border from. 
		  Step 2  Go to the Font group in the Home tab. 
		  Step 3  Click the arrow next to Borders command. 
		  Step 4  Click on the border style you would like.
	 5.	 To set column width/row height:
		  Step 1  Select the column(s) or row(s) that you want to change. 
		  Step 2  Click on Format command in Cells group from Home tab. 
		  Step 3  Choose Column Width or Row Heights under Cell size from the drop-down list. 
		  Step 4  A Column Width or Row Height dialog box will appear. 
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		  Step 5 � In the Column Width or Row Height box, type the value that you want your column 
or row to be.

	Introduction to Flash CS6

One LearnTouch

A.	 1.	 (b)	 2.	 (d)	 3.	 (a)
B.	 1.	 F  Correct Statement: Animation effects can be added in Flash.
	 2.	 F  Correct Statement: The white rectangular area of the Adobe Flash  workspace is called 

stage. 
	 3.	 T	 4.	 T
C.	 1.	 frame	 2.	 layers	 3.	 left	 4.	 bottom

ItLet's Do

A.	 1.	 Flash is a very useful application used in multimedia graphic programs. 
	 2.	 ActionScript 3.0. 
	 3.	 Yes, there are many ways to exit Flash.
	 (i)	 Click on Exit from File menu		  (ii)  Press Ctrl + Q keys 
	 4.	 Text Tool, Pen Tool and Line Tool.
B.	 1.	 To start Flash: 
		  Step 1  Click on Start button. 
		  Step 2  Click on All Programs. 
		  Step 3  Click on Adobe Flash CS6 Professional. 
	 2.	 Properties panel allows you to set the properties of the objects that you have selected on 

the stage. It also provides options to change the settings of the Flash document such as 
stage dimensions and the animation’s frame rate. 

	 3.	 To save a Flash file: 
		  Step 1  Click on File menu. 
		  Step 2  Click on Save to open Save As dialog box. 
		  Step 3  Enter a name for the file in File name text box. 
		  Step 4  Click on Save button.

Crack CodeThe

A.	 1.	 Sunidhi can place the objects on the pasteboard.
	 2.	 Options area 

6.
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B.	

		

O

E

A

6

A

R

SF

W

I E

S

T

L

N

O

3

4

8

7

5

21

I

E

D B E

B

O

D

P

AE

L A H

C

M

T M L

P

A

E

L

N E

O

F

F

L

To start Flash:
Step 1  Click on Start button. 
Step 2  Click on All Programs. 
Step 3  Click on Adobe Flash CS6 Professional. 
To create a new Flash document: 
Step 1  Click on File menu. 
Step 2  Click on New to open New Document dialog box. 
Step 3  Select ActionScript 3.0 from the Type list. 
Step 4  Click on OK button. 
To save a Flash file: 
Step 1  Click on File menu. 
Step 2  Click on Save to open Save As dialog box. 
Step 3  Enter a name for the file in File name text box. 
Step 4  Click on Save button. 
To exit Flash:
Click on Exit from File menu 
Or 
Press Ctrl + Q keys 
Or 
Press Alt + F4 keys 
Or 
Click on the Close button on top right corner of the Flash window.
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	Using Tools in Flash CS6

One LearnTouch

A.	 1.	 (c)	 2.	 (d)	 3.	 (a)	 4.	 (a)
B.	 1.	 T	 2.	 T
	 3.	 F  Correct Statement: We can change shape and size of an eraser.
	 4.	 T
C.	 1.	 Pencil	 2.	 Circle	 3.	 fill colour	 4.	 Hand	 5.	 Stroke 

ItLet's Do

A.	 1.	 Stroke Height text box is used to change width or thickness of the line.
	 2.	 Freehand lines and curves. 
	 3.	 Yes, there are some options:
	 (i)	 Oval Tool		  (ii)  PolyStar Tool
B.	 1.	 Selection Tool: It is used to select and move objects. 
		  Hand Tool: It is used to move to different parts of the stage without changing the view of 

the stage.
	 2.	 Properties of a line are Stroke Color, Stroke Size, Stroke Style and Cap. 
	 3.	 The main difference between Star and Polygon options is that the Star option creates a 

star and the Polygon option creates a polygon with specified number of sides. 

Crack CodeThe

A.	 1.	 PolyStar Tool
	 2.	 Gishi can draw a square by using the Shift key with the Rectangle Tool.
	 3.	 Yes, Surabhi can remove some parts by using the Eraser Tool.
B.	       
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Do yourself.

Periodic Assessment-3
(Based on chapters 6 & 7)

A.	 1.	 Selection Tool    2.  Hand Tool    3.  Rectangle Tool    4.  Line Tool
	 5.	 Eraser Tool    6.  Pencil Tool    7.  PolyStar Tool
B.	 1.	 Rectangle    2.  Rectangle
C.		

Options
box

Tools panelProperties panelStage

Menu bar

Pasteboard

	Computer Programming

One LearnTouch

A.	 1.	 (a)	 2.	 (c)	 3.	 (b)	 4.	 (c)	 5.	 (c)
B.	 1.	 F  Correct Statement: Assembly language is a second generation language. 
	 2.	 T	
	 3.	 F � Correct Statement: A compiler or an interpreter is used to translate the entire source 

code into machine language.

8.
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	 4.	 F � Correct Statement: The programmer must always make a flowchart before writing a 
program. 

C.	 1.	 data, instructions	 2.	 programming			   3.	 assembler 
	 4.	 flow lines, arrows	 5.	 consistent 

ItLet's Do

A.	 1.	 An assembler is a program used to translate assembly language into machine language. 
	 2.	 An Algorithm is a set of steps in a sequential and ordered manner to solve any problem. 
	 3.	 A flowchart is a type of diagram that represents an algorithm. 
B.	 1.	 The main difference between HLL and LLL is that the LLL is machine dependent and HLL is 

machine independent.
	 2.	 The advantages of HLL are:
		  •  High level language is user friendly.
		  • � High level language is similar to English with vocabulary of words and symbols, therefore 

it is easier to run.
		  •  High level language requires less time to write.
		  •  High level language is easier to maintain. 
	 3.	 A compiler and an interpreter are software that convert the entire source program into 

machine language before executing it.
C.	 1.	 Connector	 2.	 Decision	 3.	 Process	 4.	 Input/ Output   

Crack CodeThe

A.	 1.	 a. Input/Output		  b.	 Process	 c.	 Input/Output   
	 2.	 Richa should make an algorithm before drawing a flowchart. 
B.	
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  Do yourself.
	 1.	

Stop

Start

Switch on main power 
supply button

Switch on the UPS

Switch on the power supply 
button of CPU box

Switch on the monitor 
power supply button

			   2.	

Stop

Input Radius

Print Area

Start

Area = 3.14 * Radius * Radius

	 3.	

Stop

Read P, R, T

Print SI

Start

SI = (P * R * T)/100

	 4.	

Stop

Input L, W

Print P

Start

P = 2 * (L + W)
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	Visual Basic 9

One LearnTouch

A.	 1.	 (b)	 2.	 (a)	 3.	 (b)	 4.	 (b)	 5.	 (c)
B.	 1.	 T
	 2.	 F � Correct Statement: Software developers use various programming languages to design 

software. 
	 3.	 F  Correct Statement: Form is a window where all controls are put up. 
	 4.	 F  Correct Statement: The Backcolor of a Button dragged on Form can be changed.
	 5.	 F  Correct Statement: Controls cannot be dragged and dropped on the Form.  
C.	 1.	 Label	 2.	 RadioButton			   3.	 applications 	4.	 ComboBox 
D.	 1.	 property	 2.	 command	 3.	 control	 4.	 software	 5.	 window

ItLet's Do

A.	 1.	 This is because of its drag and drop feature. When you draw a control on your form, Visual 
Basic automatically generates sets of commands about that control. 

	 2.	 Programming is generally used to mean writing various lines of instructions to develop a 
program that can work. 

	 3.	 Used to run your application.
B.	 1.	 Visual Basic is used to create windows-based applications. Not only this, but you can also 

create programs which can be used on web browsers and mobiles. In short, all computer 
software running on Windows operating system can be developed in Visual Basic. 

	 2.	 Text of the Label control cannot be directly edited or changed whereas the information 
typed in the TextBox control can be edited.

	 3. 	     (i)		 The Button is the most commonly used control. It is used to start or stop a particular 
process. 

	 (ii)	 A CheckBox is used when a choice has to be given to the user to select one or more 
options from the given list of options. 

	 (iii)	 The Label is used to display text which a user cannot directly edit or change. 
C.	 1.	 F5	 2.	 Ctrl + Shift + S		  3.	 Ctrl + S	 4.	 Ctrl + N
D.	 1.	 Label			   2.	 Pointer			   3.	 TextBox
	 4.	 Month Calendar		 5.	 Button			   6.	 CheckBox

Crack CodeThe

A.	 1.	 CheckBox	 2.	 Label
B.	 1.	 Visual Basic			   2.	 Toolbox			   3.	 ForeColor property
	 4.	 Message Box			   5.	 Form

9.
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    Do yourself
  To find the total of marks obtained in 5 subjects:

	 Step 1	 Add six Label controls, six TextBox controls and a Button control on the form.
	 Step 2	 Change the Text property of Label1, Label2, Label3, Label4, Label5 and Label6 controls 

to Marks in Subject 1, Marks in Subject 2, Marks in Subject 3, Marks in Subject 4, Marks 
in Subject 5 and Total Marks respectively.

	 Step 3	 Change the Text property of the Button control to Total.
	 Step 4	 Double click the “Total” button and write the following code where the cursor appears 

to blink:
		  TextBox6.Text = Val(TextBox1.Text) + Val(TextBox2.Text) +Val(TextBox3.Text) + 

Val(TextBox4.Text) + Val(TextBox5.Text) 
	 Step 5	 Now come to the Form Design Window, save the file and run it by pressing F5. 

  To calculate interest:
	 Step 1	 Add four Label controls, four TextBox controls and a Button control on the form.
	 Step 2	 Change the Text property of Label1, Label2, Label3, and Label4 controls to Principle, 

Rate, Time, Simple Interest respectively.
	 Step 3	 Change the Text property of the Button control to Find Interest.
	 Step 4	 Double click the “Find Interest” button and write the following code where the cursor 

appears to blink:
		  TextBox4.Text = (Val(TextBox1.Text) * Val(TextBox2.Text) * Val(TextBox3.Text))/100  
	 Step 5	 Now come to the Form Design Window, save the file and run it by pressing F5. 

Periodic Assessment-4
(Based on chapters 8 & 9)

A.	 1.	 Machine language	 2.	 Assembler			   3.	 Connector   
	 4.	 RadioButton			   5.	 Form
B.	 Step 1	 Start. 
	 Step 2	 Read all three numbers and store them in A, B and C. 
	 Step 3	 Add two numbers A and B. 
	 Step 4	 Multiply the sum with the number C.
	 Step 5	 Print the result.
	 Step 6	 Stop.
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C.	

Is
X>Y?

Is
X>Z?

Is
Y<Z?

Is
Z<X?

Is
Y>Z?

Yes

Yes Yes

YesYes

No

No No

NoNo

Stop

Start

Input X, Y, Z

Print X, Z, Y Print Y, X, ZPrint X, Y, Z Print Z, X, Y Print Y, Z, X Print Z, Y, X

D. 
Start

Stop

Read P, r, t

Print SI

Calculate
SI = (P * r * t)/100
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E.	 1.	 A TextBox is used to display information which has been entered by the programmer at the 
time of designing the application or has been entered by the user during the execution of 
the application. 

	 2.	 The Pointer is used to select any control on the Form. 
	 3.	 A ListBox is used to display a list of items from which a user can select one or more options. 

Test Sheet-2
(Based on chapters 6 to 9)

Section A
A.	 1.	 (c)	 2.	 (b)	 3.	 (d)	 4.	 (a)
	 5.	 (b)	 6.	 (c)	 7.	 (a)	 8.	 (b)
B.	 1.	 Programming			   2.	 Connector, Flow Line	 3.	 Timeline 
	 4.	 Pencil			   5.	 ComboBox			   6.	 Label

Section B
A.	 1.	 Yes, there are many ways to exit Flash.
	 (i)	 Click on Exit from File menu 
	 (ii)	 Press Ctrl + Q keys 
	 2.	 Freehand lines and curves.
	 3.	 An Algorithm is a set of steps in a sequential and ordered manner to solve any problem.
	 4.	 Used to run your application.
	 5.	 Programming is generally used to mean writing various lines of instructions to develop a 

program that can work.
B.	 1.	 Properties panel allows you to set the properties of the objects that you have selected on 

the stage. It also provides options to change the settings of the Flash document such as 
stage dimensions and the animation’s frame rate.

	 2.	 Properties of a line are Stroke Color, Stroke Size, Stroke Style and Cap.
	 3.	 The main difference between Star and Polygon options is that the Star option creates a 

star and the Polygon option creates a polygon with specified number of sides.
	 4.	 The advantages of HLL are:
		  •	  High level language is user friendly.  
		  • � High level language is similar to English with vocabulary of words and symbols, therefore 

it is easier to run.
		  •  High level language requires less time to write.  
		  •  High level language is easier to maintain.
	 5.	 (a)	 The Button is the most commonly used control. It is used to start or stop a particular 

process. 
		  (b)	 A CheckBox is used when a choice has to be given to the user to select one or more 

options from the given list of options.
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C.	 1.	
Start

Stop

Read A, B, C

Print 
Sum and Prod

Sum = A + B + C

Prod = A * B * C

			   2.	

Yes

No

Start

Stop

Print 
count

Is
count < A

Read A
count = 1

count = count + 1




