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ANSWER KEY
Touchpad PRIME Ver 2.0

Class-6

	 Fundamentals of Computer

Rapid Fire

1.	 a.	 (i)	 b.	 (i)	 c.	 (ii)	 d.	 (iii)

2.	 a.	 F	 b.	 F	 c.	 T	 d.	 T	 e. F

Evaluation Time

1.	 a.	 Output Devices			   b.	 Storage Devices		  c.	 Input Devices
	 d.	 Application Software	 e.	 Disk Defragmenter

2.	 a.	 The hardware parts attached inside the CPU box are: Motherboard and CPU chip
	 b.	 CD-RW stands for Compact Disc Rewritable.
	 c.	 An operating system is a system software that works as a mediator between user and 

computer hardware.
	 d.	 Word Processors, Spreadsheet and Graphics are the types of general purpose software.
3.	 a.	 A computer accepts data and instructions from you through input devices. Data can be in 

the form of numbers, text, sound or graphics. The output devices are used to display the 
information and result of computation to the user.

	 b.	 CPU is the brain of the computer that does all the calculations and runs all the programs. It 
manages all the operations and carries out the basic instructions which operate a computer.

	 c.	 A port is a slot on the motherboard that is used to connect other components of the computer 
such as keyboard, mouse, monitor, etc. to the motherboard. Serial Port, Parallel Port and 
Audio Port are the three ports.

	 d.	 System software is the most important software to operate a computer. System software 
can be classified into three categories: Operating System, Programming Software and Utility 
Software.

	 e.	 (i) � Single user operating system allows only one user to access the computer system at a time. 
The most commonly used single-user operating systems are Palm computer and DOS.

		  (ii) �In Multi-user operating system, multiple users can use the computer at the same time. 
Examples of multi-user operating systems are Linux, Windows, etc.
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Activity Time

1.	 a.	 Graphic tablet.			   b.	 Plotters
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In The Lab

Do yourself.

	Advanced Windows

Rapid Fire

1.	 a.	 (i)	 b.	 (ii)	 c.	 (i)	 d.	 (i)
2.	 a.	 T	 b.	 T	 c.	 F	 d.	 T

Evaluation Time

1.	 a.	 Communications		  b.	 Programs	
	 c.	 Control Panel			   d.	 Disk Cleanup
2.	 a	  Buttons and Painters are the two tabs of the Mouse Properties Dialog Box.

	 b.	 The Disk Cleanup tool of Window 10 is used to search on the hard disk for files that can be 
deleted from your computer without affecting the computer’s functions or your personal files.

3.	 a.	 Steps to open the Control Panel window: 
		  Step 1: Click on the Start button. 
		  Step 2: Click on the Windows System → Control Panel option from the Start menu.
	 b.	 It deletes files like:
	 	 • Temporary internet files	 •	 Recycle Bin if it is not empty
	 	 • Windows temporary files

2.
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Activity Time

1.	 a.	 Mouse Settings			   b.	 Disk Cleanup
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Find Out

Do yourself.

In The Lab

Do yourself.

Periodic Assessment 1
(Based on chapters 1 & 2)

A.	 1.	 Word processors are used to edit and format text documents.
		  Example: MS Word. 
	 2.	 DBMS are used to create, store, sort and modify stored data.
		  Example: MS Access.
	 3.	 Spreadsheets are used to calculate, compare and analyse and prepare reports.
		  Example: MS Excel.
	 4.	 DTP software are used to create magazines, brochures, newspapers, etc.
		  Example: Corel Draw.
	 5.	� Presentation software are used to create presentation that contains animations, images, 

audio, etc.
		  Example: MS PowerPoint.
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B.	 1.	 Antivirus is an application software used to scan and delete viruses from a computer.
	 2.	 Disk defragmentor organises files in a continuous block in the memory.
	 3.	 Multi-user operating system is an Operating System.
	 4.	 Recording tab is available in the sound tab.
C.	 1.	 Demodulation			   2.	 Sound Card
	 3.	 Flatbed Scanner			  4.	 Plotter

	Advanced Features of PowerPoint 2016

Warm
Up! 	 1. (a)	 2. (a)

Rapid Fire

1.	 a.	 (iii)	 b.	 (i)	 c.	 (i)	 d.	 (i)	 e.	 (i)
2.	 a.	 F	 b.	 T	 c.	 F	 d.	 F

Evaluation Time

1.	 a.	 Audio on My PC			  b.	 Record
	 c.	 Media, Insert			   d.	 Action
2.	 a.	 If we select the Print All Slides option while printing, it will select all the slides in the 

presentation.
	 b.	 Action buttons are some built in shapes which you can add to your slides. This action happens 

when you either click an object or hover your mouse over in a slideshow.
	 c.	 Notes page is used to print slides with notes.
3.	 a.	 To insert a video file, follow the steps given below:
		  Step 1: Click on Video command under the Media group of the Insert tab.
		  Step 2: Click on the Online Video option. 
		  Step 3: Search your video on the website. 
		  Step 4: Click on the Insert button.
	 b.	 The printing options are:
		  i.  Print All slides      ii.  Print Selection      iii.  Print Current Slide

Activity Time

1.	 a.	 To insert recorded audio in a presentation, follow these steps:
		  Step 1: Click on the Audio option in the Media group.

3.
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		  Step 2: Click on the Record Audio option.
		  Step 3: Enter the name of your audio clip and click on the Record button to start recording. 
	 b.	 To insert a video file, follow the steps given below:
		  Step 1: Click on Video command under the Media group of the Insert tab. 
		  Step 2: Click on the Online Video option. 
		  Step 3: Search your video on the website.
		  Step 4: Click on the Insert button.
2.	 a.	 Record audio			   b.	 Online video			   c.	 Print Selection
	 d.	 Print Current Slide	 e.	 Action Buttons

Find Out

Do yourself.

In The Lab

Do yourself.

	More on Excel

Rapid Fire

1.	 a.	 (iv)	 b.	 (i)	 c.	 (iii)	 d.	 (i)
2.	 a.	 F	 b.	 T	 c.	 F	 d.	 T	 e.	 T

Evaluation Time

1.	 a.	 Insert			   b.	 Cell Styles
	 c.	 Reference			   d.	 Merge & Center
2.	 a.	 Yes, we can unmerge the merged cells. Name of command is Unmerged Cells.
	 b.	� Copy command is used to copy the data at the new place and also exists in its original place.
	 c.	 Wrap Text feature of Excel allows us to display multiple lines of text inside a cell.
3.	 a.	 Steps to wrap the text in a cell are:
	 	 Step 1: Click the cell in which you want to wrap the text.
	 	 Step 2: �Click on Wrap Text command from Alignment group under Home tab. The text in 

your cell will be wrapped.
	 b.	 To change row height and column width follow these steps:
	 	 Step 1: Select the column(s) or row(s) that you want to change.

4.
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	 	 Step 2: Click on Format command in Cells group from Home tab.
	 	 Step 3: Choose Column Width or Row Heights option.
	 	 Step 4: �In the Column Width or Row Height box, type the value that you want your column 

or row to be.
	 c.	 To apply cell border follow these steps: 
	 	 Step 1: �On a worksheet, select the cell or range of cells that you want to add a border to, 

change the border style on, or remove a border from. 
	 	 Step 2: Go to the Font group in the Home tab. 
	 	 Step 3: Click the arrow next to Borders command. 
	 	 Step 4: Click on the border style you would like.
	 d.	 Steps to rename worksheet tab are: 
	 	 Step 1: Right-click the sheet tab that you want to customise. 
	 	 Step 2: Click on Rename.
	 	 Step 3: Type the name. 

Activity Time

1.	 a.	 �By using the Wrap Text command present on the Alignment group in the Home tab, Sonia 
can make the text visible.

	 b.	 By inserting a column, Anaya can create space to enter the marks.
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In The Lab

Do yourself.
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Periodic Assessment 2
(Based on chapters 3 & 4)

A.		

Record Button

Play Button

Stop Button

 

B.	 a.	 It selects and inserts a video file from the Internet. Some websites such as YouTube allow 
us to insert a video in our slides. 

	 b.	 In Excel, the format of a cell is separate from the data that is stored in the cell. This display 
difference can have a significant effect when the data is numeric. Excel provides 10 different 
number formats which you can apply on the numeric values. It also allows you to create 
custom format.

	 c.	 MS Excel provides a feature called the cell styles. It is used to decorate a specific cell or a 
group of cells according to a predefined theme or according to the user.

	 d.	 Cell referencing refers to the use of a cell or a group of cells in a formula.
	 e.	 AutoFill feature automatically fills a series of data in your worksheet. It saves your time to 

complete the text or number series for you.

Test Sheet 1
(Based on chapters 1 to 4)

A.	 1.	 (iii)	 2.	 (iii)	 3.	 (i)	 4.	 (ii)
	 5.	 (i)	 6.	 (iii)	 7.	 (i)	 8.	 (i)
B.	 1.	 Output Devices			   2.	 Input Devices			   3.	 Communications
	 4.	 Control Panel			   5.	 Media, Insert			   6.	 Audio on My PC
	 7.	 Merge & Center
C.	 a.	 (iv)	 b.	 (iii)	 c.	 (i)	 d.	 (ii)	 e.	 (v)
D.	 1.	 F	 2.	 T	 3.	 F	 4.	 T	 5.	 T
E.	 1.	 Compact Disc-Read Only Memory 
	 2.	 Word Processors, Spreadsheet and Graphics 
	 3.	 The Disk Cleanup tool is used to search on the hard disk for files that can be deleted from 

your computer without affecting the computer’s functions or your personal files. 
	 4.	 Action buttons are some in built shapes which you can add to your slides. This action happens 

when you either click an object or hover your mouse over in a slideshow.
	 5.	 Yes, we can unmerge the merged cells. Name of command is Unmerged Cells.
	 6.	 Wrap Text feature of Excel allows us to display multiple lines of text inside a cell.



Touchpad PRIME (Version 2.0)-VI (Answer Key)8

F.	 1.	 (i)  �Single user operating system allows only one user can access the computer system at a 
time. The most commonly used single-user operating systems are Palm computer and 
DOS. 

		  (ii)  �Multi-user operating system: multiple users can use the computer at the same time. 
Examples of multi-user operating systems are Linux, Windows, etc.

	 2.	 It deletes files like: 
	 	 • Temporary internet files 
	 	 • Recycle Bin if it is not empty 
	 	 • Windows temporary files 
	 3.	 . To insert a video file, follow the steps given below: 
		  Step 1: Click on Video command under the Media group of the Insert tab.
		  Step 2: Click on the Online Video option.  
		  Step 3: Search your video on the website. 
	 4.	 Steps to rename worksheet tab are: 
		  Step 1: Right-click the sheet tab that you want to customise. 
		  Step 2: Click on Rename.
		  Step 3: Type the name. 
	 5.	 Steps to wrap the text in a cell are: 
		  Step 1: Click the cell in which you want to wrap the text.
		  Step 2: Click on Wrap Text command from Alignment group under Home tab. The text in 

your cell will be wrapped. 

	Formulas & Functions in Excel

Warm
Up! 	 1. 5	 2. Com	 3. 7

			   4. 4/01/2021	 5. 5	 6. 3

Rapid Fire

1.	 a.	 (i)	 b.	 (i)	 c.	 (ii)	 d.	 (iii)
2.	 a.	 F	 b.	 F	 c.	 F	 d.	 F	 e.	 T

Evaluation Time

1.	 a.	 Functions			   b.	 equal			   c.	 square root
	 d.	 Dollar ($)			   e.	 ABS ( )

5.
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2.	 a.	 A cell reference is a cell address that can be used in a formula to denote a specific cell.
	 b.	 Text Functions is used to perform number of operations on strings (i.e. a collection of 

characters like ‘hello’, ‘friend’, ‘computer’, etc.) such as finding the length of a string, joining 
two strings, searching for one string inside another etc.

	 c.		 Output: 7/23/2019
3.	 a.	 LEN function is used to return the length of the text string. For example: Input: =LEN(“Touch”)

Output: 5.
	 b.	 Rules to enter a function are:
		  1.	 All Excel functions must begin with = sign.
		  2.	 Function name must be a valid Excel name.
		  3.	 Function must be followed by opening and closing parenthesis.
		  4. 	Most of the functions must contain an argument within it.

Activity Time

1.	 Cell reference.

2.	 	

Find Out

Do yourself.

In The Lab

Do yourself.
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	Introduction to Animate CC

Warm
Up! 	 1.  Stroke			   2.  Fill.

Rapid Fire

1.	 a.	 (i)	 b.	 (iv)	 c.	 (ii)
2.	 a.	 T	 b.	 F	 c.	 T	 d.	 T

Evaluation Time

1.	 a.	 Animation	 b.	 HTML5	 c.	 Stage	 d.	 Lasso	 e.	 Lines
2.	 a.	 Properties Panel displays the different properties of the object which is selected. 
	 b.	 Gradient Fill is a combination of colours where one colour changes into another. 
	 c.	 There are three types of symbol in Animate CC: Movie Clip Symbol, Button Clip Symbol and 

Graphic Symbol. 
3.	 a.	 (i)  Selection tool is used to select objects on the stage for modification. 
		  (ii)  �Pen tool is used to draw lines and curves by creating a series of dots that are automatically 

connected. 
		  (iii) Free-transform tool is used to move, scale, rotate, skew, or distort objects. 
	 b.	 To create a symbol, perform the following steps: 
		  Step 1: �Click on the File → Open option from the menu bar. Select the desired file and click 

on the Open button. 
		  Step 2: Select the Rectangle Tool from the Tools panel. 
		  Step 3: Use the Stroke Color and Fill Color in the Properties panel to select the required 

outline and fill color from the color picker for the object. 
		  Step 4: Click on the drawing mode in the Tools panel to select the Object Drawing mode. 
		  Step 5: On the stage, draw a rectangle, holding down the left mouse button. 
		  Step 6: Click on the Selection Tool in Tools panel. 

Activity Time

1.	 a.	 Outside the stage 	 b.	 Sub – Select 

6.
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2.	 	

Find Out

Do yourself.

In The Lab

Do yourself.

Periodic Assessment 3
(Based on chapters 5 & 6)

A.	 1.	 Selection Tool			   2.	 Hand Tool			   3.	 Rectangle Tool
	 4.	 Line Tool			   5.	 Eraser Tool			   6.	 Pencil Tool
	 7.	 Polystar Tool 
B.	 Do yourself
C.	 1.	 12	 2.	 78.4	 3.	 My India	 4.	 India	 5.	 “Current date”

L
N

M
E

D

A O

L

M E

P

F

L

L

B

C

B

T

P

NI IE

O F

L S

E

O

W

R

A

S

T

O

E

E

DA

A

E

1 2 3

4

7

6
5



Touchpad PRIME (Version 2.0)-VI (Answer Key)12

	�Problem Solving and Programming Languages

Warm
Up! 	 1.  Basic			  2.  Pascal		  3.  C

Rapid Fire

1.	 a.	 (iii)	 b.	 (ii)	 c.	 (ii)	 d.	 (ii)	 e.	 (i)	 f.	 (ii)
2.	 a.	 F	 b.	 T	 c.	 F	 d.	 T	 e.	 T

Evaluation Time

1.	 a.	 Algorithm			   b.	 Connectors			   c.	 Consistent
	 d.	 Instructions			   e.	 Assembler
2.	 a.		 An Algorithm is a set of steps in a sequential and ordered manner to solve any problem.
	 b.	 A flowchart is a type of diagram that represents an algorithm.
	 c.	 An assembler is a program used to translate assembly language into machine language.
	 d.	 BASIC and PASCAL
	 e.	 A computer language is the medium by which instructions are transmitted to the computer 

to perform a specific task.
3.	 a.	 The main difference between HLL and LLL is that the LLL is machine dependent and HLL is 

machine independent.
	 b.	 The advantages of HLL are:
		  	 High level language is user friendly.
		  	� High level language is similar to English with vocabulary of words and symbols, therefore 

it is easier to run.
		  	 High level language requires less time to write.
		  	 High level language is easier to maintain.
	 c.	 Process symbol: It is used to show a process or action step. This is the most common symbol 

used in flowcharts.
		  Input/Output: It is used to represent the material or information entering or leaving the 

system, i.e., input and output.

7.



13Touchpad PRIME (Version 2.0)-VI (Answer Key)

Activity Time
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2.	 a.	 (i)  Input/Output		  (ii)	 Process	 (iii)	 Input/Output
	 b.	 Richa should make an algorithm before drawing a flowchart.

Find Out

Do yourself.

In The Lab

Do yourself.

	Introduction to Small Basic

Warm
Up! 	   9Name

Rapid Fire

1.	 a.	 (ii)	 b.	 (iii)	 c.	 (ii)	 d.	 (iii)
2.	 a.	 T	 b.	 T	 c.	 T	 d.	 T

8.
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Evaluation Time

1.	 a.	 Small Basic	 b.	 Intellisense	 c.	 Relational	 d.	 Read()
2.	 a.		 A variable is used to store different kinds of information, such as text or a number, in the 

computer’s memory. 
	 b.	 Relational operators are used to compare the values of two operands and returns Boolean 

true or false accordingly.
	 c.	 Small Toolbar is a component of Small Basic environment. It is used to give commands like 

New, Open, Save, Save As, Cut, Copy, Paste and Run.
3.	 a.	 @Tushar and & Cost are invalid variable names because a variable name must start with a 

letter or underscore. 
	 b.	 Some of the Math library function in Small Basic are:
		  (i)	 Math.Abs(number): This function returns the absolute value of a given number.
		  (ii)	� Math.Ceiling(number): It rounds up the integer value and returns the integer that is 

greater than or equal to the argument. 
		  (iii)	� Math.Floor(number): It round up the integer value and returns the integer that is less 

than or equal to the argument.

Activity Time

	 a.	 243	 b.	 2.87	 c.	 2.87	 d.	 8-5.7

Find Out

Do yourself.

In The Lab

Do yourself.

	Internet

Warm
Up! 	 1.  Advanced Research Project Agency Network

	 		  2.  World Wide Web	 3.  Uniform Resource Locator

Rapid Fire

1.	 a.	 (i)	 b.	 (iii)	 c.	 (iv)	 d.	 (D)	 e.	 (d)
2.	 a.	 F	 b.	 F	 c.	 F	 d.	 T

9.
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Evaluation Time

1.	 a.	 E-mail			   b.	 ARPANET
	 c.	 Web document			   d.	 Website
2.	 a.	 The Internet is a computer network that connects hosts and end systems throughout the 

world. 
	 b.	 Online Education has enhanced the teaching and learning process by making education 

very friendly and interesting. Education on the Internet is also called e-learning. 
	 c.	 E-mail stands for electronic mail. You can send messages and files from your computer to 

your friend’s computer and vice-versa using e-mail service. 
3.	 a.	 The World Wide Web (www) is a large information system where you can surf and get 

information. Web is a service (a system for accessing information) that is supported by the 
Internet, a system of interconnected networks. 

		  A Web page is a hypertext document. A collection of related web pages is called a website. 
Websites are housed on Web servers. A Web server is an Internet host computer that often 
stores thousands of individual Web pages. 

	 b.	 An e-greeting is just like a paper greeting card. The only difference is that it is created 
with the help of digital text and effects. Some of the popular e-greetings websites are 
www.123greetings.com, www.egreetings.com, www.e-cards.com, etc. 

Activity Time

1.	 a.	 E-greeting	 b.	 E-mail

2.	 	

Find Out   Do yourself.

In The Lab   Do yourself. 
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Periodic Assessment 4
(Based on chapters 7 to 9)

A.	

Calculate 
SI = (P * r * t)/100

Start

Stop

Read P, r, t

Print SI

	

B.	 Step 1: Start.

	 Step 2: Read three numbers.

	 Step 3: Add first two numbers.

	 Step 4: Multiply the sum of two numbers with the third number.

	 Step 5: Display the result.

	 Step 6: Stop.

C.	 1.	 654.564	 2.	 32	 3.	 89	 4.	 65847

	 5.	 41.0	 6.	 43
D.	 1.	 A Web browser is a software application designed to find hypertext documents on the Web 

and then open the documents on the user’s computer. Commonly used web browsers are 
Google Chrome, Internet Explorer, Microsoft Edge, Mozilla Firefox, etc.

	 2.	 Every Web page has a unique address, called a Uniform Resource Locator, or URL. URLs help 
you to navigate the web. When you provide a URL to the browser, the browser finds that 
URL’s Web page and then transfers the Web page to yout PC.
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Test Sheet 2
(Based on chapters 7 to 9)

A.	 1.	 (iii)	 2.	 (ii)	 3.	 (ii)	 4.	 (ii)
	 5.	 (iii)	 6.	 (i)	 7.	 (iv)	 8.	 (iv)
B.	 1.	 algorithm			   2.	 assembler			   3.	 relational
	 4.	 intellisense			   5.	 webpage			   6.	 E-mail
C.	 1.	 F	 2.	 F	 3.	 F	 4.	 T	 5.	 T	 6.	 T
D.	 1.	 An Algorithm is a set of steps in a sequential and ordered manner to solve any problem.
	 2.	 A flowchart is a type of diagram that represents an algorithm.
	 3.	 A variable is used to store different kinds of information, such as text or a number, in the 

computer’s memory. 
	 4.	 Relational operators are used to compare the values of two operands and returns Boolean 

true or false accordingly.
	 5.	 The Internet is a computer network that connects hosts and end systems throughout the 

world.
	 6.	 Online Education has enhanced the teaching and learning process by making education 

very friendly and interesting. Education on the Internet is also called e-learning. 
E.	 1.	 The main difference between HLL and LLL is that the LLL is machine dependent and HLL is 

machine independent.
	 2.	 The advantages of HLL are:
		  	 High level language is user friendly.
		  	� High level language is similar to English with vocabulary of words and symbols, therefore 

it is easier to run.
		  	 High level language requires less time to write.
		  	 High level language is easier to maintain.
	 3.	  @Tushar and & Cost are invalid variable names because a variable name must start with a 

letter or underscore. 
	 4.	 An e-greeting is just like a paper greeting card. The only difference is that it is created 

with the help of digital text and effects. Some of the popular e-greetings websites are 
www.123greetings.com, www.egreetings.com, www.e-cards.com, etc. 




