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	Classification of Computers

Let’s Plug-in

1.          2.          3. 

                 ENIAC                                      MARK - 1                               UNIVAC

Let’s Catch Up

Analog Computer, Digital Computer and Hybrid Computer.

Test Your Skills

1.	 a. (i)	 b. (iii)	 c. (iv)	 d. (ii)	 e. (iv)

2.	 a. F	 b. T	 c. F	 d. T	 e. T

3.	 a. Microcomputer 	 b. Laptop	 c. Gaming	 d. High	 e. PARAM

4.	 �a.	A minicomputer contains one or more microprocessors as its processing unit. This type of 
computer is mainly used for scientific and engineering computations.

	 b.	An embedded computer is a special type of microprocessor based system. This type of 
computer is mainly used for performing a specific task. 

	 c.	Supercomputers are the largest and fastest of all types of computers. They can process a 
very large amount of data quickly.

	 d.	ATM stands for Automated Teller Machine. 

5.	 a.	A microcomputer is a type of computer that has one microprocessor as its processing unit. It 
is a small and less expensive digital computer. This type of computer is made to be used by 
a single user at a time. Some examples of microcomputers are Laptops, Desktop computers 
and Tablet computers. 

	 b.	A handheld computer is a type of computer that can easily be stored in our pocket and 
used by holding it in our hands. Most of the handheld computers have a touchscreen in 
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which we input data by using our fingers. Some of the examples of handheld computers are 
smartphones, PDA and Smartwatches. 

	 c.	Digital Computer refers to a computer that uses digits (binary numbers 0’s and 1’s) to generate, 
process and display data. The results produced by digital computers are more accurate than 
that of analog computers. All the modern computers that we use like Desktop, Laptop, and 
smartphone are examples of digital computers.

	 d.	 i.	 The microwave that we use at our home to warm and cook food is an example of 
embedded computer. It has a computer system embedded into it to control the time 
and the temperature.

		  ii.	 ATM (Automated Teller Machine) is a type of embedded computer. It allows the user 
to withdraw money from their bank account from anywhere in the world. 

		  iii.	 PDA (Personal Digital Assistant) is a handheld computer that has a touchscreen and 
allows to organize our daily routine. It also has a pen like stylus which allows us to give 
input.

		  iv.	 Gaming console is a computing device specially designed to play video games. We 
can connect the gaming console with television to play games on television. Some 
commonly used examples are Sony PlayStation and Nintendo. 

		  v.	 Desktop is a personal computer placed at a single place on a desk or table. All its 
components such as keyboard, mouse and storage devices are connected through wire 
or wireless. 

	 e.	 i.	 Supercomputers are the largest and fastest of all types of computers. The cost of 
supercomputer is very high. They are used in very big organisations and government 
departments to do tasks such as weather forecasting and rocket launching. Some 
examples of supercomputers are PACE, Titan, Sunway TaihuLight, Pratyush, Mihir, etc. 
Whereas, a minicomputer is small, slow and less expensive than supercomputers. They 
are used for scientific and engineering computations. Some examples of minicomputers 
are PDP-11, PDP-8, HP-3000, etc.

		  ii.	 Laptop is a portable computer that is suitable for use while travelling. We can use a 
laptop computer by keeping it on our lap. A laptop computer has a built-in mouse, a 
monitor and a keyboard. Whereas, tablet is a portable computer smaller than the laptop 
computer. We can use a tablet by keeping it in our hands. It has a touchscreen as its 
primary input device instead of mouse. A tablet generally provides less features than a 
laptop computer.

Fun Zone

Let's Solve

1.	 a. Laptop		  b. Microwave
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Let’s Explore

Do it yourself.

	Basic Concepts of Programming

Let’s Plug-in

ALERT MAJOR CYCLONE 

Let’s Catch Up

BASIC, PASCAL and C

Test Your Skills

1.	 a.  (iii)	 b.  (ii)	 c.  (ii)	 d.  (ii)	 e.  (i)
2.	 a.  F	 b.  T	 c.  F	 d.  F	 e.  T
3.	 a.  Algorithm	 b.  Connectors	 c.  Consistent	 d.  Instructions 
	 e.  Assembler

2.
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4.	 a.	 An Algorithm is a set of steps in a sequential and ordered manner to solve any problem.
	 b.	A flowchart is a type of graphical diagram that represents an algorithm.
	 c.	 An assembler is a program used to translate assembly language into machine language.
	 d.	BASIC and PASCAL
	 e.	A computer language is the medium by which instructions are transmitted to the computer 

to perform a specific task.
5.	 a.	 The main difference between HLL and LLL are:
		  1.  LLL is machine dependent and HLL is machine independent.
		  2.  The types of LLL are 1GL and 2GL. The types of HLL are 3GL, 4GL and 5GL.
	 b.	The advantages of HLL are:
	 	 	 High level language is user friendly.
	 	 	 High level language is similar to English with vocabulary of words and symbols, therefore 

it is easier to run.
	 	 	 High level language requires less time to write.
	 	 	 High level language is easier to maintain.
	 c.	 Process symbol: It is used to show a process or action step. This is the most common symbol 

used in flowcharts.
		  Input/Output: It is used to represent the material or information entering or leaving the 

system, i.e., input and output.

Fun Zone

Let's Solve

1.	 a.	 (i)  Input		  (ii)  Process	 (iii)  Input

	 b.	 Richa should make an algorithm before drawing a flowchart.
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Let’s Explore

Do it yourself.

Periodic Assessment–1
(Based on chapters 1 & 2)

A.	 1.  Analog	 2.  Digital	 3.  Handheld	 4.  Handheld
B.	 1.  Start/Stop	 2.  Process	 3.  Decision	 4.  Input/Output
C.	

End

Print
“Not Prime”

Print
“Prime”

Next

Start

Read N

For i = 1 to 5

(N% i = 0)?

Check = 0 Check = 1

Check ==1?

	

	Advanced Features of PowerPoint 2016

Let’s Plug-in

1. T		  2.  T	 3.  F	 4.  F

3.
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Let’s Catch Up

1. a	 	 2. a

Test Your Skills

1.	 a. (iii)	 b.  (i)	 c.  (ii)	 d.  (iii)	 e.  (i)
2.	 a.  Audio on my PC		  b.  Record 
	 c.  Media, Insert 		  d.  Action 
3.	 a.  F	 b.  T	 c.  F	 d.  F
4.	 a.	 If we select the Print All Slides option while printing, it will print all the slides in the presentation.
	 b.	 Action buttons are some built in shapes which you can add to your slides. This action happens 

when you either click an object or hover your mouse over in a slideshow. It can open a web 
page, an e-mail, a linked file, slide in presentation, etc.

	 c.	 Notes Page View is one of the presentation views available in Powerpoint. This view shows 
how your printed notes will appear. It also shows the speaker notes that you add to the 
Notes pane for each slide.

5.	 a.	 To insert a video file, follow the steps given below:
	 	 Step 1: Click on Video command under the Media group of the Insert tab.
		  Step 2: Click on the Online Video option.
		  Step 3: Search your video on the website. 
		  Step 4: Click on the Insert button.
	 b.	 The printing options are:
		  i.  Print All slides      ii.  Print Selection      iii.  Print Current Slide

Fun Zone

Let's Solve

1.	 a.	 To insert recorded audio in a presentation, follow these steps:
		  Step 1: Click on the Audio command in the Media group.
		  Step 2: Click on the Record Audio option.
		  Step 3: Enter the name of your audio clip and click on the Record button to start recording. 
		  Step 4: Click on the OK button.
	 b.	 To insert a video file, follow these steps:
		  Step 1: Click on Video command under the Media group of the Insert tab.
		  Step 2: Click on the Online Video option.
		  Step 3: Search your video on the website.
		  Step 4: Click on the Insert button.
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2.	 a.  Record Audio	 b.  Online Video	 c.  Print Selection
	 d.  Print Current Slide 	 e.  Action Button

Let’s Explore

Do it yourself.

	More on Excel 2016

Let’s Plug-in

1.	 4 rows and 4 columns	 2.  300	 3.  109	 4.  B4 & C3
5.	 D4

Let’s Catch Up

1.	 T	 2.  T	 3. F

Test Your Skills
 

1.	 a. (iv)	 b.  (iii)	 c.  (i)	 d.  (ii)	 e.  (i)

2.	 a. F	 b.  T	 c.  F	 d.  T	 e.  T

3.	 a. Insert	 b.  Cell Styles	 c.  Select All	 d.  Merge & Center	 e.  Operators

4.	 a.	 Yes, we can unmerge the merged cells. Name of command is Unmerge Cells.

	 b.	Copy command is used to copy the data at the new place while the data also exists at its 
original place.

	 c.	 Wrap Text feature of Excel allows us to display multiple lines of text inside a cell.

5.	 a.	 Steps to wrap the text in a cell:

		  Step 1: Click the cell in which you want to wrap the text.

		  Step 2: Click on Wrap Text command from Alignment group under Home tab. The text in 
your cell will be wrapped.

	 b.	To change row height and column width follow these steps:
		  Step 1: Select the column(s) or row(s) whose width or height you want to change.
		  Step 2: Click on Format command in Cells group from Home tab.
		  Step 3: Choose Column Width or Row Heights under Cell size.
		  Step 4: In the Column Width or Row Height box, type the value that you want your column 

or row to be.

4.
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	 c.	 To apply cell border follow these steps: 
		  Step 1: On a worksheet, select the cell or range of cells that you want to add a border to, 

change the border style on, or remove a border from. 
		  Step 2: Go to the Font group in the Home tab. 
		  Step 3: Click the arrow next to Borders command. 
		  Step 4: Click on the border style we would like.

Fun Zone

Let's Solve
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2.	 a.	  By using the Wrap Text command present on the Alignment group in the Home tab, Sonia 
can make the text visible.

	 b.	By inserting a column, Anaya can create space to enter the marks.

Let’s Explore

Do it yourself.

	Formulas and Functions in Excel 2016

Let’s Plug-in

90

5.
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Let’s Catch Up

1.	 5	 2.  Comp	 3.  7	 4.  4/01/2021
5.	 5	 6.  3

Test Your Skills

1.	 a.  (i)	 b.  (i)	 c.  (ii)	 d.  (iii)	 e.  (iv)
2.	 a.  F	 b.  F	 c.  F	 d.  F	 e.  T
3.	 a. Functions	 b.  Equal	 c.  square root	 d.  dollar ($)	 e.  MIN ()
4.	 a.	 A cell reference is a cell address that can be used in a formula to denote a specific cell.
	 b.	TODAY() AND NOW()
	 c.	 Relative cell referencing refers to a cell that is above or below and left or right to a number 

of rows or columns.
	 d.	It is used to return the sum of a range.
5.	 a.	 It calculates the square root or absolute value of a number, product of numbers, etc.
		  The names of two Mathematical functions are Sum(range) and Product (range).
	 b.	Len function is used to return the length of the text string. For example: Input: =LEN(“Touch”)

Output: 5
	 c.	 There are mainly two ways to enter a formula in a worksheet:
		  1.	 Typing the formula directly in the Cell: After typing an equal sign, enter the formula in 

the cell and press the Enter key. Result of the formula will appear in the cell.
		  2.	 Typing the formula in the Formula bar: After selecting the cell, type the formula in the 

formula bar starting with equal sign and then press the Enter key.
	 d.	Rules to enter a function:
		  1.	 All Excel functions must begin with = sign.
		  2.	 Function name must be a valid Excel name.
		  3.	 Function must be followed by opening and closing parenthesis.
		  4.	 Most of the functions must contain an argument within it.
6.	 a.	 SQRT: It returns the square root of the given number.
	 b.	DAY: It returns the current day.
	 c.	 MOD: It returns the remainder after a number is divided by the divisor.
	 d.	INT: It rounds number to an integer value.
	 e.	MIN: It returns the smallest value in the given range.

Fun Zone

Let's Solve

1.	 Cell Reference
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C.	 1.  flow lines , arrows	 2.  instructions	 3.  Select All
	 4.  Audio on My PC	 5.  Desktop	 6.  programming	 7.  consistent
D.	 1.  (c)	 2.  (a)	 3.  (b)	 4.  (d)
E.	 1.	 Audio Command.
	 2.	 Full Page Slides.
	 3.	 Step 1:  Select the merged cell you want to split.
		  Step 2:  Click on the arrow of the Merge & Center command in the Alignment group on 

Home tab.
		  Step 3:  Select the Unmerge Cells option.
	 4.	 An Algorithm is a set of steps in a sequential and ordered manner to solve any problem.
	 5.	� Flowchart is a graphical representation of the sequence of operations in an information 

system or program.
	 6.	 Online Video option from the Video Command.
F.	 1.	 To insert an audio file, follow the steps given below: 
		  Step 1:  Click on Audio command under the Media group of the Insert tab.
		  Step 2:  Click on Audio on My PC.
		  Step 3:  Click on Stop, Play or Record button.
		  Step 4:  Click on Audio icon.
	 2.	 	Len function is used to return the length of the text string.
		  For example: Input: =LEN(“Touch”)Output: 5
	 3.	 To insert sound, follow the steps given below:
	 	 Step 1:  Click on Audio command under the Media group of the Insert tab.
	 	 Step 2:  Click on Audio on My PC.
	 	 Step 3:  Click on Stop, Play or Record button.
	 	 Step 4:  Click on Audio icon.
	 4.	 Action buttons are some built in shapes which we can add to our slides. This action happens 

when we either click an object or hover our mouse over in a slideshow.
		  Clicking an action button can open a webpage, an e-mail, a linked file, another slide in the 

same presentation or a slide in a different presentation.

	 Introduction to Small Basic

Let’s Plug-in

Net Beans, Visual Basic, BlueJ, etc.

Let’s Catch Up

9Name                abc_def                _jkh                Address

6.
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Let’s Explore

Do it yourself.

Periodic Assessment–2
(Based on chapters 3 to 5)

A.	 1.  Merge Cells	 2.  Format	 3.  Functions	 4.  Logical Function
	 5.  Concatenate
B.	 Do it yourself.

C.	 1.  		 Video

	 2.  		 Audio

	 3.  		 Screen Recording

Test Sheet–1
(Based on chapters 1 to 5)

A.	 1.  (iv)	 2.  (iii)	 3.  (ii)	 4.  (ii)	 5.  (i)
	 6.  (i)	 7.  (iv)	 8.  (i)
B.	 1.  F	 2.  F	 3.  F	 4.  F	 5.  T
	 6.  F	 7.  F	 8.  F



11Touchpad PLUS (Version 2.0)-VI (Answer Key)

C.	 1.  flow lines , arrows	 2.  instructions	 3.  Select All
	 4.  Audio on My PC	 5.  Desktop	 6.  programming	 7.  consistent
D.	 1.  (c)	 2.  (a)	 3.  (b)	 4.  (d)
E.	 1.	 Audio Command.
	 2.	 Full Page Slides.
	 3.	 Step 1:  Select the merged cell you want to split.
		  Step 2:  Click on the arrow of the Merge & Center command in the Alignment group on 

Home tab.
		  Step 3:  Select the Unmerge Cells option.
	 4.	 An Algorithm is a set of steps in a sequential and ordered manner to solve any problem.
	 5.	� Flowchart is a graphical representation of the sequence of operations in an information 

system or program.
	 6.	 Online Video option from the Video Command.
F.	 1.	 To insert an audio file, follow the steps given below: 
		  Step 1:  Click on Audio command under the Media group of the Insert tab.
		  Step 2:  Click on Audio on My PC.
		  Step 3:  Click on Stop, Play or Record button.
		  Step 4:  Click on Audio icon.
	 2.	 	Len function is used to return the length of the text string.
		  For example: Input: =LEN(“Touch”)Output: 5
	 3.	 To insert sound, follow the steps given below:
	 	 Step 1:  Click on Audio command under the Media group of the Insert tab.
	 	 Step 2:  Click on Audio on My PC.
	 	 Step 3:  Click on Stop, Play or Record button.
	 	 Step 4:  Click on Audio icon.
	 4.	 Action buttons are some built in shapes which we can add to our slides. This action happens 

when we either click an object or hover our mouse over in a slideshow.
		  Clicking an action button can open a webpage, an e-mail, a linked file, another slide in the 

same presentation or a slide in a different presentation.

	 Introduction to Small Basic

Let’s Plug-in

Net Beans, Visual Basic, BlueJ, etc.

Let’s Catch Up

9Name                abc_def                _jkh                Address

6.
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Test Your Skills

1.	 a.  ii	 b.  iii	 c.  ii	 d.  iii
2.	 a.  Small Basic 	 b.  Intellisense	 c.  Relational 	 d.  Read()
3.	 a.  T	 b.  F	 c.  F	 d.  T
4.	 a.	 A variable is used to store different kinds of information, such as text or a number, in the 

computer’s memory. 
	 b.	Relational operators are used to compare the values of two operands and return Boolean 

true or false accordingly. Example: Equal operator(=) checks if the values of two operands 
are equal or not. If yes, then the condition becomes true. e.g:

				   x=8 and y=6
				   x=y
				   OUTPUT: FALSE
	 c.	 Toolbar is a component of Small Basic environment. It is used to give commands like New, 

Open, Save, Save As, Cut, Copy, Paste and Run.
5	 a.	 @Tushar and &Cost are invalid variable names because a variable name must start with a 

letter or underscore. 
		  b.	 Some of the Math library functions in Small Basic are:
			   (i)	 Math.Abs(number): This function returns the absolute value of a given number.
			   (ii)	 Math.Ceiling(number): It rounds up the integer value and returns the integer that is 

greater than or equal to the argument. 
			   (iii)	 Math.Floor(number): It rounds down the integer value and returns the largest integer 

that is less than or equal to the argument.

Fun Zone

Let's Solve

1.	 243	 2.  2.87	 3.  2.87	 4.  8-5.7
Let’s Explore

Do it yourself.

Tech Practice

1.	 Area = 3.14*5*5
	 TextWindow.WriteLine(Area)
2.	 n = 56
	 m = 78
	 Add = n+m
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	 TextWindow.WriteLine(Add)
	 Subtract = m-n
	 TextWindow.WriteLine(Subtract)
	 Multiply = n*m
	 TextWindow.WriteLine(Multiply)
	 Division = m/n
	 TextWindow.WriteLine(Division)
3.	 TextWindow.WriteLine(“Enter the number: “)
	 a = TextWindow.ReadNumber()
	 b = Math.SquareRoot(a)
	 TextWindow.WriteLine(“The square root of “+a” is “+b)
4.	 TextWindow.WriteLine(“Enter the breadth of the rectangle: “)
	 B = TextWindow.ReadNumber()
	 TextWindow.WriteLine(“Enter the length of the rectangle: “)
	 L = TextWindow.ReadNumber()
	 Perimeter=2*(L+B)
	 TextWindow.WriteLine(“The Perimeter of the rectangle is: “+Perimeter)

	Control Statements in Small Basic

Let’s Plug-in

	 1.  27	 2.  7	 3.  50	 4.  2	 5.  28
	 6.  27.963

Let’s Catch Up

	 TextWindow.WriteLine(“Enter a number”)
	 i=TextWindow.ReadNumber()
	 If (i<21) Then
	 TextWindow.Writeline(i)
	 EndIf

Test Your Skills

1.	 a.  (i)	 b.  (i)	 c.  (i)	 d.  (ii)	 e.	 (i)
2.	 a.   Nested if	 b.  branching	 c.  Goto	 d.  Decision making
3.	 a.  T	 b.  F	 c.  T	 d.  F	 e.  F

7.
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4.	 a.	 The three formats of If statements in Small Basic are:
		  i.	 If-Then
				   If <condition> Then
				   Statements to be executed
				   EndIf
		  ii.	 If-Then-Else
				   IF <condition> THEN
				   Statements to be executed
				   ELSE
				   Statements to be executed
				   ENDIF
	 iii.			 Nested If and If-Else
				   IF <condition1> THEN
				   Statement to be executed
				   ELSEIF <condition2> THEN
				   Statement to be executed
				   ELSEIF <conditon3> THEN
				   Statement to be executed
				   ENDIF
	 b.	The syntax for if-Then statement is as follows:
		  IF <condition> THEN
		  Statements to be executed
		  ENDIF
		  The syntax for If-then-Else statement is as follows:
		  IF <condition> THEN
		  Statements to be executed
		  ELSE
		  Statements to be executed
		  ENDIF
	 c.	 Goto statement is used to change the flow of program by letting the control to branch to a 

statement that appears earlier or later in the program.
	 d.	In If-Then, statement(s) within the if block is executed only if specified condition evaluates 

to true. If the condition evaluates to false, then the control of execution is passed to the last 
statement, outside the if block. Whereas in the If-then-else, if condition evaluates to true, 
the indented statements following the if statements are executed, otherwise the indented 
statements following the else statement are executed.
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5.	 a.	

YesNo
Is 

condition 
true

Execute 
commands in 

the If block

Execute 
commands in 
the Else block

	 b.	The branching statements allow the flow of execution to jump to a different part of the 
program. The common branching statements used within other control structure are Goto 
and Goto with Else statement.

		  Example: 

	 c.	 TextWindow.WriteLine(“Enter the number: “)
		  n = TextWindow.ReadNumber()
		   t1 = 0
		   t2 = 1
		   nextTerm = 0
		   nextTerm = t1 + t2
		   TextWindow.Write(t1+” “)
		   TextWindow.Write(t2+” “)
		   While(a < n-2)    
		     Textwindow.Write(nextTerm+” “)
		      t1 = t2
		      t2 = nextTerm
		      nextTerm = t1 + t2
		      a = a + 1
		    EndWhile

Fun Zone

Let's Solve

	 1.	 You are old 		  2. Nothing will print		  3. Three digit number 



Touchpad PLUS (Version 2.0)-VI (Answer Key)16

Let’s Explore

Do it yourself.

Tech Practice

	 1.	 TextWindow.WriteLine(“Enter the number: “)
		  a = TextWindow.ReadNumber()
		  If a < 0 Then
		    TextWindow.WriteLine(“Negative number”)
		  ElseIf a > 0 Then
		    TextWindow.WriteLine(“Positive number”)
		  EndIf
	 2.	 TextWindow.Write( “Enter a year: “)
		  year = TextWindow.ReadNumber()
		     If ( Math.Remainder( year,4) <> 0 ) Then  
		       TextWindow.WriteLine(year + “ is not a leap year.”)
		     Else        
		  If ( Math.Remainder( year,100) <> 0 ) Then 
		        TextWindow.WriteLine( year + “ is a leap year.”)
		      Else  
		       If ( Math.Remainder( year,400) = 0 ) Then 
		         TextWindow.WriteLine( year + “ is a leap year.”)
     Else   
       TextWindow.WriteLine( year + “ is not a leap year.”)
		       EndIf
		      EndIf  
		  EndIf

	 3.	 TextWindow.WriteLine(“Enter the First number: “)
		  a = TextWindow.ReadNumber()
		  TextWindow.WriteLine(“Enter the Second number: “)
		  b = TextWindow.ReadNumber()
		  If a > b Then
		    TextWindow.WriteLine(a+” is greater than “+b)
		  ElseIf a < b Then
		    TextWindow.WriteLine(a+” is less than “+b)
		  EndIf

	 4.	 Age  = 0
		  Marks = 0
		  TextWindow.WriteLine(“Enter your age: “)
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		  Age = TextWindow.ReadNumber()
		  TextWindow.WriteLine(“Enter your Marks in % (Rounded off): “)
		  Marks = TextWindow.ReadNumber()
		  If Age > 18 And Marks > 65 Then
		    TextWindow.WriteLine(“Student is eligible to take admission in college.”)
		  ElseIf Age < 18 Then
		    TextWindow.WriteLine(“Student is underage”)
		  Elseif Marks < 65 Then
		    TextWindow.WriteLine(“Student is not qualified”)
		  EndIf 

Periodic Assessment–3
(Based on chapters 6 & 7)

A.	 1.	(A > 0)
	 	 The variable ‘A’ is not assigned.
	 2.	(A > 0)
	 	 The variable ‘A’ is not assigned.
B.	 1.  654.564	 2.  33	 3.  89	 4  65847	 5.  3
	 6.  43
C.	 TextWindow.WriteLine(“Enter Length”)
	 L=TextWindow.ReadNumber()
	 TextWindow.WriteLine(“Enter Breadth”)
	 B=TextWindow.ReadNumber()
	 Area=L*B
	 TextWindow.WriteLine(“Area of rectangle is “+Area)
D.	 TextWindow.WriteLine(“Enter distance in mile or miles”)
	 Mile=TextWindow.ReadNumber()
	 Km=Mile*1.6
	 TextWindow.Writeline(“Value in kilometres or kilometre is “+Km+” Km”)

	 Introduction to Animate CC

Let’s Plug-in

Do it yourself.

Let’s Catch Up

Fill refers to the inside of the object. 

8.
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Test Your Skills

1.	 a.  (i)	 b.  (iv)	 c.  (ii)
2.	 a.  Animation	 b.  HTML5	 c.  Stage 	 d.  Lasso	 e.  Lines
3.	 a.	 Properties Panel displays the different properties of the object, which is selected.
	 b.	 Gradient Fill is a combination of colours where one colour changes into another.
	 c.	 There are three types of symbol in Animate CC: Movie Clip Symbol, Button Clip Symbol and 

Graphic Symbol. 
4.	 a.	 i.  Selection tool is used to select objects on the stage for modification. 
		  ii.  Pen tool is used to draw lines and curves by creating a series of dots that are automatically 

connected.
		  iii.  Free-transform tool is used to move, scale, rotate, skew, or distort objects.
	 b.	 To create a symbol, perform the following steps:
		  Step 1: Click on the File → Open option from the menu bar. Select the desired file and click 

on the Open button.
		  Step 2: Select the Rectangle Tool from the Tools panel.
		  Step 3: Use the Stroke Color and Fill Color in the Properties panel to select the required 

outline and fill color from the color picker for the object.
		  Step 4: Click on the drawing mode in the Tools panel to select the Object Drawing mode.
		  Step 5: On the stage, draw a rectangle holding down the left mouse button.
		  Step 6: Click on the Selection Tool in Tools panel.

Fun Zone

Let's Solve

	 1.	 a.  Outside the stage 	 b.  Sub – Select

	 2.	
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Let’s Explore

Do it yourself.

	 Introduction to HTML

Let’s Plug-in

1.	 Homepage 	 2.  Website	 3.  Hyperlink	 4.  URL

Let’s Catch Up

1.	 F	 2.  F	 3.  T	 4.  T	 5.  T

Test Your Skills

1.	 a.  (i)	 b.  (ii)	 c.  (i)	 d.  (ii)
2.	 a.  Markup	 b.  Head	 c.  Block level	 d.  Empty	 e.  Nesting 
3.	 a.	 HTML stands for Hypertext Markup Language. It is a markup language that describes the 

structure of the web page.
	 b.	 The tags that include both opening and closing tags are called Container Tags.
	 c.	 The <HTML> tag tells the web browser that the text contained between <html > and  

</html> is a web page and can be viewed using a web browser. Every web page coding 
must start with the <html > tag and ends with the </html > tag.

	 d.	 The <Head> tag defines header area of your web page. The information given in <Head > 
tag tells the computer that this information is not to be shown on the web page.

4.	 a.	 The rules for writing HTML tags are:
		    Container tags should always be closed properly.
		    Values given to the attributes should be enclosed within the double quotes.
		    Tag name should not contain spaces.
		    There should be no spaces between < and > in a tag.
		    Tags must be nested correctly.
	 b.	 HTML editors are software which are used to write and edit HTML codes. There are mainly 

two types of HTML editors, WYSIWYG editor and Text Editor. The most commonly used 
HTML editors are Notepad and Notepad++. 

	 c.	 Every chapter in a book has headings and sub-headings. These are known as levels of 
headings. The heading tags are used to give a similar effect to your web page. These are 
container tags with a start tag and an end tag. HTML has six levels of headings such as <H1>, 
<H2>, <H3>, <H4>, <H5> and <H6>.

9.
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Fun Zone

Let's Solve

1.	 a.	 <Hn> tag
	 b.  <Title> tag
2.	
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Let’s Explore

Do your self

Tech Practice

Do your self

	 Internet Services

Let’s Plug-in

1. Communication			   2.  Movie/Train Ticket Reservation
3.  Looking for Information		  4.  Online Shopping

Let’s Catch Up

1.	 ARPANET – Advanced Research Projects Agency Network

10.
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2.	 WWW – World Wide Web
3.	 URL – Uniform Resource Locator

Test Your Skills

1.	 a.  (i)	 b.  (iii)	 c.  (iv)	 d.  (iii)
2.	 a.  F	 b.  F	 c.  F	 d.  T
3.	 a.  E-mail	 b.  ARPANET	 c.  Web document	 d.  Attachment	 e.  Website
4.	 a.	 The Internet is a computer network that connects hosts and end systems throughout the 

world.
	 b.	 Internet has enhanced the teaching and learning process by making education very friendly 

and interesting. Education on the Internet is also called e-learning.
	 c.	 E-mail stands for electronic mail. You can send messages and files from your computer to 

your friend’s computer and vice-versa using e-mail service.
5.	 a.	 The World Wide Web (www) is a large information system where you can surf and get 

information. Web is a service (a system for accessing information) that is supported by the 
Internet, a system of interconnected networks.

	 b.	 An e-greeting is just like a paper greeting card. The only difference is that it is created 
with the help of digital text and effects. Some of the popular e-greetings websites are 
www.123greetings.com, www.egreetings.com, www.e-cards.com, etc.

Fun Zone

Let's Solve

1.	 a.	 E-greeting	 b.  E-mail
2.	
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Let’s Explore

Do your self

Tech Practice

Do your self

Periodic Assessment–4
(Based on chapters 8 to 10)

A.	 1.  Fill	 2.  Web Browser	 3.  Hyperlink	 4.  Tag	 5.  HTML
B.	 1.	Web Browser: A Web browser is a software application designed to find hypertext documents 

on the Web and then open the documents on the user’s computer.
	 2.	URL: URLs help you to navigate the web. When you provide a URL to the browser, the browser 

finds that URL’s Web page and then transfers the Web page to your PC.
	 3.	Nesting of Tags: Nesting of tags means that you can start a new tag before closing the 

previous tag. The only point to remember is that tags are nested on LIFO principle, that is, 
Last In First Out.

	 4.	WYSIWYG: WYSIWYG stands for What You See Is What You Get. This type of editor allows 
the developer to see what the end result will look like when the document is created.

C.	 <html>
	 <body>
	 <h1> Introduction to HTML </h1>
	 <p> HTML stands for Hypertext markup Language. It is a markup language that describes the 

structure of the web page. It allows us to create web pages that contain paragraphs, headings, 
links and block quotes. The output of HTML web pages is same on any type of computer and 
on any operating system, i.e. Mac, Windows, etc.</p>

	 </body>
	 </html>

Test Sheet–2
(Based on chapters 6 to 10)

A.	 1.  (iii)	 2.  (iii)	 3.  (ii)	 4.  (iii)	 5.  (ii)
	 6.  (i)	 7.  (ii)	 8.  (iv)
B.	 1.  markup	 2.  header	 3.  stage	 4.  lines
	 5.  Small Basic	 6.  if-then	 7.  goto	 8.  identifier
C.	 1.  F	 2.  F	 3.  F	 4.  T	 5.  T
	 6.  F	 7.  F
D.	 1.  c.	 2.  e.	 3.  d.	 4.  b.	 5.  a.
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E.	 1.	A variable is used to store different kinds of information, such as text or a number, in the 
computer’s memory.

	 2.	Relational operators are used to compare the values of two operands and return Boolean 
true or false accordingly. 

	 3.	Math.Abs(number) : It returns the absolute value of the given number. 
		  Example:  Math.Abs(–27.963) will return 27.963.
	 4.	The fill is the inside of the drawn object. You can also use a gradient or a bitmap image (such 

as a JPEG file) as a fill, or you can specify the object to have no fill at all. In a gradient, one 
color gradually changes into another.

	 5.	HTML stands for Hypertext Markup Language. It is a markup language that describes the 
structure of the web page. It allows us to create web pages that contain paragraphs, headings, 
links and block quotes.

	 6.	Container Tags: The tags that have both opening and closing tags are called Container Tags. 
		  For example	 <b> ...... </b>
	 		  	       <head> ...... </head>
	 7.	URLs help you to navigate the web. When you provide a URL to the browser, the browser finds 

that URL’s Web page and then transfers the Web page to your PC. URL stands for Uniform 
Resource Locator

F.	 1.	Step 1:  Click and select the drawing on the Stage.
		  Step 2:  Click on the Modify → Convert to Symbol option from the menu bar.
		  Step 3:  Enter a suitable name for the symbol and click on OK button.
	 2.	Properties Panel is also called Property Inspector, this panel displays the different properties 

of the object, which is selected. We can edit the properties of the selected object by changing 
the settings of the object from the Property Inspector. Sometimes, the Property Inspector 
may not be visible, then select the Window → Properties option from the menu bar.

	 3.	The <HTML> tag tells the web browser that the text contained between <html> and </
html> is a web page and can be viewed using a web browser. Every web page coding must 
start with the <html> tag and end with the </html> tag.

		  The <BODY> tag tells the web browser that the text contained between <body> and </
body> tags is to be shown on the web page. It is a container tag.

	 4.	The World Wide Web (WWW) is a large information system where you can surf and get 
information. WWW is also known as web. Web is a service (a system for accessing information) 
that is supported by the Internet, a system of interconnected networks.

	 5.	a.	 Internet has enhanced the teaching and learning process by making education very 
friendly and interesting. Education on the Internet is also called e-learning.

		  b.	 The process of purchasing products online is called online shopping. You can purchase 
almost everything online. We must have registered with the e-commerce website from 
which we want to buy products.
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	 6.	 Movie Clip 
Symbol

Used to create animations. We can apply color settings, blending modes 
and filters in this symbol.

	Button 
Clip 
Symbol

Used to insert and manage interactivity. It needs a code or a program 
to remove work. We can apply color settings, blending modes and filters 
in this symbol.

	Graphic 
Symbol

Used to build more complex movie clip symbols. We cannot apply color 
settings, blending modes and filters in this symbol.




