
1Touchpad PLUS (Version 1.1)-VI (Answer Key)

	Computer Software

One LearnTouch

A.	 1.	 c	 2.	 c	 3.	 b	 4.	 c
B.	 1.	 T	 2.	 F	 3.	 F	 4.	 F
C.	 1.	 (This question is incorrect in the book please correct it in your textbook)
		  Q. __________is a set of instructions that make the computer perform tasks.
		  A. Software 
	 2.	 operating system
	 3.	 application software	 4.	 disk defragmenter
D.	 1.	 d.	 2.	 c.	 3.	 a.	 4.	 e.	 5.	 b.

ItLet's Do

A.	 1.	 A computer is an electronic device that performs diverse operations with the help of 
instructions to process the data in order to achieve desired results. 

	 2.	 An operating system is the most important software that runs on a computer. It 
manages the computer’s memory, processes data and controls all its software as 
well as hardware. 

	 3.	 Multimedia software are used to combine the text with graphics, videos and sounds.  
	 4.	 Application software is a program designed to help users to perform specific tasks. 

MS Word, MS Excel and MS PowerPoint are examples of application software.
B.	 1.	 System software is the most important component to operate a computer. System software 

can be classified into three categories:
	 (i)	 Operating System	 (ii)  Programming Software	 (iii)  Utility Software 
	 2.	 Application software can be of two types: 
	 (i)	 General purpose software: General purpose software are those which have not 

been developed according to the needs of a particular organization.
	 (ii)	 Customised software: Customised software are those which have been developed 

according to the needs of a particular organisation or an individual. 
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		  Some examples of application software are Microsoft Word, Microsoft Access, and 
Windows Movie Maker.

Crack CodeThe

A.	 1.	 Word Processors        2.   Antivirus        3.   Data Compression Program

Do yourself.

	Windows 7

One LearnTouch

A.	 1.	 b	 2.	 c	 3.	 c	 4.	 a
B.	 1.	 F	 2.	 T	 3.	 T	 4.	 T
C.	 1.	 taskbar	 2.	 recycle bin		  3. notification Area	 4. aero flip 

ItLet's Do

A.	 1.	 A jump list is a feature introduced in Windows 7 that allows us to view recent documents 
in a program that is pinned to the taskbar. 

	 2.	 The Disk Cleanup tool is used to search on the hard disk for files that can be deleted from 
the computer without affecting its functions or your personal files. 

	 3.	 Status bar shows various information about the file in which we are working. 
	 4.	 Five components of an active window are:
	 (i)	 Title bar	 (ii)	 Control Buttons	 (iii)	 Ribbon
	 (iv)	 Work area	 (v)	 Status bar
B.	 1.	 Snap feature arranges two windows side by side exactly to fill half the screen each whereas, 

Aero Flip feature shows you what is happening in all other open windows on the computer 
system. 

	 2.	 To open Control Panel, follow these steps:
		  Step 1  Click on Start button. 
		  Step 2  Click on Control Panel. 
	 3.	 To change date, follow these steps:
		  Step 1  Click on the Clock, Language, and Region option from the Control Panel.
		  Step 2  Click the Date and Time option.
		  Step 3  Click Change Date and Time button. 
		  Step 4  Select date and month from the calender.
		  Step 5  Click on OK button.

2.
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Crack CodeThe

A.	 1.	 By changing Mouse setting from Right handed to Left handed in the Mouse Properties 
dialog box, the mouse is configured for left handed person.

	 2.	 By using the Disk Cleanup tool, junk files can be deleted from the computer. 
B.	
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Do yourself.

Periodic Assessment-1
(Based on chapters 1 & 2)

A.	 1.	 Antivirus is a programming software used to scan the computer system for presence of 
virus.

	 2.	 Disk Cleanup tool is used to delete temporary Internet files and Windows temporary files. 
	 3.	 (This question is incorrect in the book please correct it in your textbook)
		  Q. �Snap feature of Windows 7 shows you on the taskbar a preview of the windows that are 

open.
		  A. �Sneak feature of Windows 7 shows you on the taskbar a preview of the windows that 

are open.
	 4.	 The section at the right end of the Taskbar is the Notification Area.
	 5.	 Recording tab is available in the Sound dialog box. 
B.	 1.	 Word Processors software are used to create, edit and format text documents. Microsoft 

Word is an example of Word Processors software.
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	 2.	 Database Management System (DBMS) software are used to create, store, modify and sort 
data stored in a database. Microsoft Access is an example of DBMS.

	 3.	 Spreadsheet software are used to calculate, compare and analyse data and used to prepare 
different reports. Microsoft Excel is an example of Spreadsheet software.

	 4.	 DeskTop Publishing (DTP) software are used to create newspapers, magazines, brochures, 
still advertisements, etc. Adobe InDesign is an example of DTP software.

	 5.	 Presentation software are used to create presentations which include sound, music, video, 
charts and animation. Microsoft PowerPoint is an example of Presentation software.

C.	 1.	 Application software	 2.	 Calc	 3.	 Adobe InDesign		 4.	 Share
D.	 1.	 c.	 2.	 e.	 3.	 a.	 4.	 b.	 5.	 d.

	More on MS PowerPoint 2010

One LearnTouch

A.	 1.	 d
	 2.	 (This question is incorrect in the book please correct it in your textbook)
		  Q.	 Which of the following tab is used to add audio files in a presentation?
			   a. Insert tab				   b. Home tab
			   c. View tab				    d. Design tab
		  A. a. Insert tab
	 3.	 d	 4.	 c	 5.	 b
	 6.	 (This question is incorrect in the book please correct it in your textbook)
		  Q.	 Which of these is used to preview animation on current object?
			   a. Play button 		  b. Slide Show button
			   c. Preview button		  d. Both a and c
		  A. d. Both a and c 
B.	 1.	 T	 2.	 T
	 3.	 (This question is incorrect in the book please correct it in your textbook)
		  Q. To choose a theme, click on Home tab.
		  A. False
	 4.	 (This question is incorrect in the book please correct it in your textbook)
		  Q. Audio and Video can be inserted in the slides.
		  A. True 
	 5.	 F	 6.	 F
C.	 1.	 one or more			   2.	 presentations			   3.	 animation 
	 4.	 ribbon			   5.	 slide			   6.	 create

3.
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D.	 (This question is incorrect in the book please correct it in your textbook)
	 Q. 
		  Column A				    Column B
		  1. Play button 				   a. set of predefined layouts
		  2. Themes 				    b. make a presentation more interesting
		  3. Animations 				    c. let you set up how your show will progress
		  4. Slide Show			    	 d. preview the effect of animation
	 A. 1. d.		  2. a.		  3. b.		  4. c. 

ItLet's Do

A.	 1.	 A theme is a set of predefined layouts that can be used to add a professional touch to your 
presentations. 

	 2.	 Transition determines how your presentation moves from one slide to the next. 
	 3.	 Slide transition is applied on the slides and animation is applied on the objects of the slides.
B.	 1.	 To apply design themes, follow these steps: 
		  Step 1  Click on the Design tab. 
		  Step 2  Place the mouse pointer over any of the theme in the Themes group. 
		  Step 3  Click the design theme thumbnail when we find one that suits our needs. 
	 2.	 To add audio in a presentation, follow these steps:
		  Step 1 � Click on Audio command on the Insert tab on the ribbon to open Insert Audio 

dialog box.
		  Step 2  Navigate and select the audio file to be inserted and click on Insert button.
		  Step 3  This will insert a speaker icon on the slide.
		  Step 4  Click on button to preview the audio.
	 3.	 To run a slide show, follow these steps: 
		  Step 1  Click the Slide Show tab.
		  Step 2 � Select either From Beginning (to see the show from the first slide) or From Current 

Slide (to see the show onwards from a slide selected in the Slide Pane).
	 4.	 To apply animation to text or objects, follow these steps:
		  Step 1  Click on the image or the text we would like to animate.
		  Step 2  Click Animations tab.
		  Step 3  We can either open the Animation pane or use the drop-down list.
		  Step 4  Select the animation effect we would like. 
		  Step 5 � Specify whether we want the animation to start On mouse click, After previous or 

With previous.

Crack CodeThe

A.	 1.	 By using Themes, Sumit can add a background to his presentation.
	 2.	 By using Animation, Pooja make the objects appear in a different way. 
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B.	
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Do yourself.

	Understanding MS Excel 2010 

One LearnTouch

A.	 1.	 d	 2.	 a	 3.	 c	 4.	 a	 5.	 b
B.	 1.	 T	 2.	 T	 3.	 T	 4.	 T	 5.	 F	 6.	 F
C.	 1.	 excel	 2.	 create	 3.	 program	 4.	 merge cells  

ItLet's Do

A.	 1.	 Spreadsheet is a program that allows us to store and analyse numerical data.  
	 2.	 The horizontal divisions on a worksheet are called rows and vertical divisions on a worksheet 

are called columns. 
	 3.	 AutoFill feature automatically fills a series of data in your worksheet. 
B.	 1.	 The data in the form of numbers or text can be entered by just clicking on a cell and typing 

with the help of a keyboard. We can type data directly into the cell, or we can enter data 
using the Formula bar. 

	 2.	 To set column width/row height, follow these steps:
		  Step 1  Select the column(s) or row(s) that you want to change. 
		  Step 2  Click on Format command in Cells group from Home tab. 
		  Step 3  Choose Column Width or Row Heights under Cell size from the drop-down list. 

4.
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		  Step 4  A Column Width or Row Height dialog box will appear. 
		  Step 5 � In the Column Width or Row Height box, type the value that you want your column 

or row to be. 
	 3.	 To apply cell border, follow these steps:
		  Step 1 � On a worksheet, select the cell or range of cells that we want to add a border to, 

change the border style on, or remove a border from. 
		  Step 2  Go to the Font group in the Home tab. 
		  Step 3  Click the arrow next to Borders command. 
		  Step 4  Click on the border style we would like.  

Crack CodeThe

A.	 1.	 By using the Wrap Text command present on the Alignment group in the Home tab, Sonia 
can make the text visible. 

	 2.	 By inserting a column, Anaya can create space to enter the marks.
B.		  W
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	 1.	 To add a row above fifth row, follow these steps:
		  Step 1  Select the fifth row by clicking on the row heading. 
		  Step 2  Click on Insert command in the Home tab. 
		  Step 3  Click the Insert Sheet Rows option.
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	 2.	 To insert a column to the right of third column, follow these steps:
		  Step 1  Click and select the fourth column heading. 
		  Step 2  Click on Insert command on the Home Tab.
		  Step 3  Click on Insert Sheet Columns option.  
	 3.	 To fill roll numbers from 1 to 11, follow these steps:
		  Step 1  Enter the first two numbers 1 and 2.  
		  Step 2  Select both the cells containing the numbers we have entered. 
		  Step 3 � Position the mouse pointer over the bottom right corner of the last selected cell. 

The pointer changes to (+) sign. 
		  Step 4  Drag the mouse pointer over the cells we want to include in the series. 

Periodic Assessment-2
(Based on chapters 3 & 4)

A.	 1.	 Shift + F5			   2.	 Ctrl + X			   3.	 Ctrl + V

B.	 	

Components of MS Excel 2010

Quick Access Toolbar Title Bar

Ribbon

Formula 
bar

Name box

Highlighted head-
ings

Worksheet Window

Row Heading

Active Cell

Worksheet Tabs

Worksheet tab 
scrolling buttons

Status bar

Mouse Pointer

Column 
Heading

File tab

C.	 1.	 Adding Sound			  2.	 AutoFill 
D.	 1.	 Animation			   2.	 Design		  3. Cell		  4. Title Bar

Test Sheet-1
(Based on chapters 1 to 4)

Section A
A.	 1.	 (d)	 2.	 (c)
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	 3.	 (This question is incorrect in the book please correct it in your textbook)
		  Q.	Animation is used to hold the ............................ of audience.
			   a. attendance				   b. attention
			   c. absence				    d. arrival
		  Ans. b. Attention 
	 4.	 (This question is incorrect in the book please correct it in your textbook)
		  Q.	Which of these features is used to fit the active window to fill exactly half screen?
			   a. Shake	b. Snap
			   c. Flip		  d. Sneak
		  Ans. b. Snap
	 5.	 (a)
	 6.	 (a)	 7.	 (b)
B.	 1.	 presentation	2.	 slide
	 3.	 (This question is incorrect in the book please correct it in your textbook)
		  Q. �You can use______________ option in the Alignment group to combine two or more selected 

cells into a single cell.
		  A. Merge cells 
	 4.	 Cell Styles	 5.	 create
C.	 1.	 T	 2.	 T
	 3.	 (This question is incorrect in the book please correct it in your textbook)
		  Q. To choose a theme, click on Home tab.
		  A. False
	 4.	 T
	 5.	 (This question is incorrect in the book please correct it in your textbook)
		  Q. The intersection of a row and a column is called a cell merging.
		  A. False

Section B
A.	 1.	 Slide transition can be applied on the slides of a presentation whereas Animation can be 

applied on the objects of a slide.
	 2.	 Aero Flip feature shows you what is happening in all other open windows on the computer 

system.
	 3.	 AutoFill feature automatically fills a series of data in your worksheet.
	 4.	 The horizontal divisions on a worksheet are called rows and the vertical divisions on a 

worksheet are called columns. 
	 5.	 Spreadsheet is a program that allows us to store and analyse numerical data.
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B.	 1.	 To insert Clip Art, follow these steps: 
		  Step 1  Click on Insert tab.
		  Step 2  Click on Clip Art command.
		  Step 3  Enter keyword in the Search for: text box in the ClipArt pane. 
		  Step 4  Click on the image we want to insert in a slide.  
		  To insert a picture, follow these steps: 
		  Step 1  Click on the Insert tab. 
		  Step 2 � From the Images group, click on the Picture command. The Insert Picture dialog 

box appears. 
		  Step 3  Select the desired image file and click on Insert button.
	 2.	 An operating system is the most important program of a computer that acts as a interface 

for the interaction with the hardware, using software. Without an operating system, we 
cannot even start a computer and work on it.

	 3.	 The Disk Cleanup tool is used to search on the hard disk for files that can be deleted from 
the computer without affecting its functions or your personal files. 

	 4.	 To apply cell border, follow these steps:
		  Step 1 � On a worksheet, select the cell or range of cells that you want to add a border to, 

change the border style on, or remove a border from. 
		  Step 2  Go to the Font group in the Home tab. 
		  Step 3  Click the arrow next to Borders command. 
		  Step 4  Click on the border style you would like.
	 5.	 To set column width/row height, follow these steps:
		  Step 1  Select the column(s) or row(s) that you want to change. 
		  Step 2  Click on Format command in Cells group from Home tab. 
		  Step 3  Choose Column Width or Row Heights under Cell size from the drop-down list. 
		  Step 4  A Column Width or Row Height dialog box will appear. 
		  Step 5 � In the Column Width or Row Height box, type the value that we want our column 

or row to be.

	Introduction to Flash CS6

One LearnTouch

A.	 1.	 b	 2.	 d	 3.	 a	 4.	 d
B.	 1.	 F	 2.	 F	 3.	 T	 4.	 T
C.	 1.	 frame	 2.	 layers	 3.	 left	 4.	 bottom

ItLet's Do

A.	 1.	 Flash is a very useful application used in multimedia graphic programs. 
	 2.	 ActionScript 3.0. 

5.
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	 3.	 Yes, there are many ways to exit Flash.
	 (i)	 Click on Exit from File menu 		  (ii)   Press Ctrl + Q keys 
	 4.	 Text Tool, Pen Tool and Line Tool.
B.	 1.	 To start Flash, follow these steps: 
		  Step 1  Click on Start button. 
		  Step 2  Click on All Programs. 
		  Step 3  Click on Adobe Flash CS6 Professional. 
	 2.	 Properties panel allows you to set the properties of the objects that you have selected on 

the stage. It also provides options to change the settings of the Flash document such as 
stage dimensions and the animation’s frame rate. 

	 3.	 To save a Flash document, follow these steps: 
		  Step 1  Click on File menu. 
		  Step 2  Click on Save to open Save As dialog box. 
		  Step 3  Enter a name for the file in File name text box. 
		  Step 4  Click on Save button.

Crack CodeThe

A.	 1.	 Sunidhi can place the objects on the pasteboard.
	 2.	 Options area can show her the required features.
B.	
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To start Flash:
Step 1  Click on Start button. 
Step 2  Click on All Programs. 
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Step 3  Click on Adobe Flash CS6 Professional. 
To create a new Flash document: 
Step 1  Click on File menu. 
Step 2  Click on New to open New Document dialog box. 
Step 3  Select ActionScript 3.0 from the Type list. 
Step 4  Click on OK button. 
To save a Flash file: 
Step 1  Click on File menu. 
Step 2  Click on Save to open Save As dialog box. 
Step 3  Enter a name for the file in File name text box. 
Step 4  Click on Save button. 
To exit Flash:
Click on Exit from File menu 
Or 
Press Ctrl + Q keys 
Or 
Press Alt + F4 keys 
Or 
Click on the Close button on top right corner of the Flash window.

	Using Tools in Flash CS6

One LearnTouch

A.	 1.	 c
	 2.	 (This question is incorrect in the book please correct it in your textbook)
		  Q.	 Which of the following tool is use to place the text blocks on the stage?
			   a. Colour tool		  b. Paint bucket tool
			   c. Text tool				   d. Polystar tool
		  Ans. c. Text tool
	 3.	 a	 4.	 a
B.	 1.	 T	 2.	 T	 3.	 F	 4.	 T
C.	 1.	 Pencil
	 2.	 (This question is incorrect in the book please correct it in your textbook)
		  Q. To select oval tool, click and hold on _________________Tool.
		  A. Rectangle 
	 3.	 fill colour	 4.	 Hand	 5.	 Stroke
D.	 1.	 f.	 2.	 e.	 3.	 d.	 4.	 a.	 5.	 b.
	 6.	 g.	 7.	 c.

6.
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ItLet's Do

A.	 1.	 Stroke Height text box is used to change width or thickness of the line.
	 2.	 Freehand lines and curves. 
	 3.	 Yes, there are some options:
	 (i)	 Oval Tool		  (ii)  PolyStar Tool
B.	 1.	 Selection Tool: It is used to select and move objects. 
		  Hand Tool: It is used to move to different parts of the stage without changing the view of 

the stage.
	 2.	 Properties of a line are Stroke Color, Stroke Size, Stroke Style and Cap. 
	 3.	 The main difference between Star and Polygon options is that the Star option creates a 

star and the Polygon option creates a polygon with specified number of sides. 

Crack CodeThe

A.	 1.	 PolyStar Tool can be used to draw the star.
	 2.	 Gishi can draw a square by using the Shift key with the Rectangle Tool.
	 3.	 Yes, Surabhi can remove some parts by using the Eraser Tool.
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	Internet and E-mail

One LearnTouch

A.	 1.	 c	 2.	 a	 3.	 c	 4.	 a	 5.	 c	 6.	 c
B.	 1.	 F
	 2.	 (This question is incorrect in the book please correct it in your textbook)
		  Q. �BCC is marked to the e-mail address when you do not want others to see to whom the 

e-mail has been sent.
		  A. True
	 3.	 F	 4.	 F
	 5.	 (This question is incorrect in the book please correct it in your textbook)
		  Q. �The Internet is a computer network that connects hosts and end systems throughout 

the world.
		  A. True
	 6.	 F
C.	 1.	 Bcc	 2.	 To	 3.	 Cc	 4.	 Attachment	 5.	 Website
D.	 1.	 d.	 2.	 c.	 3.	 e.	 4.	 b.	 5.	 f.	 6.	 a.

ItLet's Do

A.	 1.	 The Internet is a computer network that connects hosts and end systems throughout the 
world.

	 2.	 HTTP stands for Hypertext Transfer Protocol. It is a protocol used on Web.  
	 3.	 URL stands for Uniform Resource Locator. It is an address of a web page over the Internet.  
	 4.	 An Electronic mail or e-mail can be defined as the system of exchanging messages 

electronically through a communications network by using computer.
B.	 1.	 The World Wide Web (WWW) is a large information system where you can surf and get 

information. WWW is also known as Web. It is differ from Internet as the Internet is a 
computer network that connects hosts and end systems throughout the world.  

	 2.	 Advantages of e-mail are: 
	 (i)	 An e-mail can be sent anytime and from anywhere in the world. 
	 (ii)	 An e-mail can be sent to many people at a time. 
	 (iii)	 An e-mail can be easily forwarded to anyone without typing it again. 
	 (iv)	 Sending an e-mail is fast in comparison to traditional mails. 
	 (v)	 Music, images or any other computer file can be shared with anyone by using e-mail. 
	 (vi)	 If an e-mail is not delivered, you receive an e-mail explaining the problem why the 

e-mail could not be delivered. 
	 3.	 For signing in to your Gmail account, follow these steps:  
		  Step 1  Double-click on the Web browser icon. 

7.
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		  Step 2 � Type www.gmail.com in the address bar of the browser window and press Enter key. 
		  Step 3  Click on Sign in button on the top right-hand of the browser window. 
		  Step 4 � In the Email or phone field, enter username of the email address that you have 

created. 
		  Step 5  Click on Next button. 
		  Step 6 � In the Password field, enter the password you had created for your email account 

and click on Next button. 
		  For signing out to your Gmail account, follow these steps:
		  Step 1  Click on the icon on the top right corner of your browser window. 
		  Step 2  Click on Sign out button. 

Crack CodeThe

A.	 1.	 Attachment in an e-mail.
	 2.	 Sushant should write the e-mail address of Ajay in the To field and e-mail addresses of 

others in the Cc field. 
	 3.	 After sending e-mail to his boss, Raman should sign out from his e-mail account.
B.	
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Periodic Assessment-3
(Based on chapters 5 to 7)

A.	 1.	 Selection Tool			   2.	 Hand Tool			   3.	 Eraser Tool 
	 4.	 Pencil Tool
B.	 1.	 Rectangle			   2.	 Rectangle
C.		

Options
box

Tools panelProperties panelStage

Menu bar

Pasteboard

D.	 1.	 As soon as possible		  2. Great		  3. Laughing Out Loud
	 4.	 By The Way

	Algorithm and Flowchart

One LearnTouch

A.	 1.	 (This question is incorrect in the book please correct it in your textbook)
		  Q.	 In which of these characteristics of algorithm, each step is precisely defined?
			   a. Uniqueness	 b. Finiteness
			   c. Output	d. Precision
		  Ans. d. Precision
	 2.	 a	 3.	 a	 4.	 c	 5.	 a
B.	 1.	 F	 2.	 T	 3.	 F	 4.	 T	 5.	 T
C.	 1.	 algorithm 	 2.	 connectors	 3.	 consistent	 4.	 two	 5.	 flowchart

8.
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ItLet's Do

A.	 1.	 An Algorithm is a set of steps in a sequential and ordered manner to solve any problem.
	 2.	 A flowchart is a type of graphical diagram that represents an algorithm.
	 3.	� (Start/Stop), Process, Decision, Input/Output, Flow Line (Arrow, Connector), Connector 

(Inspection)
	 4.	� The construction of the Algorithm is the stage which requires creative thinking and finding 

the best possible combination of steps to get the result.
B.	 1.	 You must follow these basic rules while drawing a flowchart:
		  •  The flowchart should be clear, neat and easy to follow.
		  •  Maintain the direction of the flow from left to right or top to bottom.
		  •  Only one flow line should come out from a process symbol. 
		  • � Ensure that only one flow line should enter a decision symbol, but two flow lines should 

leave the decision box.
		  •  Ensure that the flowchart has a logical start and end.
	 2.	 The main characteristics of a good algorithm are:
		  •  Precision: Each step is precisely defined.
		  • � Uniqueness: Result of each step should be uniquely identified and only depend on the 

result of the preceding step.
		  •  Finiteness: It should stop after a finite number of instructions are executed.
		  •  Input: It should have well-defined input.
		  •  Output: It should have well-defined output.
		  •  Effective: It is measured in terms of time and space.
	 3.	 Process symbol: It is used to show a process or action step. This is the most common 

symbol used in flowcharts.
		  Input/Output: It is used to represent the material or information entering or leaving the 

system, i.e., input and output.
C.	 1.	 Connector	 2.	 Decision	 3.	 Process	 4.	 Input/output

Crack CodeThe

	 1.	 a. Input	 b.	 Process	 c.	 Input
	 2.	 Richa should make an algorithm before drawing a flowchart.

Do yourself.
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	Introduction to Programming

One LearnTouch

A.	 1.	 d	 2.	 c	 3.	 a	 4.	 a	 5.	 c
	 6.	 b	 7.	 a
B.	 1.	 T	 2.	 T	 3.	 T	 4.	 F	 5.	 F
C.	 1.	 object-oriented programming			   2.	 reserved	 3.	 operators 
	 4.	 Programming,			   5.	 input( )

ItLet's Do

A.	 1.	 Python is a high level programming language. It has simple language syntax which makes 
it easy to read & write. It was developed by Guido Van Rossum in 1991 at the National 
Research Institute for Mathematics and Computer Science in Netherlands.

	 2.	 Operators are special symbols in Python that are used to perform arithmetic or logical 
computation. They are used along with operands or values to get the desired result.

		  For example: 5 + 3     Operator

                                 Operands
	 3.	� A character set means the characters like alphabet, digits or special symbols that can be 

used to write programs in Python language.
		  Alphabet A–Z or a–z
		  Digits 0–9
		  Special symbols ~ ‘ ‘ ! @ # $ % ^ & ( ) * - _ + = : \ ] { } ; “ < > , ? | `
B.	 1.	� The main difference between HLL and LLL is that the LLL is machine dependent and HLL is 

machine independent.
	 2.	� A Variable is the name of memory location that is used to store data values which can be 

accessed or changed later. The names given to the variables are known as identifiers.
		  The rule to define a variable is:
	 (i)	 A variable name must start with a letter or underscore character.
	 (ii)	 A variable name cannot start with a number.
	 (iii)	 A variable name can only contain alphanumeric characters (all the letters of the 

alphabet and numbers) and underscores (_).
	 (iv)	 Variable names are case-sensitive.
	 (v)	 Variable names cannot contain any special character or symbol.
	 3.	 We use input() function to take the user’s input while a program executes. (This function 

also evaluates the expression whether the user has entered a string number or list right 
after receiving input.) The general syntax of the input() function is as follows:

		  Variable_name = input(<message to be displayed>)
		  name = input(“Enter your name: “)

9.
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		  >>> Enter your name: “Amit”
C.	 1.	 Connector	 2.	 Decision	 3.	 Process	 4.	 Input/output

Crack CodeThe

A.	 1.	 By using arithmetic operator
	 2.	 The input( ) and print( ) statements 
B.	 1.	 Python	 2.	 IDLE	 3.	 Variable	 4.	 Keyword 	 5.	 Comment	
	 6.	 print( )
C.	 1.	 Error	 2.	 Error 

Do yourself.

	Intelligence and AI Approaches

One LearnTouch

A.	 1.	 d	 2.	 b	 3.	 a	 4.	 b
B.	 1.	 interpersonal 			   2.	 machine learning		  3.	 virtual assistant 
	 4.	 intelligence			   5.	 Howard,
C.	 1.	 T	 2.	 F	 3.	 T	 4.	 T

ItLet's Do

A.	 1.	 Bodily-Kinesthetic Intelligence is being good at dancing and sports along with love creating 
things with their hands, tends to remember by doing, rather than hearing and seeing, and 
excellent hand-eye and physical coordination Flexible in different body movements and 
performing actions.

	 2.	 A rule-based system uses rules as knowledge representation. These rules are coded in the 
system in the form of if-then-else statements which help the computer in taking decisions. 
The idea behind a rule-based system is to use the knowledge of a human expert in a 
specialised domain and embody it within the computer system.

	 3.	 Intelligence refers to the ability to think, to learn from previous experience, to solve complex 
problems and to adapt new things and environment.

B.	 1.	 A computer system that achieves AI through a machine learning technique is called a learning 
based approach. This approach is often referred to as black boxes as it is not entirely clear 
how these systems take decisions.

	 2.	 Verbal-Linguistic Intelligence people possess the following qualities:
		  •  Good at using words		  •  Can remember written and spoken information
		  •  Love reading and writing		  •  Good debaters 

10.
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		  •  Explain things well		  •  Use humour while telling stories
	 3.	 Naturalistic Intelligence people possess the following qualities:
		  •  Nature lover
		  •  Love exploring the environment and learning about other species
		  •  Enjoy camping, gardening, hiking and exploring outdoors

Crack CodeThe

A.  Naturalistic Intelligence
B.	 1.	 82		  2.	 141, 582		  3.	 Plant

Do yourself.

Periodic Assessment-4
(Based on chapters 8 to 10)

A.	 1.	 Machine language	 2.	 Assembler			   3.	 hyperlink
	 4.	 Character set			   5.	 Str() function
B.	 An Algorithm to input two numbers:
	 Step 1	 Start. 
	 Step 2	 Read all three numbers and store them in A, B and C. 
	 Step 3	 Add two numbers A and B. 
	 Step 4	 Multiply the sum with the number C.
	 Step 5	 Print the result.
	 Step 6	 Stop.
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C. 
Start

Stop

Read P for Principal

         r for rate

         t for time

Print SI for 

Simple Interest

Calculate
SI = (P * r * t)/100)

D.	 1.	 Bodily-Kinesthetic Intelligence
	 2.	 Interpersonal Intelligence
	 3.	 Existential Intelligence

Test Sheet-2
(Based on chapters 5 to 10)

Section A
A.	 1.	 c.	 2.	 c.	 3.	 c.	 4.	 c.
	 5.	 b.	 6.	 c.	 7.	 a.	 8.	 a.
B.	 1.	 Programming			   2.	 Connector, Flow Line	 3.	 Timeline 
	 4.	 operators			   5.	 1969			   6.	 Machine learning

Section B
A.	 1.	 Yes, there are many ways to exit Flash. The two ways to exit Flash are:
	 (i)	 Click on Exit from File menu 
	 (ii)	 Press Ctrl + Q keys 
	 2.	 An Algorithm is a set of steps in a sequential and ordered manner to solve any problem. 
	 3.	 To execute the set of statements.
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	 4.	 Intelligence refers to the ability to think, to learn from previous experience, to solve complex 
problems and to adapt new things and environment.

		  There are multiple types of intelligence according to Howard Gardner:
	 (i)	 Visual-Spatial Intelligence	
	 (ii)	 Verbal-Linguistic Intelligence
	 (iii) 	 Logical-Mathematical Intelligence
	 (iv)	 Bodily-Kinesthetic Intelligence
	 (v)	 Musical Intelligence
	 (vi)	 Interpersonal Intelligence
	 (vii)	 Existential Intelligence
	 (viii)	 Intrapersonal Intelligence
	 (ix)	 Naturalistic Intelligence
	 5.	 The full form of HTTP is Hypertext Transfer Protocol.
B.	 1.	 Properties panel allows you to set the properties of the objects that you have selected on 

the stage. It also provides options to change the settings of the Flash document such as 
stage dimensions and the animation’s frame rate.

	 2.	 Verbal-Linguistic intelligence gauges someone’s ability to use words effectively whereas 
logical-mathematical intelligence refers to someone’s ability to solve mathematical 
problems.

	 3.	 The main difference between Star and Polygon options is that the Star option creates a 
star and the Polygon option creates a polygon with specified number of sides.

	 4.	 The advantages of HLL are:
		  •	  High level language is user friendly.  
		  • � High level language is similar to English with vocabulary of words and symbols, therefore 

it is easier to run.
		  •  High level language requires less time to write.  
		  •  High level language is easier to maintain.
	 5.	 (a)	 Variables are memory locations that are used to store values. When a variable is created, some 

space is allocated in memory for it. This memory space is referred by the name that we give 
to the variable. It is easy to create a variable in Python.

		  (b)	 Operators are special symbols used to perform arithmetic or logical computation.
	 6.	 Some common netiquettes are:
	 (i)	 The subject of email must be in relation to the matter of the email.
	 (ii)	 Signatures in an email should be small and simple.
	 (iii)	 Avoid sending repeated mails just for publicity of the product or service.
	 (iv)	 Avoid typing in capital letters as typing in capitals is taken as shouting at the person.
	 (v)	 While writing an email, the person(s) whom you want should answer must be marked 

in the ‘To:’ field. The persons marked in ‘Cc:’ field may or may not respond to the 
mail.

	 (vi)	 Avoid using “Reply to All” option when not necessary to answer everyone marked in 
the email.
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	 (vii)	 Try to overlook the minor typing mistakes done by sender.
C.	 1.	

Start

Stop

Read A, B, C

Print 
Sum and Prod

Sum = A + B + C

Prod = A * B * C

			   2.	

Yes

No

Start

Stop

Print 
count

Is
count < A

Read A
count = 1

count = count + 1

D.	 �#�To accept the marks of three subjects (out of 100) from the user and 
calculate the total marks and average.

	 a = int(input(“Enter the marks in first subject: “))
	 b = int(input(“Enter the marks in second subject: “))
	 c = int(input(“Enter the marks in third subject: “))
	 total = a+b+c
	 avg = total/3
	 print(“Total marks: “,total)
	 print(“Average marks: “,avg)




