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	Computer Memory
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Random Access Memory (RAM) is called volatile memory.

 

1.	 a. (ii)		  b. (i)	 c. (iii)	 d. (ii)
2.	 a. byte	 b. nibble	 c. RAM	 d. Hard disk
3.	 a.	The basic unit for measuring the memory of a computer is the byte. A combination of eight 

bits makes up a byte.
	 b.	A pen drive is used to transfer data from one computer to another.
	 c.	Primary memory, also known as internal memory, is the main memory of the computer. It 

holds the data and instructions  which the computer is currently working on and makes it 
easily accessible for the CPU to process.

	 d.	Cloud Storage allows us to store data in an off-site location which can be accessed later on 
any computer anywhere through the Internet. 

	 e.	Any two examples of secondary storage devices are as follows:
		  (i) Compact Disk
		  (ii) Blu-Ray Disc
4.	 RAM ROM

(i) RAM is a volatile memory. (i) ROM is a non-volatile memory.
(ii) �The data and information stored in RAM is 

lost when the processing is incomplete or the 
computer is turned off.  

(ii) �The data and information stored 
in ROM is not lost even if the 
computer is switched off.

5.	 a. Cloud Storage	 b. Memory card	 c. Blu-Ray disc
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	The Computer Timeline
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Answer: 1837

 
1.	 a. (ii)		  b. (i) 	 c. (iii) 	 d. (i)
2.	 a. F 		  b. T 	 c. F	 d. F
3.	 a.	Microprocessor 	 b. IBM 360 	 c. Pascaline 	 d. Vacuum tubes
4.	 a. John Napier, a Scottish mathematician, created a  manually operated calculating device in 

1617. Napier’s Bones device used  a  set  of rods  with numbers written on them.
	 b.	In 1837, Charles Babbage devised another calculator called Analytical Engine. It is the  

first-ever working model of a mechanical computer and a fully program controlled machine.
	 c.	 Integrated Circuits or ICs were used in the third generation of computers.
	 d.	Features of fourth generation computers are: 
		  • Reduction in the size of computer
		  • More reliable than the earlier generation of computers with a great storage device
		  • Extremely powerful and can process millions of instructions per second 
5.	 a.	She is talking about the third generation computers.
	 b.	We currently use the fifth generation of computers.

2.
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Answer:

	Managing Files and Folders
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Answer: Sub-folder

 

1.	 a. (ii)		  b. (ii)	 c. (iii)	 d. (iii)
2. 	 a. All apps	 b. Auto HDR	 c. Ctrl+C	 d. File
3.	 a. Power Button	 b. Recycle Bin	 c. Icons	 d. .docx
4.	 a. The Recommended section of Start Menu recommends apps which Microsoft recommends 

us to try and if we click on more it may  display some apps  we have recently used. It also 
contains the Power button at bottom right  corner  for restarting and shutting down the 
computer.

	 b. A folder is a file cabinet where we can store our files and other subfolders. It helps us to keep 
our files organised.

	 c. Clicking on  the  Start  menu will open a set of Microsoft-related apps  pinned to the main 
page  and  a  search  box  at  the  top  of the menu.

	 d. The work we do or the information we collect is saved in the form of files. A file is a collection 
of data and information, stored on a storage device such as a hard disk, pen drive and CD/ 
DVD. The steps to rename a file as follows:

3.
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	    Step 1: Right-click the  file that you want to rename and click on Show more options.

	    Step 2: Select the Rename option from the displayed options

	    Step 3: Type a new name and press the Enter key.

	 e.	To delete a file or a folder, follow these steps: 

	    Step 1: Go to the location of your folder and select it.

	    Step 2: Right-Click on the file and select the Delete option. 
5. 	 a. Fiesta	 b. Three	 c. Two	 d. ???	 e. Excel File
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Answer: 
a. 14			  b. 23	 c. 6

Periodic Assessment–1
(Based on chapters 1 to 3)

1.	 a. Pen/Flash Drive	 b. Digital Versatile Disc (DVD)
	 c. Hard Disk	 d. Vacuum Tubes 
2.	 a. Folder	 b. Music File	 c. Video File	 d. Document File
3.	 a. (iii)		 b. (iv) 	 c. (ii) 	 d. (v) 	 e. (i)

	 Images and Objects in Word 2021

uiz Bee
Page-37

The Wrap Text option wraps text around an image.

 

1.	 1. a. (i)	 b. (iii)	 c. (i)	 d. (iii)

2. 	 a. Rotate 	 b. Insert 	 c. Wrapping	 d. WordArt

4.
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3. 	 a. F		  b. T	 c. T	 d. F
4.	 a.	Wrapping Text refers to how the text is positioned around objects or images.
	 b.	We can format a shape under the Insert tab.
	 c.	The steps to insert WordArt in our document are as follows:
		  (i) Click on the Insert tab.
		  (ii) Click the WordArt option.
		  (iii) Select the WordArt style.
		  (iv) Type your text in the text box to apply the WordArt effect.
	 d.	The steps to add text to shapes are as follows:
		  (i) Select the shape and right-click on it.
		  (ii) Choose the Add text option.
		  (iii) Type the desired text.

5.	 The Pictures command is present under the Insert tab.
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Answer: 
 a. C      b. I      c. E      d. H

	Creating Tables in Word 2021
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a. Combining two or more cells into one is called merging.
b. Breaking a cell into a number of rows or columns is called splitting.

 

1.	 a. (ii)		  b. (i)	 c. (ii)	 d. (iii)	 e. (ii)
2.	 a. F		  b. F	 c. T	 d. F

5.
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3.	 a. (iii)		 b. (iv)	 c. (i)	 d. (ii)

4. 	 a. Insert Tab	 b. Layout Tab	 c. Double-Click

	 d. Right-click→ Insert→ Insert Rows Below option 

5.	 a. The Table Move Handle is used to select an entire table.

	 b. We can enhance the look of a table by applying the Border and Shading styles.

	 c. There are nine types of alignments present in Word 2021.

	 d. The steps to enter data in a table are as follows:

	    Step 1: Click the mouse button on the cell where you want to enter data.

	    Step 2: Type the data you want to enter in that cell.

	 e. The steps to insert a column in an existing table are as follows:

	    Step 1: �Right click on the cell where you want to insert row/column and click on the insert 
option.

	    Step 2: Select the desired option.

	 f. Word 2021 allows us to enhance the look of a table by applying the Borders and Shading styles.
6.	 Splitting Cells Merging Cells

1. �A cell is split into rows or columns. 1. �Two or more cells are merged to create a 
larger cell.

2. �We can split a cell into the required number 
of rows or columns.

2. �Cells can be merged either column-wise or 
row-wise.

7.	 We should use table to organize  the work consisting of numeric  data.
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a. 30                b. cdd     def

Periodic Assessment–2
(Based on chapters 4 & 5)

1.	 a. Insert tab	 b. Rotate handles and Resize handles.	     c. Format Tab.
2.	
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3.	 a. Tab		 b. Alt+End	 c. Down Arrow	 d. Alt+Page Up Key
.	 e. Alt+Home	 f. Alt+Page Down Key	 c. Shift+Tab	 d. Up Arrow

Test Sheet–1
(Based on chapters 1 to 4)

1.	 a. (iii)  	 b. (ii)	 c. (iii)	 d. (i)	 e. (iii)
	 f. (iii)		  g. (ii)
2.	 a. nibble	 b. Start	 c. Insert	 d. Wrapping
	 e. Vaccum Tubes	
3.	 a. T		  b. F	 c. F	 d. T	 e. F
4.	 a. (v) 	 	 b. (iv)	 c. (i)	 d. (ii)	 e. (iii)

5.	 a. The highest unit of measuring memory is Geopbyte.

	 b. All files and folders move to the Recycle Bin when we delete them.

	 c. The WordArt option is found in the Insert tab.

	 d. John Napier, a Scottish mathematician, invented Napier’s Bone.

6.	 a. The steps to rename a folder are as follows:

	    Step 1: Right-click on the folder you want to rename and click on Show more options.

	    Step 2: Select the Rename options from the displayed options.

	    Step 3: Type a new name and press the enter key.

	 b.	Word 2021 provides an option to change the appearance of the text through the WordArt 
feature. You can create shadowed, skewed and stretched text that has been fitted to shapes. 
WordArt allows you to create text effects that are not available through font formatting.

	 c.	The features of fourth generation of computers:

		  (i) Reduction in the size of computer

		  (ii) More reliable than the earlier generation of computers with a great storage device

		  (iii) Extremely powerful and can process millions of instructions per second

	 d.	The steps to delete a file or folder are follows:

	    Step 1: Go to the location of your folder and select it.

	    Step 2: Right-click on the folder and select the Delete option.
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	 Introduction to PowerPoint 2021
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A title slide displays the text placeholder, where the text is to be typed.

 

1. 	 a. (ii) 		 b. (iii) 	 c. (i) 	 d. (ii) 
2. 	 a. Slide 	 b. Quick Access Toolbar 	 c. Title 
	 d. Placeholder 
3. 	 a. Ribbon 	 b. Normal View 	 c. F5 key 	 d. Reading view 
4. 	 a.	A presentation is a sequential display of information using text, graphics, audio, video and 

animation.
	 b. Any two components of PowerPoint are as follows:
		  (i)	� Title Bar
		  (ii)	� Quick Access Toolbar
	 c.	The steps to save a presentation are as follows:

	    Step 1: Click on the File tab.

	    Step 2: Click on the Save or Save As option.

	    Step 3: Click on Browse to select a location to  save the file. 

	    Step 4: In the File name box, type the name of the presentation.

	    Step 5: Click on the Save button.
	 d.	The steps to delete a slide in PowerPoint are as follows:

	    Step 1: Right-click on the slide you want to delete from the Slide Navigation Pane.

	    Step 2: Click on the Delete Slide option.
	 e.	PowerPoint  is an application software developed by Microsoft.   It allows us to create 

an alternative, eye-catching and professional presentation. The steps to open an existing 
presentation are as follows:

	    Step 1: Click on the file tab.

	    Step 2: Click on open.

	    Step 3: Click on Browse.

6.
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	    Step 4: Navigate the folder.

	    Step 5: Click on the name of the presentation you want to open.
5.	� Right-click on the slide you want to delete from the Slide Navigation pane and then click on 

the Delete Slide option.
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Answer: 
1. NOITATNESERP        2. SLIDE

	More on PowerPoint 2021
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The Normal view is used to change the order of the slides.

 

1. 	 a. (iii) 		 b. (iii)	 c. (i) 	 d. (ii) 
2.	 a. Normal 	 b. Presenter 	 c. nine 	 d. Slide show 
3.	 a. The slide layout is the arrangement of text, images, ClipArts, charts, etc. on a particular slide.
	 b. Outline view displays the text of each slide on the left pane and we can edit the text directly 

from here.
	 c. The steps to add themes to a presentation are as follows:

	    Step 1: Click on the Design tab.

	    Step 2: Select a theme in the Themes group.

	    Step 3: Select variants from here.
	 d. There are two options to view a presentation in Slide Show view. The two options are: From 

Beginning or From Current Slide.

7.
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4.	 Reading View Slide Show View
(i) It is used when we want to view a presentation 
not in full screen but in a window with simple 
controls that make the presentation easy to view.

(i) �It is used to run a presentation in full-
screen mode.

(ii) This view is like a Slide Show view. (ii) This view is not like the Reading view.

5.	 Sumit will find the themes option under the Design tab.

	More on Internet

uiz Bee
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Answer: The first page that appears when a website is opened is known as the home page.

 

1.	 a. (i)		  b. (ii)	 c. (iii)	 d. (ii)
2. 	 a. web pages 	 b. refresh	 c. HTML 	 d. Address bar
3. 	 a. (iii)		 b. (iv)	 c. (i)	 d. (ii)
4. 	 a. A web browser is a software that lets us access the pages on the World Wide Web.
	 b. �A web page may contain links to other web pages or places. These links are known as  

Hyperlinks. 
	 c. Any two advantages of the Internet are as follows:
		  (i) We can get information on any topic.  
		  (ii) We can buy products on the Internet.
	 d. �We can avoid becoming a victim of cybercrime by following certain guidelines such as 

choosing strong passwords, always using antivirus programs, etc.
	 e. Microsoft Edge is a default web browser that comes with Windows Operating System. Any 

four components of Microsoft Edge are:
		    (i) Address bar
		   (ii) Search Box
		  (iii) Back Button
		  (iv) Forward Button

8.
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5.	 a.	Amit should not add his personal details as by doing so he is very likely to become a victim 
of cybercrime.

	 b.	I will suggest that she should not enter her card details and pin on the website as this will 
increase her chances of becoming a victim of cybercrime, given that no legitimate website 
asks for such details when adding items to the cart.
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Answer: 
a. https://www.google.com/	 b. https://www.facebook.com/
c. http://twitter.com/[username]	 d. https://en.wikipedia.org/

Periodic Assessment–3
(Based on chapters 6 to 8)

1.	

2.	 a. Title and Content	

	 b. Content with Caption

	 c. Comparison

3.	 a. Mozilla Firefox      b. Online Safety      c. Google Chrome      d. Microsoft Edge
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	Blocks in Scratch

uiz Bee
Page-90

The Sound block instructs the sprite to play music.

 

1.	 a. (ii) 		 b. (i) 	 c. (i) 	 d. (i)
2. 	  a. T 		  b. F 	 c. F 	 d. F 
3.	 a. Logical operators are used to combine two or more conditions. They are used when we want  

to test more than one condition and make a decision.
	 b. The Looks block lets us modify the sprite’s costume and colours.
	 c. The Say Hello for 2 Seconds block displays a speech bubble of the sprite for a specified 

amount of time.
	 d. Control blocks have looping blocks which are used when the same blocks have to be repeated 

a number of times. Any two Control blocks are:
		  (i) Wait 1 seconds- This block pauses the running of the script for the number of seconds.
		  (ii) Repeat 10- This block repeats a set of blocks for a given number of times.
	 e. Scratch has four operators that allow you to do arithmetic calculations. These are addition, 

subtraction multiplication and division. Examples- 

when clicked

if then

say 100 is greater than 50 and 60

> >100 10050 60and when clicked

say

say

for secondsThe Difference between 100 and 50 is 2

–100 50

	 f. Any three rational or logical operators are:
		  (i) Logical and- The result is true if both the conditions are true.
		  (ii) Logical or- The result is true if one of the statements is true.
		  (iii) Logical not- Reverses the condition,i.e., it’s false if the condition is true and vise-versa.

9.
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4.	 a. This block starts playing a sound.
	 b. This block gives the x and y position of the sprite on the stage.
	 c. This block sets the size of the sprite to a specified percentage of the original size.
	 d. This block pauses the running of the script for the number of seconds.
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Do it yourself

	Drawing Shapes in Scratch

uiz Bee
Page-99

Erase all in Pen block erases pen marks from the stage.

 

1.	 a. (iii) 		 b. (ii) 	 c. (i) 	 d. (ii) 
2. 	 a. F		  b. F	 c. F	 d. T
3.	 a. The Forever block is used to make the sprite do something infinitely (nonstop) until a command 

is passed over it by the user.
	 b. The Pen block provides a trail for the sprite and gives instructions to change the colour, size 

and shade of the trail.
	 c. Sometimes it is important to use the wait block otherwise the movements on the script would 

occur so quickly that it would be difficult to observe them.
	 d.	The steps to draw a circle are as follows: 

pen down

repeat

when clicked

turn degrees1
move steps

set to pen size 5

360
1

Change pen color by 5

10.
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	 e.  The steps to draw a line in Scratch are as follows:

	      Step 1: Click the Motion button to display the Motion Blocks.

	      Step 2: Drag a  when clicked   block to the scripts area from the Events menu. 

	      Step 3: Drag a  set pen color to   block into the scripts area.

	      Step 4: �Drag a  set to pen size 1   block into the scripts area and change the size 
to 5.

	      Step 5: �Drag a  pen down   block. 

	      Step 6: �Drag on move 10 steps block and change it to  move steps50 .

	      Step 7: �Now, drag  Change pen color by 10   block to change the pen colour.

	      Step 8: �Then again, move 50 steps by dragging the move 10 steps block and change it to 
move steps50 .

	      Step 9: �Change the pen colour again by using the Change pen color by 10  block.

	      Step 10: �At last, move 50 steps by dragging the move 10 steps block and changing the steps 
to  move steps50 .

	      Step 11: Click the green flag at the top right corner of the stage to run your program.
4.	

pen down
repeat

when clicked

6

turn degrees60
move steps100
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pen down
repeat

when clicked

8

turn degrees45
move steps100 repeat

when clicked

next costume

8
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	Categories of Robots

uiz Bee
Page-106

Pre-Programmed robots are used in situations where the task requires a high level of accuracy.

 
1.	 a. (ii)		  b. (i)	 c. (iii)	       d. (ii)
2.	 a.	Autonomous	 b. Atlas	 c. Pre-programmed	      d. Augmenting
3.	 a. �Drone Controllers are used for surveillance purposes and detecting landmines on the 

battlefield.
	 b. �WoeBot  is a  therapist robot designed to  offer  convenient care to  people struggling with 

depression by  mimicking human conversation and offering help and companionship to its 
users.

	 c. Heartlander Robot is used to deliver treatment to delicate locations in the body like the heart.
	 d. �Augmenting robots are designed to enhance human capability or replace the abilities a human 

may have lost. They are used in medicines. Example- exoskeleton is used to lift heavy objects.
4.	 a. Atlas	 b. Artificial limb	         c. Woebot
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Answer: 

a. @!&*%%^+	 b. BAD

Periodic Assessment–4
(Based on chapters 9 to 11)

1.	 a. This block displays a speech bubble of the sprite for a specifies amount of time.
	 b. This block changes the costume of the sprite to the next costumes in the costume list.
	 c. This block starts playing a sound.
	 d. This block clears all the sound effects.
	 e. If the block's sprite is visible, it will hide the sprite. If the sprite is already hidden, nothing will 

change.

11.
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2.	 a. (ii)  	 b. (iii)	 c. (i)
3.	 a. Pre-Programmed Robot	 b. Humanoid Robot	              c. Tele-Operated Robot

Test Sheet–2
(Based on chapters 5 to 11)

1.	 a. (ii)		  b. (iii)	 c. (iii)	 d. (iii)	 e. (ii)
	 f. (i)		  g. (i)	 h. (iii)
2.	 a. Quick Access Toolbar	 b. Presenter	 c. Refresh	 d. Atlas
	 e. Pre-Programmed 
3.	 a. T		  b. F	 c. F	 d. F	 e. T
4.	 a. A presentation is a sequential display of information using text, graphics, audio, video and 

animation.
	 b. The Pen block provides a trail for the sprite and gives instructions to change the colour, size 

and shade of the trail.
	 c. The slide layout is the arrangement of text, images, ClipArts, charts, etc. on a particular slide.
	 d. Outline view displays the text of each slide on the left pane and we can edit the text directly 

from here.
	 e. A Web  Browser is a software that lets us access the pages on the World Wide Web.
	 f.	� Logical operators are used to combine two  or  more conditions. They are used when we 

want to test more than one condition and make a decision.
5. 	 a. The steps to save a presentation are as follows:
	    Step 1: Click on the File tab.
	    Step 2: Click on the Save or Save As option.
	    Step 3: Click on Browse to select a location to  save the file. 
	    Step 4: In the File name box, type the name of the presentation.
	    Step 5: Click on the Save button. 
	 b. The steps to view a presentation in slide show view are as follows:
	    Step 1: Click on the Slide Show tab.
	    Step 2: Click on From Beginning from the slide show group.
	 c. Microsoft Edge is a default web browser that comes with Windows   Operating System. Any 

four components of Microsoft Edge are:
		  (i) Address bar
		  (ii) Search Box
		  (iii) Back Button
		  (iv) Forward Button
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	 d. Scratch has four operators that allow you to do arithmetic calculations. These are addition, 
subtraction multiplication and division. Examples-

when clicked

if then

say 100 is greater than 50 and 60

> >100 10050 60and when clicked

say

say

for secondsThe Difference between 100 and 50 is 2

–100 50

	 e.  The steps to draw a line in Scratch are as follows:

	      Step 1: Click the Motion button to display the Motion Blocks.

	      Step 2: Drag a  when clicked   block to the scripts area from the Events menu. 

	      Step 3: Drag a  set pen color to   block into the scripts area.

	      Step 4: �Drag a  set to pen size 1   block into the scripts area and change the size 
to 5.

	      Step 5: �Drag a  pen down   block. 

	      Step 6: �Drag on move 10 steps block and change it to  move steps50 .

	      Step 7: �Now, drag  Change pen color by 10   block to change the pen colour.

	      Step 8: �Then again, move 50 steps by dragging the move 10 steps block and change it to 
move steps50 .

	      Step 9: �Change the pen colour again by using the Change pen color by 10  block.

	      Step 10: �At last, move 50 steps by dragging the move 10 steps block and changing the steps 
to  move steps50 .

	      Step 11: Click the green flag at the top right corner of the stage to run your program.
	 f. �Augmenting robots are designed to enhance human capability or replace the abilities a human 

may  have  lost. They are used in medicines. Example-  Exoskeleton is used to lift heavy objects.




