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	Computer Software

Exercise
A.	 1.	(c)	 2. (c)	 3. (b)	 4. (c)

B.	 1.	instructions	 2. operating system		 3. application software	

	 4.	disk defragmenter

C.	 1.	(d)	 2. (c)	 3. (a)	 4. (e)	 5.	 (b)

D.	 1.	An electronic device that performs diverse operations with the help of instructions to process 
the data in order to achieve desired results. 

	 2.	An operating system is the most important software that runs on a computer. It manages 
the computer’s memory, processes data and controls all its software as well as hardware. 

	 3.	Multimedia software are used to combine the text with graphics, videos and sounds.  
	 4.	Application software is a program designed to help users to perform specific tasks. 

MS Word, MS Excel and MS PowerPoint are application software.
E.	 1.	System software is the most important component to operate a computer. System software 

can be classified into three categories:
		  (i)	 Operating System		  		  (ii)	 Programming Software	

	 	 (iii)	Utility Software 

	 2.	Application software can be of two types: 
		  (i)	� General purpose software: General purpose software are those which have not been 

developed according to the needs of a particular organization.

		  (ii)	� Customised software: Customised software are those which have been developed 
according to the needs of a particular organisation or an individual. 

		  Some examples of application software are Microsoft Word, Microsoft Access, and Windows 
Movie Maker.

Brain Teaser
	 1.	Word Processors        2.   Antivirus
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Lab Session
Do yourself.

	Windows 7

Exercise
A.	 1.	(b)	 2. (c)	 3. (c)	 4. (a)

B.	 1.	F		  2. T	 3. T	 4. T

C.	 1.	A jump list is a feature introduced in Windows 7 that allows you to view recent documents 
in a program that is pinned to the taskbar. 

	 2.	The Disk Cleanup tool is used to search on the hard disk for files that can be deleted from 
your computer without affecting its functions or your personal files. 

	 3.	Status bar shows various information about the file in which you are working. 

	 4.	Five components of an active window are:

		  i.	 Title bar	 	 ii. Control Buttons	

		  iii.	Scroll bars		  iv. Work area	

		  v.	Status bar

D.	 1.	Snap feature arranges two windows side by side exactly to fill half the screen each and Aero 
Flip feature shows you what is happening in all other open windows on the computer system. 

	 2.	To open Control Panel:

		  Step 1  Click on Start button. 

		  Step 2  Click on Control Panel. 

	 3.	To change date:

	 	 Step 1  Click on the Clock, Language, and Region option from the Control Panel.

		  Step 2  Click the Date and Time option.

		  Step 3  Click Change Date and Time button. 

	 	 Step 4  Select date and month from the calender.

		  Step 5 Click on OK button on the Date and Time Settings dialog box. 

		  Step 6 Click on OK button on the Date and Time dialog box. 

2.
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Brain Teaser
A.	 1.	By changing Mouse setting from Right handed to Left handed in the Mouse Properties dialog 

box, the mouse is configured for left handed person.

	 2.	By using the Disk Cleanup tool, junk files can be deleted from the computer. 
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Lab Session
Do yourself.

Periodic Assessment 1
(Based on chapters 1 & 2)

A.	 1. Antivirus is an utility software used to scan the computer system for presence of virus.

	 2. Disk Cleanup tool is used to delete temporary Internet files and Windows temporary files.

	 3. Sneak feature of Windows 7 shows you a preview of the windows that are open on the taskbar.  

	 4.	The section at the right end of the Taskbar is called Notification Area.

	 5.	Recording tab is available in the Sound dialog box. 

B.	 1.	Word Processors software are used to create, edit and format text documents. Microsoft 
Word is an example of Word Processors software.

	 2.	Database Management System (DBMS) software are used to create, store, modify and sort 
data stored in a database. Microsoft Access is an example of DBMS.
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	 4.	To apply animation to text or objects:
		  Step 1  Click on the image or the text you would like to animate.
		  Step 2  Click Animations tab.
		  Step 3  You can either open the Animation pane or use the drop-down list.
		  Step 4  Select the animation effect you would like. 
		  Step 5 � Specify whether you want your animation to start On mouse click, After previous or 

With previous.
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Lab Session

Do yourself.

	More on MS Word 2010

Exercise
A.	 1.	(d)	 2. (c)	 3. (a)

B.	 1.	T		  2. T	 3. T	 4. F 

C.	 1.	page	 2. watermark	 3. footer	 4. buttons     5. page orientation 

4.

	 3.	Spreadsheet software are used to calculate, compare and analyse data and used to prepare 
different reports. Microsoft Excel is an example of Spreadsheet software.

	 4.	DeskTop Publishing (DTP) software are used to create newspapers, magazines, brochures, 
still advertisements, etc. Adobe InDesign is an example of DTP software.

	 5.	Presentation software are used to create presentations which include sound, music, video, 
charts and animation. Microsoft PowerPoint is an example of Presentation software.

C.	 1.	Application software	 2. Calc	 3. Adobe InDesign		  4.	 Share
D.	 1.	(c)	 2. (e)	 3. (a)	 4. (b)	 5. (d)

	More on MS PowerPoint 2010

Exercise
A.	 1.	(d)	 2. (c)	 3. (b)	 6. (b)

B.	 1.	one or more	 2. presentations	 3. animation 	 4. ribbon		

	 5.	slide	 6. create

C.	 1.	(d)	 2. (a)	 3. (b)	 4. (c)

D.	 1.	A theme is a set of predefined layouts that can be used to add a professional touch to your 
presentations. 

	 2.	Transition determines how your presentation moves from one slide to the next. 

	 3.	Slide transition is applied on the slides and animation is applied on the objects of the slides.

E.	 1.	To apply design themes: 

		  Step 1  Click on the Design tab. 

		  Step 2  Place your mouse pointer over any of the theme in the Themes group. 

		  Step 3  Click the design theme thumbnail when you find one that suits your needs. 

	 2.	Steps to run a slide show:
	 	 Step 1 Click the Slide Show tab. 
	 	 Step 2 Select From Beginning (to see the show from the first slide).  

	 3.	To add video to the presentation: 
		  Step 1 Click on Video command on the Insert tab on the ribbon to open Insert Video dialog 

box. 
		  Step 2 Navigate and select the video file to be inserted and click on Insert button. 
		  Step 3 This will insert the video along with the play control bar at the bottom of the clip. 
		  Step 4 Click on  button to preview the video. 

3.
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	 4.	To apply animation to text or objects:
		  Step 1  Click on the image or the text you would like to animate.
		  Step 2  Click Animations tab.
		  Step 3  You can either open the Animation pane or use the drop-down list.
		  Step 4  Select the animation effect you would like. 
		  Step 5 � Specify whether you want your animation to start On mouse click, After previous or 

With previous.
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Lab Session

Do yourself.

	More on MS Word 2010

Exercise
A.	 1.	(d)	 2. (c)	 3. (a)

B.	 1.	T		  2. T	 3. T	 4. F 

C.	 1.	page	 2. watermark	 3. footer	 4. buttons     5. page orientation 

4.
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Brain Teaser
	 1.	Mail Merge	 2. Watermark	 3. Smart Art

Lab Session
Do yourself.

	Learning MS Excel 2010

Exercise
A.	 1.	(d)	 2. (a)	 3. (c)	 4. (c)

B.	 1.	T		  2. T	 3. T	 4. T

C.	 1.	Excel	 2. create	 3. program	 4. merge cells  

D.	 1.	Spreadsheet is a program that allows you to store and analyse numerical data.  
	 2.	It displays quick access buttons of the Save, Undo and Redo commands. 
	 3.	AutoFill feature automatically fills a series of data in your worksheet. 

E.	 1.	The data in the form of numbers or text can be entered by just clicking on a cell and typing 
with the help of a keyboard. You can type data directly into the cell, or you can enter data 
using the Formula bar. 

	 2.	To set column width/row height:
	 	 Step 1  Select the column(s) or row(s) that you want to change. 
	 	 Step 2  Click on Format command in Cells group from Home tab. 
	 	 Step 3  Choose Column Width or Row Heights under Cell size from the drop-down list. 
		  Step 4  A Column Width or Row Height dialog box will appear. 
	 	 Step 5  �In the Column Width or Row Height box, type the value that you want your column 

or row to be. 

	 3.	To apply cell border:
		  Step 1 � On a worksheet, select the cell or range of cells that you want to add a border to, 

change the border style on, or remove a border from. 
	 	 Step 2  Go to the Font group in the Home tab. 
	 	 Step 3  Click the arrow next to Borders command. 
		  Step 4  Click on the border style you would like.  

5.

D.	 1.	Formatting refers to the layout of a paper and it is important to format a document to make 
it more understandable and attractive. 

	 2.	There are two types of orientation: Portrait and Landscape.

	 3.	Page margins are used to add blank space around the text of the document so it is easy to 
bind the papers. 

E.	 1.	The Header or Footer are used to save time and effort of the operator to enter same text on 
each page. It also reduces chances of errors like missing to enter details on a page. To add 
a header or footer:

	 	 Step 1  Click on the Insert tab.

		  Step 2  Click on Header or Footer command from the Header & Footer group.

		  Step 3  �You can choose from various available header/footer templates or choose Blank 
option to enter text of your choice.

	 	 Step 4 � This will open the respective Header or Footer section of the page. You can type the 
text you want to appear on each page.  

	 2.	The Mail Merge feature in MS Word is used to create personalised letters to be sent to many 
persons. It saves a lot of time, as you do not need to change the information for every person 
manually. 

	 3.	To find a word: 

	 	 Step 1  �Click on the Find command on Home tab. This will open Navigation panel on the left 
side of the MS Word window. 

		  Step 2  Type the word or phrase in the text box. 
		  Step 3  Click on the Search icon on the right side of the text box or press Enter key. 
	 	 Step 4 � The lower part of the Navigation panel will display a list of occurrences of the required 

text or phrase. 
		  Step 5  Press Enter key to move to the required occurrence of the text. 

		  To replace a word:
		  Step 1  �Click on the Replace command on Home tab. This will open Find and Replace dialog box. 
		  Step 2  Type the existing word or phrase that is to be changed in the Find what text box. 
		  Step 3  Type the new word or phrase in the Replace with text box. 
	 	 Step 4 � Click on Find Next and Replace buttons for selective replacement of the text or click 

on Replace All button to replace all occurrences of the existing text with the new text. 
	 4.	To insert mathematical equations:
		  Step 1  Click on the Insert tab. 
		  Step 2  In the Symbols group, click on the down arrow under the Equation command. 
		  Step 3  Click on the Insert New Equation. 
		  Step 4  A blank equation box saying ‘Type Equation here’ appears on the document. 
		  Step 5 � You can enter the equation using number keys on the keyboard and symbols on the 

ribbon under Design tab. 
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Brain Teaser
	 1.	Mail Merge	 2. Watermark	 3. Smart Art

Lab Session
Do yourself.

	Learning MS Excel 2010

Exercise
A.	 1.	(d)	 2. (a)	 3. (c)	 4. (c)

B.	 1.	T		  2. T	 3. T	 4. T

C.	 1.	Excel	 2. create	 3. program	 4. merge cells  

D.	 1.	Spreadsheet is a program that allows you to store and analyse numerical data.  
	 2.	It displays quick access buttons of the Save, Undo and Redo commands. 
	 3.	AutoFill feature automatically fills a series of data in your worksheet. 

E.	 1.	The data in the form of numbers or text can be entered by just clicking on a cell and typing 
with the help of a keyboard. You can type data directly into the cell, or you can enter data 
using the Formula bar. 

	 2.	To set column width/row height:
	 	 Step 1  Select the column(s) or row(s) that you want to change. 
	 	 Step 2  Click on Format command in Cells group from Home tab. 
	 	 Step 3  Choose Column Width or Row Heights under Cell size from the drop-down list. 
		  Step 4  A Column Width or Row Height dialog box will appear. 
	 	 Step 5  �In the Column Width or Row Height box, type the value that you want your column 

or row to be. 

	 3.	To apply cell border:
		  Step 1 � On a worksheet, select the cell or range of cells that you want to add a border to, 

change the border style on, or remove a border from. 
	 	 Step 2  Go to the Font group in the Home tab. 
	 	 Step 3  Click the arrow next to Borders command. 
		  Step 4  Click on the border style you would like.  

5.
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Brain Teaser
	 1.	By using the Wrap Text command present on the Alignment group in the Home tab, Sonia 

can make the text visible. 

	 2.	By inserting a column, Anaya can create space to enter the marks.

Lab Session
Do yourself.

Periodic Assessment 2
(Based on chapters 3 to 5)

A.	 1. Ctrl + F	 2. Ctrl + H	 3. Esc	 4. Shift + F5		

	 5.	Ctrl + X	 6. Ctrl + V

B.	
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Test Sheet 1
(Based on chapters 1 to 5)

Section A
A.	 1.	(d)	 2. (b)	 3. (c)	 4. (a, b)	 5. (a)
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B.	 1.	presentation    2. object    3. orientation    4. page    5. create
C.	 1.	Record button: It is used to start recording your voice. 

	 2.	Preview Results: It is used to see the preview of mail merge. 

	 3.	Orientation: It is used to define orientation of the page. 

	 4.	Stop Record button: It is used to stop the recording. 

	 5.	Border: It is used to set the border of a cell or text.

	 6.	SmartArt: It is used to represent food chains or hierarchy series.

D.	 1.	T		  2. T	 3. T	 4. F	 5. T

Section B
A.	 1.	Slide transition can be applied on the slides of a presentation whereas animation can be 

applied on the objects of a slide.
	 2.	A slide is a single page of a presentation.
	 3.	Page margin is the white space all around the printed area of the paper. 
	 4.	The horizontal divisions on a worksheet are called rows and the vertical divisions on a 

worksheet are called columns. 
	 5.	Spreadsheet is a program that allows you to store and analyse numerical data.

B.	 1.	To insert Clip Art: 

		  Step 1  Click on Insert tab.

		  Step 2  Click on Clip Art command.

		  Step 3  Enter keyword in the Search for: text box in the ClipArt pane. 

	 	 Step 4  Click on the image you want to insert in a slide.  
		  To insert a picture: 

		  Step 1  Click on the Insert tab. 

	 	 Step 2 � From the Images group, click on the Picture command. The Insert Picture dialog box 
appears. 

	 	 Step 3  Select the desired image file and click on Insert button.
	 2.	The Header or Footer are used to save time and effort of the operator to enter same text 

on each page. It also reduces chances of errors like missing to enter details on a page.  
To add a header or footer:

		  Step 1  Click on the Insert tab.
		  Step 2  Click on Header or Footer command from the Header & Footer group.
		  Step 3 � You can choose from various available header/footer templates or choose Blank 

option to enter text of your choice.
		  Step 4 � This will open the respective Header or Footer section of the page. You can type the 

text you want to appear on each page.
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	 3 .	The Mail Merge feature in MS Word is used to create personalised letters to be sent to many 
persons. It saves a lot of time, as you do not need to change the information for every person 
manually.

	 4.	To apply cell border:

		  Step 1 � On a worksheet, select the cell or range of cells that you want to add a border to, 
change the border style on, or remove a border from. 

	 	 Step 2  Go to the Font group in the Home tab. 
		  Step 3  Click the arrow next to Borders command. 
	 	 Step 4  Click on the border style you would like.
	 5.	To set column width/row height:

	 	 Step 1  Select the column(s) or row(s) that you want to change. 
		  Step 2  Click on Format command in Cells group from Home tab. 
	 	 Step 3  Choose Column Width or Row Heights under Cell size from the drop-down list. 
		  Step 4  A Column Width or Row Height dialog box will appear. 
	 	 Step 5 � In the Column Width or Row Height box, type the value that you want your column 

or row to be.

	 Introduction to Flash CS6

Exercise
A.	 1.	(b)	 2. (d)	 3. (a)

B.	 1.	frame	 2. layers	 3. left	 4. bottom

C.	 1.	Flash is a very useful application used in multimedia graphic programs. 

	 2. Layers in the Timeline panel provide a way to organise the elements of your movie. You can 
draw and edit objects on one layer without affecting objects on another layer. 

	 3. A frame is a single step of animation or picture on the flash timeline.  
	 4.	Text Tool, Pen Tool and Line Tool.

D.	 1.	To start Flash: 

		  Step 1  Click on Start button. 
		  Step 2  Click on All Programs. 
		  Step 3  Click on Adobe Flash CS6 Professional. 
	 2.	Properties panel allows you to set the properties of the objects that you have selected on the 

stage. It also provides options to change the settings of the Flash document such as stage 
dimensions and the animation’s frame rate. 

6.



11Thinkcode (Version 1.0)-VI (Answer Key)

	 3.	Panels provide easy access to controls that help you work with the content in your document. 
By default, the Properties panel and the Library panel are docked to the right side of the 
workspace. Any available panel can be opened by selecting it in the Window menu. 

	 4. The Timeline panel is used to control the images and sounds in your Flash document. The 
timeline is divided into frames. 

Timeline panel

Layers

Show/Hide 
Layer

Lock/Unlock 
Layer

Motion 
Editor

Playhead

Delete 
Layer

Timeline Current 
frame

Frame 
Rate

Elapsed 
Time

Insert Layer 
Folder

Insert 
Layer
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Lab Session
To start Flash:
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Step 1  Click on Start button. 
Step 2  Click on All Programs. 
Step 3  Click on Adobe Flash CS6 Professional. 
To create a new Flash document: 
Step 1  Click on File menu. 
Step 2  Click on New to open New Document dialog box. 
Step 3  Select ActionScript 3.0 from the Type list. 
Step 4  Click on OK button. 
To save a Flash file: 
Step 1  Click on File menu. 
Step 2  Click on Save to open Save As dialog box. 
Step 3  Enter a name for the file in File name text box. 
Step 4  Click on Save button. 
To exit Flash:
Click on Exit from File menu 
Or 
Press Ctrl + Q keys 
Or 
Press Alt + F4 keys 
Or 
Click on the Close button on top right corner of the Flash window.

	 	 Using Tools in Flash CS6

Exercise
A.	 1.	(c)	 2. (d)	 3. (a)	 4. (a)
B.	 1.	T		  2. T	 3. F	 4. T	 5. T
C.	 1.	Stroke Height text box is used to change width or thickness of the line.

	 2.	Freehand lines and curves. 

	 3.	Yes, there are some options:

		  (i)  Oval Tool				  (ii) PolyStar Tool

D.	 1.	Selection Tool: It is used to select and move objects. 

		  Hand Tool: It is used to move to different parts of the stage without changing the view of 
the stage.

	 2.	Properties of a line are Stroke Color, Stroke Size, Stroke Style and Cap. 

7.
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	 3.	The main difference between Star and Polygon options is that the Star option creates a star 
and the Polygon option creates a polygon with specified number of sides. 

Brain Teaser
	 1.	PolyStar Tool
	 2.	Gishi can draw a square by using the Shift key with the Rectangle Tool.

Lab Session
Do yourself.

Periodic Assessment 3
(Based on chapters 6 & 7)

A.	 1.	Selection Tool	 2. Hand Tool	 3. Rectangle Tool    4. Line Tool

	 5.	Eraser Tool  	   6. Pencil Tool	 7. PolyStar Tool

B.	 1.	Rectangle Tool	 2. Rectangle Tool

C.		

Options
box

Tools panelProperties panel Library panelStage

Menu bar

Timeline Panel

Pasteboard
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	Mobile App Development

Exercise
A.	 1.	(c)	 2. (a)	 3. (a)	 4. (a)

B.	 1.	T		  2. F	 3. T	 4. T 

C.	 1.	Apps or Applications are application software which run on mobile phones, computers, tablets, 
etc. 

	 2.	Apps that are developed for a specific platform (Operating System) and device are called 
Native Apps. 

	 3.	Components pane: This pane shows list of all the components added to the screen in 
hierarchical view.

D.	 1.	Hybrid apps are the apps that are combination of both native and web apps. These apps are 
developed in software like HTML5, CSS, JavaScript, JQuery, etc.

	 2.	To remove an app from our device, follow the given steps: 

		  Step 1  Tap the Setting icon on your mobile screen.

		  Step 2  Tap on Apps icon.

		  Step 3  Tap on Manage apps option.

		  Step 4  Select the App’s icon by tapping it.

		  Step 5  Tap on Uninstall icon. 

	 3.	The major difference is that a web app can be a small part of a website which provides a 
particular functionality. On the other hand, a website can contain many web apps.  Some of 
the examples of the Web apps are OLX, Flipkart, Amazon, and Pinterest. Web apps are actually 
web applications or websites which give a user with experience similar to native apps.

	 4.	To download any app from Play Store, follow the given steps:

		  Step 1  Tap on the Play Store Icon on Screen.

		  Step 2  Type the name of the app (Duolingo) you want to install in the search box.

		  Step 3  Tap on the app you want to install.

		  Step 4  Tap on the Install option. 

Brain Teaser
	 1.	Lifestyle Apps		  2. Hybrid Apps 

8.
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Lab Session
Do yourself.
	

	Computer Programming

Exercise
A.	 1.	(a)	 2. (c)	 3. (b)	 4. (c)	 5. (c)

B.	 1.	data, instructions	2. programming	 3. assembler 	 4. flow lines, arrows	

	 5.	consistent 

C.	 1.	(d)	 2. (c)	 3. (b)	 4. (a)

D. 	 1. An assembler is a program used to translate assembly language into machine language so 
that the computer can understand it.

	 2.	An algorithm is used to solve any problem or complition task in a sequential manner.

	 3.	A flowchart is a pictorial representation of the steps written in an algorithm. It is a set of 
instructions that can be followed to perform a specific task, workflow or process.

	 4. A program is a set of instructions given to the CPU in a pre-defined sequence to complete 
a task.

E. 	 1. 	HLL: High Level Language (HLL) is a programming language that enables a programmer to 
write programs that are machine independent. These languages are considered high level 
as they are closer to human languages and away from machine languages.

		  LLL: A low level language is a programming language that is machine dependent. A machine 
dependent language runs only on one particular type of computer. These programs are not 
easily portable to other type of computers.

	 2.	Following are the advantages of high level language:

		  •	� High level language is similar to English with vocabulary of words and symbols, therefore 
it is easier to run.

		  •	 High level language requires less time to write.

		  •	 High level language is easier to maintain.

		  •	 High level language is problem oriented rather than ‘Machine Based’.

9.
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	 3.	A compiler and an interpreter are software that convert the entire source program into 
machine language before executing it. 

	 4.	We need a translator program to converts high level language (HLL) program into a machine 
language. The language translator comprises of the following types: Assembler, Compiler 
and Interpreter.

F.	 1.	Connector		

	 2. Decision	

	 3. Process		

	 4. Input/Output

Brain Teaser
	 1.	a. Input box  		

		  b. Process box		

		  c. Output box

	 2.	Algorithm

Lab Session
	Do yourself.

	

Periodic Assessment 4
(Based on chapters 8 & 9)

A.	 1.	Machine language	 2. Assembler	 3. Connector   

B.	 Step 1 Start. 

	 Step 2 Read all three numbers and store them in A, B and C. 

	 Step 3 Add two numbers A and B. 

	 Step 4 Multiply the sum with the number C.

	 Step 5 Print the result.

	 Step 6 Stop.
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C.   

Is
X>Y?

Is
X>Z?

Is
Y<Z?

Is
Z<X?

Is
Y>Z?

Yes

Yes Yes

YesYes

No

No No

NoNo

Stop

Start

Input X, Y, Z

Print X, Z, Y Print Y, X, ZPrint X, Y, Z Print Z, X, Y Print Y, Z, X Print Z, Y, X

D.	
Start

Stop

Read P, r, t

Print SI

Calculate
SI = (P * r * t)/100
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Test Sheet 2
(Based on chapters 6 to 9)

Section A
A.	 1.	(c)	 2. (b)	 3. (d)	 4. (a)

	 5.	(b)	 6. (a) 	 7. (a)	 8. (b)

B.	 1.	Programming	 2. Connector, Flow Line	 3. Timeline 

	 4.	Pencil	 5. frame	 6. Stroke

Section B
A.	 1.	Yes, there are many ways to exit Flash.
		  (i)	 Click on Exit from File menu 
		  (ii)	 Press Ctrl + Q keys 

	 2.	Freehand lines and curves.

	 3.	An Algorithm is a set of steps in a sequential and ordered manner to solve any problem.

	 4.	Stroke Height text box is used to change width or thickness of the line.

	 5.	A program is a set of instructions given to the CPU in a pre-defined sequence to complete 
a task.

B.	 1.	Properties panel allows you to set the properties of the objects that you have selected on the 
stage. It also provides options to change the settings of the Flash document such as stage 
dimensions and the animation’s frame rate.

	 2.	Properties of a line are Stroke Color, Stroke Size, Stroke Style and Cap.

	 3.	The main difference between Star and Polygon options is that the Star option creates a star 
and the Polygon option creates a polygon with specified number of sides.

	 4.	The advantages of HLL are:
		  • � High level language is user friendly.  
		  • � High level language is similar to English with vocabulary of words and symbols, therefore 

it is easier to run.
		  •  High level language requires less time to write.  
		  •  High level language is easier to maintain.

	 5.	A compiler and an interpreter are software that convert the entire source program into 
machine language before executing it. 
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C.	 1.	
Start

Stop

Read A, B, C

Print 
Sum and Prod

Sum = A + B + C

Prod = A * B * C

	 2.	

Yes

No

Start

Stop

Print count

Is 
count < A

Count = 1

Read A

count = count + 1




