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Class

Logicode (Ver. 5.0)

	Computer Memory

 

1.	 a. (ii)	  	 b. (ii) 	 c. (i) 	 d. (iii) 	 e. (iii)
	 f. (ii)		  g. (ii)	 h. (i)
2.	 a. 1024 ExaBytes	 b. Nibble	 c. Flash	 d. Primary
	 e. Bottom right	 f. File	 g. Windows 11	 h. Deleted
3.	 a. T		  b. T	 c. F	 d. F
4.	 a. Read-only Memory (ROM) 	 b. Universal Serial Bus (USB) 
	 c. Cloud storage 	 d. Bits	 e. File 	 f. File extension 
	 g. Power button 	 h. Task View button
5.	 a.	There are three types of ROM. Programmable Read-only Memory (PROM), Erasable 

Programmable Read-only Memory (EPROM), Electrically Erasable Programmable Read-only 
Memory (EEPROM).

	 b.	Cloud storage allows us to store data in an off-site location which can be accessed later on 
any computer anywhere through the Internet. If we store data in cloud storage, we can save 
money that would otherwise have to be invested in paying for storage devices.

	 c.	 Primary memory Secondary memory
Primary memory is the main memory of 
the computer. It is also known as internal 
memory. Example: RAM, ROM

Secondary memory is the external memory 
of the computer that can store large 
amounts of data permanently. Example: 
Hard disk, CD, DVD, etc.

	 d.	Solid State Drive (SSD)
	 e.	To create a folder, follow the given steps: 
	 	 1  Open the location, where you want to create a folder. 
		  2  Right-click on any empty area and select the New option. 
		  3  Click on the Folder option.
	 f.	 The steps to rename a file/folder as follows:
	 	 1  Right-click the file/folder that you want to rename and click on Show more options. 
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		  2  Select the Rename option. 
		  3  Type a new name for the file/folder and press the Enter key.
	 g.	A folder is a file cabinet where we can store our files and other subfolders.
	 h.	 Copying Moving

Copying a file or folder means making a 
copy of the original file or folder, either in 
the same location or in another location, 
without removing it from its original 
location.

We can move files and folders from one 
place to another. When we move a file 
or folder, it is removed from its original 
location and placed at the new location.

5.	 a.	Secondary memory devices are best to do so because they can store large amounts of data 
permanently. They are not directly accessed by the CPU and also cheaper in comparison to 
primary memory. 

	 b.	The issue is likely caused by RAM (Random Access Memory), as it is volatile and loses data 
when the computer is turned off. He should save data to permanent storage (like a hard disk 
or SSD) before turning off the computer.

	 c.	To restore a file from the Recycle Bin, follow the given steps: 
		  1  Double-click on the Recycle Bin icon on the Desktop. 
		  2  Right-click on the file in the Recycle Bin that you want to restore. 
		  3  Select the Restore option from Context menu. 
		  4  You can also click on Restore all items to restore all the files from Recycle Bin.
	 d.	She should create folders by follow the given steps: 
		  1  Open the location, where you want to create a folder. 
		  2  Right-click on any empty area and select the New option. 
		  3  Click on the Folder option. 
		  4  Type the name of the new folder and press the Enter key. 
		  Now she should move the files to their respective folders by follow the given steps: 
		  1  Open the location containing the files you want to move. 
		  2  Right-click on the file and select the Cut option. 
		  3  Open the new location where you want to move the file. 
		  4  Right-click on the empty area and select Paste option.
	 e.	To relocate a folder containing photos from one drive to another, Aditi can follow these steps:
		  1  Open the location containing the folder you want to move. 
		  2  Right-click on the folder and select the Cut option. 
		  3  Open the new location where you want to move the folder. 
		  4  Right-click on the empty area and select Paste option.

	MORE ON WORD 2021

 

1.	 a. (ii)		  b. (iii)	 c. (i)	 d. (ii)	 e. (iii)
	 f. (i)		  g. (i)	 h. (iv)
2. 	 a. Rotate 	 b. Shadowed 	 c. Wrap Text 	 d. Shape Format
	 e. Delete Column	 f. Border	 g. Alt + Home	 h. Insert
3.	 a. F		  b. T	 c. F	 d. T	 e. T
	 f. F		  g. T	 h. F
4.	 a. Pictures 	 b. WordArt	 c. Bing	 d. Text Effects
	 e. Alt + End 	 f. Clicking the table handle 	 g. Tab key
5.	 a. To add text into a shape, follow the given steps: 
		  1  Select the shape and right-click on it. 
		  2  Choose the Add Text option. 
		  3  Type the desired text.
	 b.	To delete a row, follow the given steps:
		  1  Select and right-click the row that you want to delete.
		  2  Click on the Delete Rows option.
	 c.	To wrap the text around a picture, follow the given steps:
		  1  Click on the picture to select it.
		  2  Click on the Picture Format tab.
		  3  Click the Wrap Text option.
		  4  Select any Wrap Text style you prefer for the picture.
	 d.	To insert a picture from a file, follow the given steps:
		  1  Click on the Insert tab.
		  2  Click on drop-down button of Pictures option.
		  3  Select This Device option from the drop-down menu to insert picture from your device.
		  4  Select the picture that you want to insert.
		  5  Click on the Insert button.
	 e.	The shortcut key to move to the first cell of the row is Alt + Home.
	  f.	To insert a column in a table, follow the given steps:
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	MORE ON WORD 2021

 

1.	 a. (ii)		  b. (iii)	 c. (i)	 d. (ii)	 e. (iii)
	 f. (i)		  g. (i)	 h. (iv)
2. 	 a. Rotate 	 b. Shadowed 	 c. Wrap Text 	 d. Shape Format
	 e. Delete Column	 f. Border	 g. Alt + Home	 h. Insert
3.	 a. F		  b. T	 c. F	 d. T	 e. T
	 f. F		  g. T	 h. F
4.	 a. Pictures 	 b. WordArt	 c. Bing	 d. Text Effects
	 e. Alt + End 	 f. Clicking the table handle 	 g. Tab key
5.	 a. To add text into a shape, follow the given steps: 
		  1  Select the shape and right-click on it. 
		  2  Choose the Add Text option. 
		  3  Type the desired text.
	 b.	To delete a row, follow the given steps:
		  1  Select and right-click the row that you want to delete.
		  2  Click on the Delete Rows option.
	 c.	To wrap the text around a picture, follow the given steps:
		  1  Click on the picture to select it.
		  2  Click on the Picture Format tab.
		  3  Click the Wrap Text option.
		  4  Select any Wrap Text style you prefer for the picture.
	 d.	To insert a picture from a file, follow the given steps:
		  1  Click on the Insert tab.
		  2  Click on drop-down button of Pictures option.
		  3  Select This Device option from the drop-down menu to insert picture from your device.
		  4  Select the picture that you want to insert.
		  5  Click on the Insert button.
	 e.	The shortcut key to move to the first cell of the row is Alt + Home.
	  f.	To insert a column in a table, follow the given steps:
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		  1  Right-click in the cell where you want to insert column and click on the Insert option.
		  2  Select the desired option.
	 g. A table is an arrangement of text in the form of rows and columns.
	 h. Splitting cells Merging cells

Splitting cells means dividing one cell into 
two or more smaller cells.

Merging cells means joining two or more 
cells to make one big cell.

6.	 a. Use Insert → Shapes to add banners or callouts. Style them using the Shape Format tab with 
colours and effects to match your theme. 

	 b. Editing means changing text appearance like font, size, colour, and alignment to improve 
the document.

	 c.	Use a table to organise names and ages. It keeps the data neat and easy to read.
	 d.	Use table styles, borders, shading, and adjust column widths to make the table clear and 

visually appealing.
	 e.	By pressing the keys Alt + End.

	Advanced Features of Word 2021

 

1.	 a. (iii) 		 b. (i) 	 c. (ii) 	 d. (i) 	 e. (iii) 
2.	 a. Font 	 b. Find 	 c. Text Highlight Color 
	 d. Calibri (Body) 	 e. Columns 
3.	 a. T 		  b. T 	 c. T 	 d. T 	 e. T
4.	 a. Bullets 	 b. Ctrl + R	  c. Line spacing 	 d. Replace
5.	 a.	The blank space between two lines of a paragraph is called line spacing.
	 b.	Highlighting the text means focussing on a particular text.
	 c.	Merging is used to create a larger cell. Cells can be merged either column-wise or row-wise.
	 d.	(i)	 Ctrl + F
		  (ii)	 Ctrl + H
		  (iii)	Ctrl +  J
		  (iv)	Ctrl + R
6.	 a.	Text Highlight Color tool 
	 b.	Find and Replace tools
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	 c.	To create a list in Word, you can use the Bullet or Numbering feature.
	 d.	To place the title neatly between the left and right edges of the page, Pankaj should use the 

Centre Alignment feature. This will align the title in the middle of the page.
	 e.	Aarav should use the Line Spacing feature.

 Introduction to Powerpoint 2021

 

1.	 a. (ii)		  b. (iv)	 c. (iii) 	 d. (i)
2.	 a. Microsoft	 b. Presentation 	 c. Commands 	 d. Save 
3.	 a. F 	 	 b. F 	 c. T 	 d. F 
4.	 a. Four types 	 b. Ribbon 	 c. Status bar 	 d. Slide
5.	 a.	 (i)	 Ctrl +M
		  (ii)	 Ctrl +S
		  (iii)	 Alt + F4
		  (iv)	 F5
	 b.	We use the Title slide to add an introduction to our presentation.
	 c.	 PowerPoint 2016 window consists of the following components: 
		  (i)	� Title Bar: It is present on the top of the PowerPoint window. It displays the name of 

the presentation you are working on. 
		  (ii)	� Quick Access Toolbar: It provides shortcuts to commonly used commands like Save, 

Undo and Redo.
	 d.	To open an existing presentation, follow the given steps:
	 	 1  Click on the File tab.
	 	 2  Click on the Open button. 
	 	 3  Click on Browse option. 
	 	 4  Select the location to open a saved file.
	 	 5  Click on the presentation file you want to open.
	 	 6  Click on the Open button.
6.	 a.	To delete a slide, follow the given steps:
	 	 1  Right-click on the slide you want to delete from the Slide Pane.
	 	 2  Click on the Delete Slide option.
	 b.	To add a new slide, follow the given steps:
	 	 1  Click on the New Slide drop-down list in the Slides group.
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	 	 2  Select the type of slide you want.
	 c.	 In Quick Access Toolbar.
	 d.	Title bar
	 e.	Status bar

	MORE ON POWERPOINT 2021

 

1.	 a. (ii) 		 b. (iii) 	 c. (iv) 	 d. (i) 	 e. (iii)
2.	 a. Backstage 	 b. Layouts 	 c. Home 	 d. Presenter 
	 e. Slide Show
3.	 a.	To change the slide layout, follow these steps: 
		  1  Select the slide to change the layout.
		  2  Click on the Home tab.
		  3  Click on Layout drop-down arrow present in the Slides group. 
		  4  Choose the desired layout.
	 b.	Some of the Slide Layouts are Title Slide, Title and Content, Section Header, Two Content, 

Blank, Comparison, Content with Caption, Title Only and Pictures with Caption.
	 c.	Slide Sorter view shows the miniature version of all slides. Here, we can easily change the 

order of the slides. Whereas Reading view is used when you want to view a presentation not 
in full screen but in a window with simple controls that make the presentation easy to review. 
The ribbon and the slides/outline pane are not visible.

	 d.	To change the theme, follow the given steps:
		  1  Click on the Design tab. 
		  2  Select a theme from the Themes group. 
		  3  Select a variant from the Variants group.
4.	 a. Design tab
	 b.	Select the slide to change the layout → Click on the Home tab → Click on Layout drop-down 

arrow present in the Slides group → Choose Comparison Layout.  
	 c.	Slide Sorter view
	 d.	Reading view
	 e.	Outline view
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	Creating Digital Landscapes

 

1. 	 a. (iv) 		 b. (i) 	 c. (iii) 	 d. (iii) 	 e. (ii) 
2.	 a. Sketchpad	 b. Hidden	 c. Pattern	 d. Star	 e. Layer
3.	 a. F		  b. T	 c. F	 d. F	 e. T
4.	 a.	Layers are like clear, plastic sheets stacked one on top of the other in a drawing. Each layer 

holds a different part of your artwork which help you keep your drawing neat and organised.
	 b.	The Mirror Brush is a digital tool used to make symmetrical designs. Whatever is drawn on 

one side of the canvas is copied on the other side, making it easy to create balanced patterns.
	 c.	The steps to add shapes in Sketchpad are as follows:
		  1  Click on the Shape tool.
		  2  Click on the Choose Shape option.
		  3  Select Rectangle from the available shapes.
		  4  Drag the mouse on the canvas and draw the rectangle.
	 d.	The options available in the Hamburger icon are as follows: 
		  •  Send to Back: Moves the layer behind others. 
		  •  Send to Front: Moves the layer slightly in front of another. 
		  •  Send Backwards: Moves the layer all the way to the back.
	 e.	To select multiple layers at once, press and hold the Shift key.
	 f.	 The steps to create a design for the digital rangoli are as follows:
	 	 1  Add a yellow colour Octagon.
	 	 2  Select Mirror Brush from the Choose Brush option.
	 	 3  Set the Sides to 8.
	 	 4  Select the Fill colour.
	 	 5  Select the Outline colour.
	 	 6  Drag the mouse in the canvas area to create the pattern.
5.	 a.	Nitin should use Mirror brush.
	 b.	To correct the layer order without starting over, Aditi can use the Layers Panel in Sketchpad. 

She can drag the layers up or down to change their order, adjusting the z-position of the 
element and placing it in the desired position.

	 c.	To add clipart, follow the given steps: 
	 	 1  Click on the Clipart tool.
	 	 2  Click on the Choose Graphic down arrow.
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	 	 3  Type Cake in the search bar.
	 	 4  Select the cake you want to add.
	 	 5  Resize the cake and drag it to the correct spot.
	 d.	To apply a gradient to the digital rangoli, follow the given steps:
	 	 1  Click on the Vector Fill tool. 
	 	 2  Select the Radial Fill to apply to the rangoli. 
	 	 3  Click on the canvas to apply the colour to the background.
	 e.	Using layers allows Kiran to organise her artwork by keeping elements like the background, 

text, and images separate. This way, she can edit each component without affecting the 
others.

	Scratch Coding Adventures

 

1. 	 a. (iii) 		 b. (i) 	 c. (iii) 	 d. (i) 
2.	 a. Vector 	 b. Erase All 	 c. Events 	 d. Hide 	 e. Coding
3.	 a. (iii) 		 b. (iv) 	 c. (v) 	 d. (ii) 	 e.	 (i) 
4.	 a. Sound blocks are as follows: 
		  (i)	� play sound [Meow] until done – Plays the sound and waits until it finishes before continuing 

the script.
		  (ii)	 start sound [Meow] – It is used to play the selected sound without pausing the script.
	 b.	These blocks have notch at the top and bumped bottom. They stack on top of each other to 

tell the sprite what to do, like move, turn or say something.
	 c.	Custom costumes are different appearances you can assign to a sprite using tools in the 

Costumes tab.
	 d.	Comparison operator allow you to compare the relationship between two values or variables. 

It will compare two numbers and decide whether it is true or false. Comparison operators 
are used with the if... then block.

	 e.	Difference between the ‘if then’ and ‘if then else’ blocks are as follows:

If then block If then else block
Checks if a condition is true. If yes, it performs 
the action. If not, it does nothing.

Checks a condition and performs one action 
if it’s true or a different action if it’s false.

5.	 a.	�Vikram should use the division ( / ) operator block to divide the candies equally among 4 
friends.

7.
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	 b.	Jiya should use the “think [message] for [seconds]” block to show a thought bubble with a 
message.

	 c.	Kiran should use switch costume to costume 2 block from Looks category.
	 d.	Meera should use vector mode to design her logo.
	 e.	Rohan should use if on edge, bounce block from motion category.

	Shapes in Scratch

 

1.	 a. (iii)		 b. (ii)	 c. (ii)	 d. (iii)
2.	 a. Polygon	 b. Repeat	 c. Square	 d. Pen down
3.	 a. T		  b. F	 c. T	 d. T	 e. F
4.	 a.	Pen blocks provide a trail for the sprite and give instructions to change the colour, size and 

shade of the trail. These blocks are colour-coded as dark green and used to draw shapes in 
Scratch.

	 b.	To draw a line, follow the given steps: 
		  1  Drag a when flag clicked block to the scripts area from the Events menu.
		  2  Drag a set pen color to block into the scripts area. 
		  3  Drag a set pen size to block into the scripts area and change the size to 5. 
		  4  Drag a pen down block. 
		  5  Drag a move 10 steps block and change it to move 50 steps.
		  6  Click the green flag at the top right corner of the stage to run your program.
	 c.	This block makes the script wait for the number of seconds specified by us, before the next 

block follows. Sometimes, it is important to use the Wait block otherwise, the movements 
would occur so quickly that it would be difficult to observe them.

	 d.	
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	 e.	Steps to Work with Two Sprites in Scratch are as follows: 
		  1  Open Scratch. A sprite is already added.
		  2  Click the Choose a Sprite button (looks like a cat face) at the bottom right. 
		  3  Pick a new sprite (like a dog, ball, etc.). → Now you have two sprites on your stage. 
		  4  Click on Sprite 1 (like the cat). 
		  5  Add your blocks (example: move, say, or turn). 
		  6  Now click on Sprite 2 (the one you added). 
		  7  Add different blocks for this sprite.
5.	 a.	The first script will draw square. To create a triangle repeat 3 times, move 100 steps and turn 

120 degrees.
	 b.	45 degrees.

	 c.	

	 d.	You can add pen blocks by clicking on the Add Extension button, then clicking on Pen 
extension to add it.  

	 e.	60 degrees.

	Categories of Robots

 

1.	 a. (ii) 		 b. (iii) 	 c. (ii) 	 d. (iii)	 e. (ii) 
2.	 a. F 		  b. F 	 c. T 	 d. F 	 e. T 
3.	 a.	Pre-programmed robots are designed to work in a controlled environment. They are 

used in: 
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		  •	� repetitive tasks that are considered boring because of their repetitive nature or too 
dangerous to be done by humans. 

		  •	 situations where the task requires a high level of accuracy.
	 b.	Saudi Arabia granted Sophia the title of the world’s first robot citizen.
	 c.	Drone controllers are used for surveillance purposes and detecting landmines on the 

battlefield.
	 d.	Augmenting robots are designed to enhance human capability or replace the abilities, a 

human may have lost. They are used in medicines.
4.	 a.	Augmenting robot like an exoskeleton can be used. It helps by enhancing the worker’s 

strength and supporting physical movement. 
	 b.	I would recommend an autonomous robot like the Roomba vacuum cleaner. It works 

independently and helps clean the house without requiring physical effort.
	 c.	Palki
	 d.	Tele-operated robots
	 e.	WoeBot 
 


