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	Safeguarding your Computer

  (Page no. 7)

1, 2 and 4

byte Quest  (Page no. 16)

1. (d)		 2. (b)	 3. (a)	 4. (c)

TeCh Ready

A.	 1. (iii)	 2. (i)	 3. (ii)	 4. (iii)	 5. (ii)	 6. (i)	

B.	 1. Malware	 2. Biometric	 3. Adware  	 4. Retina biometrics 
	 5. Password

C.	 1. F	 2. F	 3. T	 4. T	 5. T

D.	 1.	� Authentication is the process of verifying a user’s identity before granting him or her 
access to a computer system. In private and public computer networks (including the 
Internet), authentication is commonly done through the use of login passwords. Some of 
the authentication procedures as follows: 

		  i.	 Password Protection 
		  ii.	 Biometric Authentication 
		  iii.	 Voice Recognition 

	 2.	� A computer virus is a program that is able to copy itself when it is run. It gets activated 
each time the program or file to which it is attached is opened or executed. It is the most 
common type of malware. It can spread itself by infecting other programs or files. 

	 3.	� a.	� Trojan Horse: A trojan horse is a malicious program. It represents itself as helpful software 
program. Once the user clicks on it to agree to run it, it gains access to sensitive data 
and then modifies, blocks, or deletes the data. 

		  b.	� Spyware: A spyware steals important information and data on the device, such as account 
passwords or bank details. It observes the user’s activity without their knowledge.

1.
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	 4.	� An infected computer system will: 
		  i.	 start displaying unusual messages on the screen.
		  ii.	 take more time to load the programs.

	 5.	� Ways to protect our computer: 
		  i.	 Download only legal software 
		  ii.	 Use the original version of Windows 
		  iii.	� Scan Pen drive, CD and any other external storage device for viruses before opening 

in computer 

	 6.	� A worm is similar to virus but it can copy itself and spread rapidly to any device attached. 
A worm does not need any program to activate it. 

A.	 1. AVG 	 2. Norton 	 3. McAfee 

B.

Some tips to 
safeguard from  

Hacking

Don’t 

plug in to devices you 
are not sure about. 

Always download trusted

 Apps from Internet and 
check permissions and 

authentication. 

1. He should scan the pen drive before using it, to protect his computer.

2. I’ll suggest him to neither open these emails nor reply to them.

	Formulas and Functions in Excel

  (Page no. 21)

Total marks obtained = 95 + 85 + 90 = 270
Maximum marks can be obtained = 100 + 100 + 100 = 300
Average marks = 270/3 = 90
Percentage = (270/300) x 100 = 90%

byte Quest  (Page no. 28)

1. -500	 2. 1250	 3. 2400	 4. 2

2.
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byte Quest  (Page no. 35)

1. 5	 2. Comp	 3. 7	 4. 5	 5. 3

TeCh Ready

A.	 1. (i)	 2. (i)	 3. (ii)	 4. (iii)

B.	 1. Functions	 2. Equal to 	 3. Square root	 4. Dollar ($)

C.	 1. T	 2. F	 3. T	

D.	 1.	 NOW(): It returns the current system date and time.
		  TODAY(): It returns the current date.

	 2.	� It returns the length of the text string. Example:
		  Input: =LEN(“Touch“)
		  Output: 5

	 3.	� Rules for using functions are:
		  (i) 	 All Excel functions must begin with = sign.
		  (ii) 	 Function name must be a valid name.
		  (iii) 	Function must be followed by opening and closing parenthesis.
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1.	 =SUM(range)

2.	 =NOW()
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	More on Excel
  (Page no. 38)

1. Deepak	 2. Anurag

byte Quest  (Page no. 43)

1. Column Chart	 2. Pie Chart 	 3. Area Chart 	 4. Line Chart 

TeCh Ready

A.	 1. (ii)	 2. (i)	 3. (iv)

B.	 1. Column	 2. Scatter charts 	 3. Plot area

C.	 1. F	 2. F	 3. F	 4. T

D.	 1. (b)	 2. (c)	 3. (d)	 4. (a)

E.	 1.	� a. �Data series is related to the set of values. It is represented by the bars or slices that 
represent the data values.

		  b. �Legend is a key which shows the meanings of symbols and colours used in the chart.

	 2.	� Custom Sorting is used when more than one column is to be sorted in such a way that the 
first column is in ascending order and if some data is the same for more than one row, 
then the second column of such rows gets sorted in descending order.

	 3.	 To create a chart, follow the given steps: 

		  Step 1: Select the range of cells. 

		  Step 2: Click on the Insert tab. 

		  Step 3: Click on the Insert Column or Bar Chart button. 

		  Step 4: Select the desired Chart option.

A.	 Do it yourself.

B.	 1. Bar Chart	 2. Sorting	 3. Ascending Order

1. Sorting data

2. Pie Chart

3.
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Periodic Assessment 1
(Based on chapters 1 to 3)

A.	 1. Code Red Worm 	 2. Zeus 	 3. Emotet 	 4. Pegasus 

B.	

1  Select 
the data to 
be sorted.

3  Click on the Sort & Filter button.2  Click on Home tab.

4  Select Sort A to Z (for text) or Sort Smallest to 
Largest (for numbers) to sort the data in ascending order.

C.	 1. �Line chart is used to show trends over a period of time. It is similar to plotting a graph on 
graph paper with its values on the X and Y axes.

	 2. �The bar chart displays the data in the form of long rectangular rods, also called bars. These 
bars can be placed horizontally on the chart area.

D.	 1. It returns the specified number of characters from the right side of the text string.  

	 2. �It checks whether the given condition is met, and returns value1 if the condition evaluates 
to true, and value2 if the condition evaluates to false.   

	Advanced Features of PowerPoint 2016

  (Page no. 49)

1. From Beginning	 2. Online Pictures	 3. Shapes 	 4. WordArt

BYTE Quest   (Page no. 54)

1. Normal View	 2. Slide Sorter View	 3. Notes Page View	 4. Reading View

4.
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BYTE Quest   (Page no. 60)

	 1. AIFF Audio (.aiff), AU Audio (.au) 

	 2. (iv) .mp3

TeCh Ready

A.	 1. (ii)	 2. (iv)	 3. (iii)	 4. (iii)	 5. (ii)

B.	 1. Insert 	 2. Slide 	 3. Text	 4. Object 

C.	 1. F	 2. F	 3. F	 4. T	 5. T

D.	 1. Slide Show view allows to view the presentation in full screen mode.

	 2. �Slide transition determines how presentation moves from one slide to next whereas Animation 
is the addition of special visual/sound effects to the text and graphics in a slide.

	 3. �To insert an audio file, follow the given steps: 

	 Step 1: Click on the Insert tab. 

	 Step 2: Click on the Audio button. 

	 Step 3: Choose the desired option. 

	 Step 4: Select the folder.

	 Step 5: Select the file. 

	 Step 6: Click on the Insert button. 

	 Step 7: Click on Play/Pause button to play or pause the audio.

	 4. �Importing data from files, such as media files or objects created in Microsoft Office 
applications, enhances the understanding of a presentation. It also helps explain our views 
more effectively than text alone.

	 5. Four views in PowerPoint are: 

	 a. Normal View

	 b. Slide Sorter View 

	 c. Notes Page View 

	 d. Reading View
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1. He can add Action buttons to do so.

2. She can apply Animation to do so.

	Algorithmic Intelligence

  (Page no. 66)

1 12 5 18 20 27 13 1 10 15 18 27 3 25 3 12 15 14 5

A L E R T M A J O R C Y C L O N E

code Quest   (Page no. 68)

3. web browser
4. www.google
5. who developed first code? 
6. Enter key

5.
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code Quest   (Page no. 71)

	 Step 1: Start

	 Step 2: Take triangle’s height and base

	 Step 3: Calculate, area of triangle = 1/2(Base x Height)

	 Step 4: Print area of triangle

	 Step 5: Stop

TeCh Ready
A.	 1. (iii)	 2. (ii)	 3. (iv)

B.	 1. F	 2. T	 3. T	 4. T	 5. F

C.	 1.	� An algorithm is a set of steps in a sequential manner to solve a problem or to complete a task.

	 2.	� A Mind Map is a problem-solving technique that allows us to organise ideas, thoughts or 
concepts and their relationship in a graphical manner.

	 3.	� Rectangle- It shows a process or action step.

	 4.	 Step 1: Start

		  Step 2: Select the paragraph that you want to copy in Word.

		  Step 3: Click on the Copy command from the Home tab.

		  Step 4: Click the mouse where you want to paste the selected paragraph.

		  Step 5: Click on the Paste command from the Home tab.

		  Step 6: End

Yes

No

Stop

Start

Read MARKS

Print "Fail"

Print "Pass"If 
MARKS > 40
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1. (i) Parallelogram 	 (ii) Rectangle 	 (iii) Parallelogram

2. She should write an algorithm before making a flowchart.

Periodic Assessment 2
(Based on chapters 4 & 5)

A.	 1. Insert tab	 2. Animations tab	 3. Transitions tab 

	 4. Slide Show tab

B.	

Yes

No

Stop

Start

Input A, B

A=A+1

Print AIf
A>B

C.	

Yes

No

Stop

Start

Read X, Y

Print Y

Print XIf
X>Y

(Based on chapters 1 to 5)
Test Sheet 1

A.	 1. (ii)	 2. (iii)	 3. (iv)	 4. (iv)	 5. (i)	 6. (iv)	 7. (ii)	 8. (ii)

B.	 1. Column	 2. Slide	 3. Text	 4. Biometric	 5. Dollar
	 6. Scatter charts	 7. Plot area	 8. Object
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C.	 1. F	 2. F	 3. T	 4. F	 5. T

D.	 1. (b)	 2. (c)	 3. (d)	 4. (a)

E.	 1.	� Ways to protect our computer: 

	 •  Download only legal software 
	 •  Use the original version of Windows 
	 • � Scan Pen drive, CD and any other external storage device for viruses before opening in 

computer

	 2.	� To create a chart, follow the given steps: 

		  Step 1: Select the range of cells. 

		  Step 2: Click on the Insert tab. 

		  Step 3: Click on the Insert Column or Bar Chart button. 

		  Step 4: Select the desired Chart option. 

	 3.	� Action buttons help other people using our presentation in navigating from one slide to 
another. We can also assign a particular task to be done when the viewer of the presentation 
clicks on an action button. 

	 4.	 Step 1: Start

		  Step 2: Select the paragraph that you want to copy in Word.

		  Step 3: Click on the Copy command from the Home tab.

		  Step 4: Click the mouse where you want to paste the selected paragraph.

		  Step 5: Click on the Paste command from the Home tab.

		  Step 6: End

	 5.	� a. �Trojan Horse: A trojan horse is a dangerous virus. It represents itself as helpful software 
program. Once the user clicks on it to agree to run it, it gains access to sensitive data 
and then modifies, blocks, or deletes the data.

		�  b. �Adware: An adware tracks user’s browser and download history and keeps popping 
advertisements on the screen.

	 6.	 It returns the length of the text string. Example:
		  Input: =LEN(“Touch“)
		  Output: 5

	 7.	 To insert an audio file, follow the given steps: 
		  Step 1: Click on the Insert tab. 
		  Step 2: Click on the Audio button. 
		  Step 3: Choose the desired option. 
		  Step 4: Select the folder. 
		  Step 5: Select the file.
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		  Step 6: Click on the Insert button. 
		  Step 7: Click on Play/Pause button to play or pause the audio. 

	Using MakeCode Arcade

  (Page no. 78)

Step 1: Start
Step 2: Take first alphabet of the name of the book
Step 3: Go to the that alphabetical section of the library
Step 4: Search the book in that section and take it out
Step 5: Stop

code Quest  (Page no. 81)

1. Syntax

2. Programming language

code Quest  (Page no. 84)

1. Dictionary

2. Pseudocode

code Quest  (Page no. 100)

1. Event 	 2. Event Handler

TeCh Ready

A.	 1. (iii)	 2. (i)	 3. (ii)	 4. (iii)	 5. (iii)		  6. (ii)

B.	 1. Pseudocode 	 2. dictionary 	 3. say 	 4. MakeCode Arcade

	 5. Event handler

C.	 1. T 	 2. F 	 3. T 	 4. F	 5. T

D.	 1.	� The block toolbox is your source for all the necessary code elements to create your game. 
These elements are neatly categorised in drawers based on their functions and methods. 

	 2.	� Integrated Development Environment 
	 3.	� Pseudocode is used to describe the steps of an algorithm in a human-understandable language. 

It has no syntax and can be easily understood by a layman. 

6.
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	 4.	� The splash block in MakeCode displays a message on the screen for a specified duration.  
		�  Splash block will get execute when you click on ‘start the simulator’ button. In this ‘start 

the simulator’ button is an event handler.   
		  5.	 �A bug is an unexpected problem in your program. You follow a defined sequence to write 

a program, from which you expect to return a specific output. Any change in the expected 
and actual output of the program is said to be the result of a bug. 

		  6.	� The pause block in MakeCode temporarily stops program execution for a specified duration 
in milliseconds, allowing for timed delays between actions.  

�
1. Pencil 	 2. Eraser 	 3. Rectangle 	 4. Fill
5. Circle 	 6. Line

1. By creating a sprite using the image editor.

2. Pause Block

	Introduction to Python

  (Page no. 104)

1. 48		 2. 8.4	 3. 1	 4. -190	 5. 38

code Quest  (Page no. 111)

1. Python	 2. Interactive Mode	 3. Script Mode

code Quest  (Page no. 112)

	 Roll no = 201 

	 Student Name = “Chirag” 

	 Section = ‘A’

TeCh Ready

A.	 1. (iv)	 2. (i)	 3. (iii)	 4. (i)

B.	 1. Prompt	 2. Guido van Rossum	 3. Variables	 4. print( )	 5. line by line

7.
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C.	 1. T	 2. T	 3. F	 4. T

D.	 1.	� The Features of Python are: 
	 	 • Open Source 
	 	 • Object-oriented 
	 	 • Easy to code

	 2.	� Prompt is a blinking cursor after the symbol (>>>), which indicates the Python interpreter 
is ready to accept commands. 

	 3.	� a = 10 
	 	 b = 20 
	 	 print ("a=", a) 
	 	 print ("b=", b) 
	 4.	� Two variable naming conventions are: 
	 	 • A variable name must start with a letter (a-z, A-Z), or an underscore (_). 
	 	 • A variable name cannot start with digits(0-9). 
	 5.	� There are two components of Python IDLE window: 
	 	 • �Menu Bar: The Menu Bar of Python IDLE window is similar to the Menu Bar of other 

programs. It has various menus such as File, Edit, Shell, Debug, Options, Window and 
Help. 

	 	 • �Prompt: You will see a blinking cursor after the symbol (>>>) in the window. This is 
known as the Prompt. The Prompt allows the user to enter commands directly into 
Python and get an output instantly by pressing the Enter key. 

	 6.	� The input( ) function takes the user’s input while a program executes. On the other hand, 
the print( ) function prints or sends the output to the standard output device, which is 
usually a monitor. 

1. Sanjay	 2. 10 10	 3. 10 20 30

1. Script Mode 
2. float() 

Periodic Assessment 3
(Based on chapters 6 & 7)

A.	 1.	� Bar code scanner	 2.	 Booking tickets	 3.	� Printer
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B.	 Menu bar

Prompt

C.	 1.	 Sum of 2 and 3 is 5

	 2.	 Student Name: Shikha

		  Subject: Computer

		  Marks obtained: 86

	Human vs Machine Intelligence

  (Page no. 116)

Do it yourself.

 Quest  (Page no. 118)

1.	 The ability to understand and use spoken and written language.
2.	� Emotions, self-awareness, passion and motivation enable us to accomplish complex cognitive 

tasks. 

TeCh Ready
A.	 1. (iii)	 2. (ii)	 3. (iv)

B.	 1. F	 2. T	 3. T	 4. F

C.	 1. � S.No. Human Intelligence Artificial Intelligence

1. Created by nature Created by human intelligence

2. Processes information slower Process information with high speed

	 2. �Two capabilities of human brain are as follows: 

	 • Learn from different experiences 
	 • Understand complex concepts 

Do it yourself.

8.
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1. Do it yourself.
2. Human Intelligence

	AI Technologies

  (Page no. 122)

Do it yourself.

 Quest   (Page no. 125)

Siri, Alexa

TeCh Ready

A.	 1. (ii)	 2. (iv)	 3. (i)	 4. (iv)

B.	 1. voice 	 2. Google Assistant 	 3. Speech recognition
	 4. Face recognition

C.	 1. T	 2. T	 3. F	 4. T	 5. F

D.	 1.	� Two areas where face recognition is used are as follows:

	 	 • It is used in phones to unlock them. 

	 	 • It is used on social media websites to spot faces when you upload a photo.

	 2.	 Two areas where AI-powered OCR is being used are as follows: 

	 	 • Document are scanned using OCR. 

	 	 • Robots use OCR to scan barcodes in the warehouses and find stock. 

	 3.	� Face recognition is a technology which is used to identify an individual’s face.

	 4.	 Two benefits of AI-powered speech recognition systems are as follows: 
	 	 • They can capture speech much faster than we type. 
	 	 • They save time and effort as the user needs to spend less time in typing. 

1. Google Assistant		  2. Siri	 3. Alexa

9.



16 DigiCode AI (Ver. 2.1)-VI (Answer Key)

IMPRINT 1

1. Optical Character Recognition (OCR) 
2. Face Recognition

	  Types of Robots 

  (Page no. 130)

1. Zenbo: It is a low-cost robot capable of rolling around freely. 
2. Z-Machines: It is a music-band.

 Quest   (Page no. 138)

A.	 1. Kitchen Robots and Ironing Robots
	 2. A-PUFFER and BRUIE
	 3. Furby and Aibo
B.	 �Robots are changing agriculture beyond recognition, from cobot-assisted milking to cow-

herding drones, they are there to help in every steps of farming.

TeCh Ready

A.	 1. (ii)	 2. (ii)	 3. (iv)	 4. (i)	 5. (ii)

B.	 1. marimba-playing	 2. Service	 3. Furby	 4. Humanoid	 5. Robots

C.	 1. T	 2. F	 3. F	 4. F	 5. T

D.	 1.	� Industrial robots, Collaborative robots and Service robots.

	 2.	� A collaborative robot, or Cobot, is a type of robot intended to physically interact with 
humans in a shared workspace.

	 3.	� Industrial robot is a robot system which used for manufacturing purposes. These robots 
are automated, programmable and capable of movement in three or more axes.

	 4.	� Robots in the medical industry enhance precision in surgeries, assist in rehabilitation, and 
ensure cleanliness through disinfection.

	 5.	� Two reasons for using Robots in space and research are as follows:

•	 They are sent to space because sending a robot in space is much cheaper than sending 
a human. 

•	 They don’t need to eat or sleep. Hence, they can work for long hours.

10.
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C S H I M O N F E A

C U R I O S I T Y I

X B S V F H Y H B B

J L S S A F F I R O

Y E J N V L Z A U D

U G S C J J D S I Z

D O T W U R I S E S

J S D Y Z N I N U L

N U F P S W X V A Q

L K F U R B Y L P Y

1. Service robots 
2. BRUIE

Periodic Assessment 4
(Based on chapters 8 to 10)

A.	

S.No. Human Intelligence Artificial Intelligence

1. Created by nature Created by human intelligence

2. Processes information slower Process information with high speed

3. Less accurate More accurate

4. Capable of adapting changes Can’t easily adapt changes

5. Has the capacity of multi-tasking Performs single task more efficiently

6. Has social skills Lack social skills

B.	 1. Optical Character Recognition  	 2. �Speech Recognition	 3. �Face Recognition

C.	 1. �Face Mask Detection Robot	 2. Knightscope	 3. Aibo 	 4. Humanoid
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(Based on chapters 6 to 10)
Test Sheet 2

Section A

A.	 1. (iv)	 2. (iv)	 3. (iv)	 4. (iv)	 5. (i)	 6. (ii)	 7. (iii)	 8. (i)

B.	 1. Speech recognition	 2. Face recognition	 3. marimba-playing
	 4. Humanoid	 5. Guido van Rossum	 6. Event handler
	 7. Pseudocode	 8. Prompt

C.	 1. T	 2. T	 3. T	 4. F	 5. T	 6. F	 7. T	 8. F

D.	 1. a = 10 

	   b = 20 

	   print ("a=", a) 

	   print ("b=", b) 

	 2. Industrial robots, Collaborative robots and Service robots.

	 3. �Two areas where AI-powered OCR is being used are as follows: 
	 •  Document are scanned using OCR. 
	 •  Robots use OCR to scan barcodes in the warehouses and find stock.

	 4. �Two reasons for using Robots in space and research are as follows:
	 •  �They are sent to space because sending a robot in space is much cheaper than sending 

a human. 
	 •  They don’t need to eat or sleep. Hence, they can work for long hours.

	 5. S.No. Human Intelligence Artificial Intelligence

1. Created by nature Created by human intelligence

2. Processes information slower Process information with high speed

	 6. �Pseudocode is used to describe the steps of an algorithm in a human-understandable 
language. It has no syntax and can be easily understood by a layman. 

	 7. �The pause block in MakeCode temporarily stops program execution for a specified duration 
in milliseconds, allowing for timed delays between actions. 

	 8. �A collaborative robot, or Cobot, is a type of robot intended to physically interact with 
humans in a shared workspace. These robots are supposed to work along with the humans 
and provide safety and flexibility.


