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	   A Computer System

Exercise
A.	 1. c.	 2. c.	 3. a.	 4. a.
B.	 1. IPO	 2. Microphone	 3. CPU	 4. Webcam
C.	 1. Printer	 2. Monitor	 3. Projector	 4. Hard disk	 5. Webcam
D.	 1. A mouse is a pointing device that inputs data by pointing, clicking and dragging.
	 2. �Two output devices are monitor: displays the output as softcopy (on its screen) and printer: 

prints the output on a paper which is called a hard copy.
E.	 1. A computer works on the IPO cycle (Input-Process-Output). 
	 	 Input: The data and instructions we give to a computer are called Input.
	 	� Process: A computer takes action on the data entered by the user. It converts the data into 

meaningful information with the help of the processor which is the CPU. This conversion of 
data into information is called processing.

	 	 Output: The result which we get after processing the data and instructions is called output.
	 2. �Storage devices are the hardware devices used to store data. Once you have finished working 

with your data, you can store the data permanently in storage devices. Some examples of 
storage devices are hard disk, DVD and pen drive.

F.	 Microphone

	   Computer Memory

Exercise
A.	 1. c.	 2. b.	 3. b.	 4. d.
B.	 1. Byte	 2. RAM	 3. USB	 4. Magnetic

1.

2.
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C.	 1. ROM	 2. MAGNETIC DISK	 3. COMPACT DISC
	 4. FLASH DRIVE
D.	 1. �RAM is a temporary memory. The information stored in this memory is lost when the computer 

is turned OFF.
	 2. �Memory Card are used in mobile phones and digital cameras. You need to have card reader 

to read stored data on memory card.
	 3. �Three categories of secondary memory devices are Magnetic Disks, Optical Discs and  

Flash Drives.
E.	 1. �The basic unit for measuring the memory of a computer is byte. A byte consists of a group 

of eight bits. A group of 4 bits is known as a nibble (half byte). Other units for measuring the 
computer’s memory are kilobyte, megabyte, gigabyte, terabyte, etc.

	 2. �Hard Disk: It consists of one or more magnetic disks called platters. It is permanently fixed in 
the CPU box. It comes in a variety of sizes with storage capacities as high as 5 TB (TeraByte) 
or even more.

	 	� External hard disks are also available. They are the hard disks that can be connected to any 
computer with the help of a USB port.

F.	 Memory Card

Worksheet 1
(Based on chapters 1 & 2)

A.	 1. Printer	 2. Projector	 3. Speakers	 4. Microphone
B.	 1. F	 2. F	 3. T	 4. T

C.	

 

3 1 4 2

D.	 Sushant should use external hard disk for this.

	   Let’s Know about Windows 10

Exercise
A.	 1. c.	 2. b.	 3. b.	 4. a.
B.	 1. Icons	 2. Taskbar	 3. Double-clicking	 4. Desktop background

3.
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C.	 1. T	 2. F	 3. T	 4. F
D.	 1. DESKTOP	 2. WINDOWS	 3. RECYCLE BIN	 4. WALLPAPER
E.	 1. Desktop is the first screen that appears after switching on the computer.
	 2. Sorting the icons means arranging the icons on the desktop.
	 3. �Start button is known as the gateway to Windows and its programs. It opens the Start menu, 

when we click on it.
F.	 1. Features of Windows 10 are given below:
	 	 • �Windows 10 has a Graphical User Interface (GUI) that means you do not need to remember 

all the commands.
	 	 • It allows you to run several programs at the same time.
	 2. To hide desktop icons, follow the given steps:
	 	 Step 1: �Right-click on any blank area of the desktop. Click on the View option from the  

pop-up menu.
	 	 Step 2: Uncheck the Show desktop icons option by clicking on it in the submenu.
G.	 To sort desktop icons, Yugansh should follow these steps:
	 Step 1: �Right-click on the blank area of the desktop. From the pop-up menu, click on Sort by 

option. A submenu appears.
	 Step 2: Click on any one option to arrange the icons in that order.

	   Advanced Features of Paint

Exercise
A.	 1.	a.	 2. a.	 3. b.	 4. b.
B.	 1.	Tabs	 2. Text	 3. Drawing Area	 4. File
C.	 1.	F	 2. T	 3. T	 4. F
D.	 1. iv	 2. i	 3. ii	 4. iii
E.	 1. 	File Tab, Ribbon, Title Bar, Drawing Area are the components of Paint window.
	 2. 	�Paint provides three types of callout shapes which are Rounded rectangle callout, Oval callout 

and Cloud callout.
	 3. 	�Foreground means the colour that is in front, whereas, Background means the colour that is 

in back or behind.

4.



Touchpad MODULAR Ver. 4.0-III (Answer Key)4

F.	 1. 	To use text tool, follow these steps:
	 	 Step 1: Click on the Home tab.
	 	 Step 2: Click on the Text tool from the Tools group.
	 	 Step 3: Select a colour from the Colors group.
	 	 Step 4: �Drag the mouse pointer in the Drawing Area. A text box will appear with the cursor 

blinking in it.  Type your text in the text box.
	 2. 	To open an existing drawing, follow these steps:
	 	 Step 1: Click on the File tab.
	 	 Step 2: Click on the Open option.
	 	 Step 3: �Select the file name that you want to open or type the file name in the File name: 

box.
	 	 Step 4: Click on the Open button.
G.	 1.	Rohit should use Color Picker tool to achieve this.
	 2.	Amisha should use different shapes from the Shapes group.

Worksheet 2
(Based on chapters 3 & 4)

A.	

Tools Group Drawing Area

Title BarTab

File Tab

Ribbon

Shapes Group Colors Group

B.	 1.	 	 2. 	 3. 

	 	   	
C.	 1. Icons	 2. Taskbar	 3. Start Button	 4. Desktop

This PC Recycle Bin Folder
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Test Sheet 1
(Based on chapters 1 to 4)

A.	 1. c.	 2. a.	 3. b.	 4. a.

B.	 1. Icons	 2. USB	 3. Read Only Memory	 4. Foreground

C.	 1. The basic unit for measuring the memory of a computer is byte.

	 2. Ribbon contains tabs and groups in Paint window.

	 3. Application software is used to perform a specific task.

D.	 1. To open an existing drawing, follow these steps:
	 	 Step 1 Click on the File tab. 
	 	 Step 2 Click on the Open option.
	 	 Step 3 Select the file name that you want to open or type the file name in the File name: box. 
	 	 Step 4 Click on the Open button.
	 2. �Primary memory is the main memory of the computer. CPU can directly access this memory. 

It is fixed on the motherboard of the computer.

	 	 RAM ROM

RAM is a temporary memory. The information 
stored in this memory is lost when the 
computer is turned OFF. It is also called 
volatile memory.

Information stored in ROM is permanent 
in nature, i.e., it holds the data even if the 
system is switched OFF. It is also called 
non-volatile memory.

	 3. To sort desktop icons, follow these steps:
	 	 Step 1: �Right-click on the blank area of the desktop. From the pop-up menu, click on Sort 

by option. A submenu appears.
	 	 Step 2: Click on any one option to arrange the icons in that order.

	   More on Paint

Exercise
A.	 1.	a.	 2. b.	 3. c.	 4. b.
B.	 1.	F	 2. T	 3. T	 4. F
C.	 1.	Zoom	 2. Rectangular Selection	 3. Home	 4. Select

D.	 1.	Zoom In	 2. Rectangular Selection Tool	 3. Zoom Out	 4. Flip vertical

5.
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E.	 1.	Select command is used to select a drawing or a part of a drawing.
	 2.	The keyboard shortcut to cut and paste the image is Ctrl + X and Ctrl + V.
F.	 1.	�The Rotate command is used to change the position of the drawing at different angles, 

whereas, the Flip command is used to get the mirror image of the drawing either horizontally 
or vertically.

	 2.	The steps to copy an image are as follows:
	 	 Step 1: Click on the Home tab.
	 	 Step 2: Click on the Select command.
	 	 Step 3: Select the image by dragging the mouse over it.
	 	 Step 4: Click on the Copy command from the Clipboard group.
	 	 Step 5: Click on the Paste command from the Clipboard group.
G.	 1. �By using the Select, Copy, and Paste functions, Sahil can quickly make several birds of the 

same size in Paint.
	 2. Rihanna should use Zoom tool for this.

	   Stepwise Thinking

Exercise
A.	 1. c.	 2. c.	 3. b.	 4. c.
B.	 1. �The process of completing one step and then moving onto the next is known as Stepwise 

thinking.
	 2. �An example of a loop in real life is a washing machine cycle. The washing machine repeats 

the steps of washing, rinsing, and spinning until the cycle is complete.
	 3. Steps of making a strawberry milkshake are:
	 	 Step 1: Take fresh strawberries and wash them thoroughly.
	 	 Step 2: Cut the strawberries into small pieces.
	 	 Step 3: Add the strawberries to a blender.
	 	 Step 4: Add milk and sugar to the blender (according to your taste).
	 	 Step 5: Blend the mixture until smooth.
	 	 Step 6: Pour the milkshake into a glass and enjoy!

C.	 1.	The term used to describe this action is a loop.

	 2.	

6.
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Worksheet 3
(Based on chapters 5 & 6)

A.	 Yes
B.	 1. Cut command is used to remove the image from its original place.
	 2. Free form selection command is used to select the drawing in free form as per need.
	 3. Zoom in command is used to get a closer view of an image.
	 4. Rotate command is used to change the position of the drawing at different angles.

	   Pivot Animator

Exercise
A.	 1. a.	 2. b.	 3. a.
B.	 1. Add Frame	 2. Player Controls	 3. Segment Handle	 4. Status
C.	 1. �Pivot Animator is a free and simple app that allows you to create animations using stick 

figures.
	 2. Because the saved projects can be opened later or shared with others.
D.	 1. �Exporting an animation means turning your project into a finished file, like a GIF or video. This 

file can be watched on other devices or shared with others. When you export, the animation 
is saved in a way that doesn’t need the software to play. You can use it outside the program.

	 2. To create a figure in Pivot Animator, follow the given steps:
		  Step 1: Click on the File menu.
		  Step 2: Select the Create Figure Type option.
		  Step 3: Click on the Add Line tool.
		  Step 4: Click on the segment handle and draw a line.
E.	 1. Gunjan should select the Loop check box in the Player Controls to do the same.
	 2. Vihan can use the Segment Handle to reposition the figures.

	   Introduction to Google Blockly

Exercise
A.	 1. b.	 2. c.	 3. b.	 4. d.
B.	 1. Puzzle	 2. Turns left	 3. 10	 4. Check Answers
C.	 1. F	 2. T	 3. F	 4. T

7.

8.
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D.	 1. �The Maze game teaches users how to use blocks to move characters, create loops, and repeat 
actions to reach a destination.

	 2. Google Blockly is a tool that helps the young users to learn programming quickly and easily. 

	 3. �After completing the ten levels of the Maze, the home page will automatically appear on the 
screen.

E.	 1. To start Google Blockly Games, follow these steps:
	 	 Step 1: Open the web browser.
	 	 Step 2: Type www.blockly.games in the address bar of the web browser.
	 	 Step 3: Press Enter key.
	 	 The Google Blockly Games webpage will appear with eight different games.
	 2. The blocks used in the Maze game are as follows:
	 	 • �move forward block: Moves the object in the forward direction from the direction it is 

facing.
	 	 • turn left block: Turns the object in the left direction from the direction it is facing.
	 3. This Puzzle game teaches the user to:
	 	 • join the blocks.
	 	 • create stack of blocks.
	 	 • placing stack of blocks inside a container block.
F.	 Reyansh can learn basic programming is a playful way using Google Blockly games.
	 To start Google Blockly Games, Reyansh should follow these steps:
	 Step 1: Open the web browser.
	 Step 2: Type www.blockly.games in the address bar of the web browser.
	 Step 3: Press Enter key.
	 The Google Blockly Games webpage will appear with eight different games.
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Worksheet 4
(Based on chapters 7 & 8)

A.	

B.	 Title Bar

Menu Bar

Status Bar

Frame 
Controls

Frame 
Panel

Canvas

Figure

Segment 
Handle

Origin 
Handle

Player 
Controls

Background 
Button

Add Figure 
Button

Figure 
Controls

Add Frame 
Button

Test Sheet 2
(Based on chapters 5 to 8)

A.	 1. b.	 2. c.	 3. b.	 4. c.
B.	 1. T	 2. T	 3. T
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C.	 1. The Rotate command is used to change the position of the drawing at different angles.
	 2. �If some answers are incorrect in the Puzzle game, the screen displays the number of incorrect 

blocks.
	 3. �The process of completing one step and then moving onto the next is known as Stepwise 

thinking.
	 4. Because the saved projects can be opened later or shared with others.
D.	 1. To select the drawing in rectangular form, follow these steps:
	 	 Step 1: Click on the Home tab.
	 	 Step 2: Click on the down arrow, under the Select command.
	 	 Step 3: Click on the Rectangular selection.
	 	 Step 4: �Hold the left mouse button and drag over the drawing to select it. Release the left 

mouse button after the desired selection.
	 2. The blocks used in the Maze game are as follows:
	 	 • �move forward block: Moves the object in the forward direction from the direction it is 

facing
	 	 • turn left block: Turns the object in the left direction from the direction it is facing
	 	 • turn right block: Turns the object in the right direction from the direction it is facing
	 3. �An example of a loop in real life is a washing machine cycle. The washing machine repeats 

the steps of washing, rinsing, and spinning until the cycle is complete.
	 4. �Exporting an animation means turning your project into a finished file, like a GIF or video. This 

file can be watched on other devices or shared with others. When you export, the animation 
is saved in a way that doesn’t need the software to play. You can use it outside the program.


