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1Touchpad MODULAR Ver. 4.0-VIII (Answer Key)

	   Computer Networking

Exercise
A.	 1. b.	 2. d.	 3. c.	 4. d.
B.	 1. Router 	 2. Server	 3. Network Architecture	 4. Networking
	 5. Peer-to-peer
C.	 1. T	 2. T	 3. T	 4. F	 5. T
D.	 1. �The computer network is a system of interconnected computers which can communicate 

with each other. It allows us to share the resources such as computers and peripherals.
	 2. �Peer to Peer Network – It is a network of two or more computers that use same type of 

program to share the data
	 	 Client-Server Architecture
	 	� It is a network in which one computer is designated as the server and all the other computers 

connected on the network are called the clients.
	 3.	Topology refers to the physical or logical arrangement of computers or nodes in a network. 
	 4. �Modem stands for MODULATOR - DEMODULATOR. It is a hardware device that is used to 

connect a computer to the Internet via a telephone line or a wireless medium. It converts 
data from digital to analog and vice versa.

E.	 1. Below are the three components required for a computer network:
		  a. �Network Interface Card (NIC): It is an expansion card that enables a computer to access 

a network. It allows the computer to connect to a network through a wired or wireless 
medium. It is also known as Network adapter.

		  b. �Hub or Switch: It is hardware device that has various ports to which the computers, printers 
and other networking devices are connected. The main function of a hub is to direct 
information around the network and facilitate communication between all the connected 
devices.

		  c. �Router: It is a networking device used to connect and facilitate transfer of data between 
two networks. It is located at the gateways where two networks connect.

1.
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	 2. The advantages of computer network are:
		  • The information can be easily shared by the people.
		  • It helps in reducing the cost of hardware.
		  • Store information on one centralised location.
		  • �Reliability implies backing up of information. If a system crashes, then the information is 

accessible on another workstation for future use.
		  • Reduction in installation cost.
		  • User authentication process to secure the data.
	 3. �In a wireless networking technology, no wires or physical media is used for connecting 

computers. It uses electromagnetic waves like infrared, microwave and radio waves for 
transmission of the data. There are two types of wireless technologies named Wi-Fi and 
Bluetooth.

		�  Wi-Fi is the most popular wireless communication technology used for homes, private business 
LANs and public hotspots. A Wi-Fi enabled device such as a PC, video game console, mobile 
phones or MP3 player can connect to the Internet when it comes within the range of a wireless 
network.

		�  Bluetooth is a technology that enables wireless communication between a low-power 
consumption devices within a short range (1 meter, 10 meters, 100 meters). It facilitates 
communication between different devices when they are within a required range. The latest 
version of Bluetooth, Bluetooth 5.4 technology provides data transfer speed up to 2 Mbps.

F.	 1. Star Topology
	 2. Mesh Topology

	   Photo Editor and Video editor

Exercise
A.	 1. b.	 2. a.	 3. b.	 4. d.	 5. a.
B.	 1. T	 2. F	 3. F	 4. T	 5. T
C.	 1. Photos app	 2. Flipping	 3. Filters	 4. transition
D.	 1. Follow the below steps to open Photos App:
	 	 Step 1: Click on the Start button
	 	 Step 2: Scroll down the Photos App and click on it.
	 2. Cropping means removing the useless portion of the photo.
	 3. �Video Editing means to add/remove some content in an existing video or apply some effects 

to the video.

2.
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E.	 1. �Filters are the special effects that can change the appearance of a photo by modifying its 
shades and colours to apply filters to a photo. Follow the given steps.

	 	 Step 1: Open a photo in editing mode and click in the Filters tab.
	 	 Step 2: Click on the desired filter to apply it on the selected photo.
	 	 Step 3: �Click on the Save as Copy option in the Save options drop-down list to save the 

changes made.
	 2. Follow the steps given below to use the adjustments feature:
	 	 Step 1: Open a photo in editing mode and click on the Adjustments tab.
	 	 Step 2: Adjust the brightness of the photo by moving the options in the Light section.
	 	 Step 3: Adjust the colours of the photo by moving the options in the Color slide.
		  Step 4: �Click on the Save as copy option in the Save options drop-down list to save the 

changes made.
	 3. Perform the following steps to import a media file:
	 	 Step 1: Click on the file menu.
	 	 Step 2: Select the Import Files option.
	 	 Step 3: Navigate to the folder where the media file is saved and select it.
		  Step 4: Select the desired video.
	 	 Step 5: Click on the Open button.
F.	 1. Adjustments feature	 2. Crop tool

Worksheet 1
(Based on chapters 1 & 2)

A.	 1. Ring Topology		  2. Personal Area Network (PAN)
	 3. Star Topology		  4. Mesh Topology
B.	 1. Editing		  2. Filters
	 3. Desired filter		  4. Save as copy, Save options
C.	 1. Rotating		  2. Flipping
	 3. Protocol		  4. Wi-Fi

	   Introduction to GIMP

Exercise
A.	 1. b.	 2. c.	 3. a.	 4. d.
B.	 1. Template	 2. GIMP	 3. Toolbox	 4. File	 5. Layer Palette
C.	 1.	�To start GIMP, click on Start button → Scroll to find letter G → Click on GIMP 2.10.28.
		  You can also double-click on GIMP icon on the desktop to start GIMP.

3.
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	 2.	�Rulers are shown above and to the left of the Image window, indicating coordinates within 
the image.

	 3.	�The color areas show GIMP’s current foreground and background colours. Clicking on either 
one of them will open a color selector dialog box that allows changing to a different color. 
Clicking on the double-headed arrow exchanges the two colors, and clicking on the small 
symbol in the lower left corner resets them to black and white.

D.	 1.	�When you click on Advanced Options, the Create a New Image dialog box appears and you 
get some advanced options:

		  •  �X and Y resolution: The values in the X resolution and Y resolution fields relate mainly to 
printing. The values represent the number of pixels per unit length in the horizontal (X) and 
vertical (Y) directions. They usually determine physical size of the image when it is printed.

		  •  �Color space: You can create the new image in different color modes (RGB or Grayscale).
		  •  �Fill with: Selects the initial background colour of the new document.
	 2.	Following are the features of GIMP:
		  •  �User friendly interface
		  •  �Image manipulation can be done quickly
		  •  �Powerful tools are used to change the colour of an image by adjusting brightness, contrast, 

colour balance, hue and saturation levels
		  •  �Layer effect preserves the original state of the image
	 3.	�To save a file, click on the File → Save option from the Menu bar. This will open the Save 

Image dialog box.
		  a. Navigate the folder to save the file.
		  b. Type the name of the file in the Name text box.
		  c. Click on Save button.
		  The image is saved with the specified name with .xcf extension.
E.	 1.	�To open an Image, Suresh must click on File → Open option from the Menu bar. This will 

open the Open Image dialog box. Then he should
		  a. Choose the image to be inserted.
		  b. Click on the Open button.
	 2.	�To save a file, Neha should click on File → Save option from the Menu bar. This will open the 

Save Image dialog box. Then she should
		  a. Navigate the folder to save the file.
		  b. Type the name of the file in the Name text box.
		  c. Click on Save button.
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	   Using Tools in GIMP

Exercise
A.	 1. c.	 2. c. 	 3. b.	 4. b.
B.	 1. Toolbox	 2. Blur/Sharpen		 3. Ctrl 	 4. Text tool
C.	 1. True	 2. False	 3. True	 4. True
D.	 1.	�Clone tool is used to duplicate part of an image. It involves setting the sampling point in the 

image to be cloned.
	 2.	Two correction tools are:
		  a. �Blur/Sharpen tool - This tool is used to blur the image or some part of it. It is also used to 

sharpen images to improve their quality.
		  b. �Smudge Tool - This tool is used to show the image as the wet paint on the image has been 

spread by a finger.
	 3.	�Free Select Tool - It is used to select an object or a section of an image by drawing a freehand 

border around it.
		  Rectangle Select Tool – It is used to select a rectangular portion of an image.
E.	 1.	To use the Burn tool – 
		  a. Open an image.
		  b. Click on the Burn tool.
		  c. Select the brush size and hardness from Tool Options.
		  d. �Press and hold Ctrl key. Click and drag the mouse pointer over the area that you want to 

burn. Release the Ctrl key.
	 2.	�Gradient tool is used to show a blending effect between two or more colours in the workspace.
		  Different types of gradient modes are as follows:
		  •  Linear: It is used when straight lines are to be shown in gradient effect.
		  •  Radial: It is used when circles are to be shown in gradient effect.
		  •  Spiral: It is used when spiral shapes are to be shown in gradient effect.
		  •  Conical: It is used to give the effect of looking down at the tip of a cone.
	 3.	To use the Healing tool, follow the below steps:
		  Step 1: Open the image you want to retouch.
		  Step 2: Click on the Healing tool.
		  Step 3: Specify the brush size.
		  Step 4: �Press and hold down the Ctrl Key and click on a clean area of the image that’s similar 

to the area you want to retouch.
		  Step 5: �Move your cursor over the area you want to retouch then, click and drag the mouse 

to start healing.
F.	 1.	Meera can use Healing Tool to fix the scratches and restore the image.
	 2.	Dodge Tool

4.
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	   Advanced features of GIMP

Exercise
A.	 1. b.	 2. c.	 3. a.	 4. d.
B.	 1. Layers	 2. Filters	 3. Background		  4. Delete
C.	 1. True	 2 True	 3 False	 4 False
D.	 1.	Filters are tools which are used to modify an image in a variety of ways. 
	 2.	�Lock Pixel button prevents edits directly to the pixel data on the layer. Lock Position and Size 

button prevents accidental movement or resizing of the layer. Lock Alpha Channel button 
protects the transparency information of the layer. 

	 3.	�Yes. To make hidden layer visible again, click on the place of Eye icon on the layer. Layer gets 
visible.

E.	 1.	To add a new layer, follow the given steps:
		  Step 1: Cilck on Layer menu from the Menu bar.
		  Step 2: �Choose New Layer option. Or click on the Create a new layer button at the bottom 

of the Layers Palette.
		  Step 3: Specify the desired settings, such as name of the layer, its dimensions, etc.
		  Step 4: Click on the OK button.
	 2.	To merge two images, follow the given steps:
		  Step 1: �Open an image in GIMP and add a new layer by clicking on the Create a new layer 

button.
		  Step 2: Click on the Image menu then select the Canvas Size option
		  Step 3: Enter the desired value in Width and Height box to increase the canvas size.
		  Step 4: Hide the layer by clicking on the Eye icon.
		  Step 5: �Open an another image and then Using the Selection Tool, select whole or a part of   

image.
		  Step 6: �Copy the selected portion and paste it on the added layer. When you paste an image, 

a temporary layer, called floating layer is added to the Layers palette.
		  Step 7: �Click on Anchor the floating layer button at the bottom of the Layers palette to merge 

the floating layer to the layers palette and then unhide the first layer.
	 3.	To view the entire image, we can change its print size. To do so, follow the given steps:
		  Step 1: Click on Image menu from the Menu bar.
		  Step 2: Select the Print Size option.
		  Step 3: Change the unit of measurement from px (pixel) to inches or centimeters.
		  Step 4: Type a print size in the Width and Height box.
		  Step 5: Click on OK button.

5.
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F.	 1. Ritika can use Eye icon to hide the text layer without deleting it.
	 2. Priya can use Anchor the floating layer option.

Worksheet 2
(Based on chapters 3 to 5)

A.	
Layers tab

Delete a layer

Layers stack

Create a duplicate layer

Lock buttons

Create a new layer group

Anchor a floating layer

Create a new layer

Raise this layer

Eye icon

B.	
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C.	 1. Neha should use Gradient Tool.
	 2. Anil can use Clone Tool.
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Test Sheet 1
(Based on chapters 1 to 5)

A.	 1. d.	 2. c.	 3. b.	 4. b.
	 5. d.	 6. c.	 7. d.	 8. c.
B.	 1. T	 2. T	 3. T	 4. T
	 5. F	 6. T	 7. F	 8. F
C.	 1.  server	 2. Topology	 3. Flipping	 4. Toolbox
	 5. Text tool	 6. Blur/Sharpen	 7. Layers	 8. Filters
D.	 1.	�The computer network is a system of interconnected computers which can communicate 

with each other.
	 2.	Cropping means removing the useless portion of the photo.
	 3.	�Rulers are shown above and to the left of the Image window, indicating coordinates within 

the image. 
	 4.	�Free Select Tool - It is used to select an object or a section of an image by drawing a freehand 

border around it.
		  Rectangle Select Tool – It is used to select a rectangular portion of an image.
	 5.	Filters are tools which are used to modify an image in a variety of ways. 
E.	 1.	The advantages of computer network are: 
		  a. The information can be easily shared by the people. 
		  b. It helps in reducing the cost of hardware. 
		  c. Store information on one centralised location. 
		  d. �Reliability implies backing up of information. If a system crashes, then the information is 

accessible on another workstation for future use. 
		  e. Reduction in installation cost. 
		  f. User authentication process to secure the data.
	 2.	Perform the following steps to import a media file:
		  Step 1: Click on the file menu.
		  Step 2: Select the Import Files option.
		  Step 3: Navigate to the folder where the media file is saved and select it.
		  Step 4: Select the desired video.
		  Step 5: Click on the Open button.
	 3.	Following are the features of GIMP:
		  •  User friendly interface
		  •  Image manipulation can be done quickly
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	 	 •  �Powerful tools are used to change the colour of an image by adjusting brightness, contrast, 
colour balance, hue and saturation levels

		  •  Layer effect preserves the original state of the image
	 4.	To use the Healing tool, follow the below steps:
		  Step 1: Open the image you want to retouch.
		  Step 2: Click on the Healing tool.
		  Step 3: Specify the brush size.
		  Step 4: �Press and hold down the Ctrl Key and click on a clean area of the image that’s  similar 

to the area you want to retouch.
		  Step 5: �Move your cursor over the area you want to retouch then, click and drag the mouse 

to start healing.
	 5.	To view the entire image, we can change its print size. To do so, follow the given steps:
		  Step 1: Click on Image menu from the Menu bar.
		  Step 2: Select the Print Size option.
		  Step 3: Change the unit of measurement from px (pixel) to inches or centimeters.
		  Step 4: Type a print size in the Width and Height box.
		  Step 5: Click on OK button.

	   Introduction to Tupi 2D

Exercise
A.	 1. c.	 2. b. 	 3. a. 	 4. b. 	 5. d. 
B.	 1. Shapes	 2. Ctrl + W	 3. Workspace	 4. Pencil
C.	 1. True	 2. True	 3. True	 4. True	 5. True
D.	 1.	Animation is a way through which you can show characters and objects live. 
	 2.	Pencil tool is used to draw free hand drawings. 
	 3.	Two important features of Tupi 2D are:
		  a. It is an open source and free software.
		  b. �This software allows us to use vector graphics like, ellipses, lines, rectangles and polygons.
E.	 1.	�Nodes Selection Tool - This tool helps to reorder the nodes which were created while drawing 

an object. Users can only use this if they’ve used line tool, polyline tool or pencil tool.
		�  Object Selection Tool - We can select the objects which are created in diffefent layers or 

frames using this tool. This tool helps the user to modify, flip or group objects as per their 
requirements.

6.
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	 2.	To use the Shapes tool, follow the given steps:
		  Step 1: Click on the Shapes tool from the Toolbox.
		  Step 2: Select the Rectangle shape.
		  Step 3: Click on the Brush Properties on the left sidebar.
		  Step 4: Click on the Cap option to choose the line patterns.
		  Step 5: Click on the Color Palette button on the left sidebar.
		  Step 6: Select the colour from the Contour option to change the outline colour of the rectangle
		  Step 7: �Select the colour from the Fill option to change the colour that is to be filled inside 

the rectangle.
		  Step 8: �Move to the workspace and drag to draw the shape. Similarly, you can add more shape.
	 3.	Follow these steps to save a Tupi 2D file:
		  Step 1: Click on the File menu.
		  Step 2: Click on the Save Project option. The Save As dialog box appears.
		  Step 3: Enter a name for the project in the File name text box.
		  Step 4: Click on the Save button.
	 4.	To use the PolyLine tool, follow the given steps:
		  Step 1: Click on the PolyLine tool from the Toolbox. 3
		  Step 2: Click on the Brush Properties on the left sidebar.
		  Step 3: Change the settings of the line by modifying the stroke thickness, pattern etc.
		  Step 4: Click on the Color Palette button on the left sidebar.
		  Step 5: Choose the colour of the line from the Color Palette.
		  Step 6: Draw the first line and then click at different points to draw connecting lines.
F.	 1.	Ishaan should use Ellipse tool.
	 2.	Riya should use Paint Bucket Tool.

	   Animations in Tupi 2D

Exercise
A.	 1. c.	 2. c.	 3. a.	 4. c.
B.	 1 True	 2 False	 3 False	 4 True
C.	 1.	�Layers are like stack of transparent sheets that are used to work on the individual part of the 

image without affecting the other parts. 
	 2.	Tweening is a feature that helps us to make animation process easier and faster. 
	 3.	�Motion tween helps to move an object whereas Scale tween helps to give zooming effect to 

an object.

7.
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D.	 1.	�A frame is a single animation that is applied on an object or picture on a timeline. Frames 
hold the content of the project at a particular moment. Frames make it easy to place image 
on the page. To insert frames:

		  a. Click on the Exposure Sheet in the right sidebar.
		  b. Click on the Insert frame button. 
	 2.	To use coloring tween:
		  a. Draw a circle using the Shapes tool and then click on Tween option from the Toolbox.
		  b. Select the Coloring Tween option and type a name for the tween.
		  c. Click on + button and select the object.
		  d. �Click on the Set Properties radio button and set the properties as starting frame and ending 

frame.
		  e. �Set initial and ending colour, iterations, and loop then click on Save Tween button to save 

the animation.
	 3.	Some important points about the tween are:
		  a. There should be at least one object in the scene to use a tween. 
		  b. One kind of tween can be applied for every object. 
		  c. If an object is part of a tween, then that object cannot be edited as a vector path.
E.	 1.	Motion Tween	 	 2. Opacity Tween

Worksheet 3
(Based on chapters 6 & 7)

A.	 Menu Bar

Toolbar

Left Side 
bar

Toolbox

Modules Tab Workspace Paint Area Actions Toolbar

Right Slide 
bar

Exposure 
sheet
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B.	 1.	Rotation Tween	 2. 24	 3. Clockwise
C.	 1. Shear Tween	 2. Layer Panel	 3. Animation

	   App Development

Exercise
A.	 1. a.	 2. a. 	 3. c. 	 4. d. 
B.	 1 Application	 2. Web App	 3. App Inventor
	 4. e-commerce	 5. Social networking
C.	 1. False	 2. False	 3. True	 4. False	 5. False
D.	 1.	�The three most popular app stores are Google’s Play Store, Apple’s App Store, and  

Microsoft Store.
	 2.	�iOS is a popular operating system developed by Apple Inc. for its hand-held devices such as 

iPhone and iPad. The user interface of the iOS looks very professional.
	 3.	�Utility apps allow us to do our daily tasks such as booking a cab, booking a railway ticket, 

booking an appointment with doctor, sharing files, and performing calculations. These apps 
make our work easy. Example, Calculator, Flashlight.

	 4.	�Communication Apps allows us to communicate with each other by sending and receiving 
messages, information and opinion in the form of texts, videos and audios.

E.	 1.	To download and install an app on an Android device, perform the following steps:
		  Step 1: Tap on the Play Store icon of your Android mobile.
		  Step 2: �Type the name of the app or related keyword in the Search for apps & games box at 

the top. 
		  Step 3: Tap on the app you want to install.
		  Step 4: Tap on the Install button.
		  Step 5: Tap on the Open button to open and use the app.
	 2.	�Desktop App: The application that is mainly developed for computer or laptop is called a 

desktop app. This type of application depends of the hardware and operating system on 
which it run. Examples are Paint, Notepad, and Word.

		�  Mobile App: Mobile app is software program that is developed for hand-held devices such 
as smartphones and tablets. Examples are Snapchat, WhatsApp, and Facebook Messenger.

	 3.	�E-commerce means to buy or sell products on an online service over the Internet. 
		�  E-commerce apps allow us to buy or sell products while sitting at home or any other place. 

Example Amazon, Zomato, Blinkit.
	 4.	There are three types of mobile apps: native, web and hybrid.
		  a. �Native Apps: Native apps are platform dependent, which means that these apps are primarily 

8.
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developed for a specific platform. For example, any app developed for iOS will not run on 
any other platform such as Android and Windows.

		  b. �Web apps: Web-based apps on mobiles are applications that are accessed  through a 
mobile device’s web browser rather than being downloaded and installed from an app 
store. These apps are designed to be responsive, meaning they adapt to different screen 
sizes and orientations, providing a mobile-friendly experience.

		  c. �Hybrid Apps: An app that is created by combining the features of native app and  web 
app is called a hybrid app. Similar to a native app, hybrid app is developed for a specific 
platform and deployed on the app store. You need to install the hybrid app before using 
it on your mobile device.

F.	 1.	Mobile app		  2. E-Commerce apps

	   Loops in Python

Exercise
A.	 1. d.	 2. c. 	 3. b.	 4. b. 
B.	 1. break	 2. in-built	 3. Sequence	 4. infinite loop	
C.	 1. False	 2. False	 3. True	 4. True	 5. True
D.	 1.	�If the condition given in a loop never becomes false, then the loop will never terminate and 

run indefinitely. This type of loops is called an infinite loop.
	 2.	�range() function is an in-built function of Python. This function generates a list which is a 

sequence type.
	 3.	Python offers two jump statements – break and continue. 
		�  break: The break statement halts the execution of a loop and program flow switches to the 

statement after the loop. 
		�  continue: When a continue statement is encountered inside a loop, control of the program 

jumps to the beginning of the loop for next iteration, skipping the execution of rest of the 
statements in the loop for the current iteration.

E.	 1.	�In Python, the statements that are used to repeat a set of instructions are called iterative 
or looping statements. Looping statements are very useful and necessary for developing 
applications. Python provides two types of looping statements – for and while. The for 
statement is used to repeat an instruction or a set of instructions a fixed number of times. 
Whereas, the while statement is used to repeat a set of instructions until a condition evaluates 
to true.

	 2.	�The range() function is an in-built function of Python. This function generates a list which is 
a sequence type. A sequence is a succession of values bound together by a single name. The 
range() function is used in the for loop to iterate over the numbers.

9.
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	 3.	�The for statement executes a simple or compound statement for a fixed number of times 
whereas the while statement executes a set of statements repeatedly, as long as the logical 
expression evaluates to true. When the condition becomes false, the control comes out of 
the loop.

F.	 1.	1
		  2

		  3

	 2.	0
		  1

		  2

		  Loop finished

G.	 1.	# Number guessing activity
		  while True:

		      number = int(input("Enter a positive number: "))

		      if number > 100:

		          print("Number greater than 100 entered. Exiting the program.")

		          break  # Exit the loop

		      else:

		          print("Try again! Enter a number greater than 100 to stop.")

	 2.	# Game: Print numbers from 1 to 10, excluding those divisible by 3
		  for num in range(1, 11):

		      if num % 3 == 0:

		          continue  # Skip numbers divisible by 3

		      print(num)

In the Lab

	 1.	# Get input from the user
		  n = int(input("Enter a positive integer: "))

		  # Initialize sum

		  total = 0

		  # Calculate sum using a for loop

		  for num in range(1, n + 1):

		      total += num  # Add each number to total

		  # Display the result

		  print(f"The sum of the first {n} natural numbers is: {total}")

	 2.	# Get input from the user
		�  num = int(input("Enter a number to print its multiplication table: 

"))
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		  # Initialize counter

		  i = 1

		  # Print multiplication table using a while loop

		  while i <= 10:

		      print(f"{num} x {i} = {num * i}")

		      i += 1  # Increment counter

	 3.	while True:
		      �num = int(input("Enter a number (enter a negative number to stop): 

"))

		      if num < 0:

		          print("Negative number entered. Exiting the loop.")

		          break  # Exit the loop

	 4.	# Print odd numbers from 1 to 10
		  for num in range(1, 11):

		      if num % 2 == 0:

		          continue  # Skip even numbers

		      print(num)

	 5.	# Get input from the user
		  num = int(input("Enter a number to calculate its factorial: "))

		  # Initialize factorial and counter

		  factorial = 1

		  i = num

		  # Calculate factorial using a while loop

		  while i > 0:

		      factorial *= i  # Multiply factorial by the current value of i

		      i -= 1  # Decrease i by 1

		  # Display the result

		  print(f"The factorial of {num} is: {factorial}")

Worksheet 4
(Based on chapters 8 & 9)

A.	 1.	Google Play Store	 2. iOS	 3. Hybrid App
	 4.	E-commerce App	 5. Educational App	 6. Social Media App
B.	 1.	i = 0					   
		  while i < 5:

	     print(i)

	     i += 1



Touchpad MODULAR Ver. 4.0-VIII (Answer Key)16

	     if i == 3:

	         break

		  else:

		      print(0)

	 2.	i = 0
		  while i < 3:

		      print(i)

		      i += 1

		  else:

		      print(0)

C.	 count = 0

		  number = 39 # The 20th odd number (starting from 1) is 39

	 while count < 20:

	     print(number)

	     number -= 2 # Move to the previous odd number

	     count += 1

Test Sheet 2
(Based on chapters 6 to 9)

A.	 1. c.	 2. b.	 3. a.	 4. c.
	 5. c.	 6. d.	 7. c.	 8. b.
B.	 1. T	 2. T	 3. F	 4. F
	 5. F	 6. T	 7. T	 8. F
C.	 1. Ctrl + W keys.	 2. Stage	 3. MIT App Inventor	 4. inbuilt
	 5. list	 6. Infinite	 7. e-commerce	 8. Social media
D.	 1.	Pencil tool is used to draw free hand drawings. 
	 2.	Tweening is a feature that helps us to make animation process easier and faster. 
	 3.	�Utility apps allow us to do our daily tasks such as booking a cab, booking a railway ticket, 

booking an appointment with doctor, sharing files, and performing calculations. These apps 
make our work easy. Example, Calculator, Flashlight.

	 4.	�The three most popular app stores are Google’s Play Store, Apple’s App Store, and Microsoft 
Store.

	 5.	�Python offers two jump statements – break and continue. 
		�  break: The break statement halts the execution of a loop and program flow switches to the 

statement after the loop. 
		�  continue: When a continue statement is encountered inside a loop, control of the program 

jumps to the beginning of the loop for next iteration, skipping the execution of rest of the 
statements in the loop for the current iteration.
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E.	 1.	Follow these steps to save a Tupi 2D file:
		  Step 1: Click on the File menu.
		  Step 2: Click on the Save Project option. The Save As dialog box appears.
		  Step 3: Enter a name for the project in the File name text box.
		  Step 4: Click on the Save button.
	 2.	Some important points about the tween are:
		  a. There should be at least one object in the scene to use a tween. 
		  b. One kind of tween can be applied for every object. 
		  c. If an object is part of a tween, then that object cannot be edited as a vector path.
	 3.	E-commerce means to buy or sell products on an online service over the Internet. 
		�  E-commerce apps allow us to buy or sell products while sitting at home or any other place. 

Example Amazon, Zomato, Blinkit.
	 4.	There are three types of mobile apps: native, web and hybrid.
		  a. �Native Apps: Native apps are platform dependent, which means that these apps are primarily 

developed for a specific platform. For example, any app developed for iOS will not run on 
any other platform such as Android and Windows.

		  b. �Web apps: Web-based apps on mobiles are applications that are accessed  through a 
mobile device's web browser rather than being downloaded and installed from an app 
store. These apps are designed to be responsive, meaning they adapt to different screen 
sizes and orientations, providing a mobile-friendly experience.

		  c. �Hybrid Apps: An app that is created by combining the features of native app and  web 
app is called a hybrid app. Similar to a native app, hybrid app is developed for a specific 
platform and deployed on the app store. You need to install the hybrid app before using 
it on your mobile device.

	 5.	�The range() function is an in-built function of Python. This function generates a list which is 
a sequence type. A sequence is a succession of values bound together by a single name. The 
range() function is used in the for loop to iterate over the numbers.


