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	Working with Windows 10

Exercise

A.	 1.	a	 2. a	 3. c	 4. c
B.	 1.	Video file	 2. Music file	 3. Image file	 4. Spreadsheet file
C.	 1.	T	 2. T	 3. T	 4. F
D.	 1.	�Name of the common folders provided by Windows 10 are Documents, Videos, Pictures.
	 2.	Organised files and folders help us find the right files to use when we run a program.
E.	 1.	�A folder is a collection of various files and sub folders whereas a file is a collection of related 

information.
	 2.	To delete a file or folder, follow the given steps: 
	 	 Step 1	 Open the folder that contains the file you want to delete. 
	 	 Step 2	 Right-click on File or folder. 
	 	 Step 3	 Click on Delete option.
F.	 Kabir can restore the deleted file from the Recycle Bin on his computer.

In the lab

Do it yourself.

	Page Formatting and Mail Merge in Word 2016

Exercise

A.	 1. a 	 2. b 	 3. a 	 4. a 	 5. c

B.	 1. Indentation 	 2. Bottom 	 3. Tabs 	 4. Breaks

C.	 1.	The components of Mail Merge are: Main Document, Data Source and Merged Document. 

	 2.	There are two types of orientations in Word 2016: Portrait and Landscape.

1.

2.
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	Enhancing a Presentation

Exercise

A.	 1. c	 2. b	 3. a	 4. c	 5. a

B.	 1.	Design	 2. Justify	 3. Insert	 4. Chart Layouts

C.	 1. �Slide Master is used to create the default layout and appearance of the slides in the 
presentation. 

	 2.	To align the text, follow these steps: 

	 	 Step 1	 Select the text. Click on Home tab. 

	 	 Step 2	� Select any alignment option from the Paragraph group. The text will be aligned 
according to selected alignment.

	 3. �A chart is an important part of PowerPoint to display data in pictorial form. It makes it easier 
to draw comparison and analyse the growth, relationship and trends among the values in a 
table. 

D.	 1.	To insert a table in a slide, follow these steps: 

	 	 Step 1	 �Create a new presentation or open an existing presentation and select the slide 
on which you want to insert a table. 

	 	 Step 2	 �Click on Table command from the Tables group under the Insert tab.  
A drop-down menu appears.

	 	 Step 3	� Hover the mouse over the square boxes and click on the last box up to which you 
want to insert the table. 

	 	 The table with selected rows and columns will be inserted. 

	 2.	To insert a chart in a slide, follow these steps: 

		  Step 1	� Select the slide on which you want to add a chart. Click on the Chart command 
under the Illustrations group of the Insert tab. The Insert Chart dialog box 
appears. 

		  Step 2	 Select the type of chart from the left pane and chart format from the right pane

		  Step 3	 Click on OK button.

	 3.	Theme Background is a background style of the theme. 

		  To change Theme Background, follow these steps:

	 	 Step 1	� Click the Background Styles command under the More button of the Variants 
group, on the Design tab of the ribbon. 

3.D.	 1.	To insert Header in a Document, follow these steps: 

	 	 Step 1	 Click on Insert tab. 

	 	 Step 2	 Click on the Header command. 

	 	 Step 3	� You can choose from various available header templates or choose Blank option 
to enter text of your choice. 

	 2.	To create New Address List in mail merge, follow these steps:

	 	 Step 1	� Click on Select Recipients command in the Start Mail Merge group under Mailings 
tab.

	 	 Step 2	� Select the Type New List option from the drop-down list. The New Address List 
dialog box will appear.

	 	 Step 3	� Enter required details like Title, First Name, Last Name, Address Lines, etc. for all 
the recipients. When the details of all the recipients have been added, click on OK 
button.

	 	 Step 4	� This will open Save Address List dialog box. Enter a name for  the file and click on 
Save button.

E.	 Kabir can use Tab key to indent the first line of each paragraph  by ½ inch.
In the lab

Do it yourself.

Periodic Assessment–1
(Based on chapters 1 & 2)

A.	 1.	e	 2. d	 3. a	 4. b	 5. c
B.	

Search barAddress barForward

Toolbar

Back

Navigation 
Pane
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	Enhancing a Presentation

Exercise

A.	 1. c	 2. b	 3. a	 4. c	 5. a

B.	 1.	Design	 2. Justify	 3. Insert	 4. Chart Layouts

C.	 1. �Slide Master is used to create the default layout and appearance of the slides in the 
presentation. 

	 2.	To align the text, follow these steps: 

	 	 Step 1	 Select the text. Click on Home tab. 

	 	 Step 2	� Select any alignment option from the Paragraph group. The text will be aligned 
according to selected alignment.

	 3. �A chart is an important part of PowerPoint to display data in pictorial form. It makes it easier 
to draw comparison and analyse the growth, relationship and trends among the values in a 
table. 

D.	 1.	To insert a table in a slide, follow these steps: 

	 	 Step 1	 �Create a new presentation or open an existing presentation and select the slide 
on which you want to insert a table. 

	 	 Step 2	 �Click on Table command from the Tables group under the Insert tab.  
A drop-down menu appears.

	 	 Step 3	� Hover the mouse over the square boxes and click on the last box up to which you 
want to insert the table. 

	 	 The table with selected rows and columns will be inserted. 

	 2.	To insert a chart in a slide, follow these steps: 

		  Step 1	� Select the slide on which you want to add a chart. Click on the Chart command 
under the Illustrations group of the Insert tab. The Insert Chart dialog box 
appears. 

		  Step 2	 Select the type of chart from the left pane and chart format from the right pane

		  Step 3	 Click on OK button.

	 3.	Theme Background is a background style of the theme. 

		  To change Theme Background, follow these steps:

	 	 Step 1	� Click the Background Styles command under the More button of the Variants 
group, on the Design tab of the ribbon. 

3.
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	 	 Step 2	 Click on the New option. 

	 	 Step 3	 Click on Blank workbook option in the Available Templates list. 

	 	 The new workbook file will open and you can start adding your own data. 

	 5.	�A label is an important entry in Excel. The label is used to define the information on the 
spreadsheet, i.e. heading of columns, titles and names. It is any text besides phone numbers, 
numbers, formulas, etc. Labels are aligned on the left side of a cell.

F. 	 �He will use Save command. 
In the lab

Do it yourself.

	Editing in Excel 2016

Exercise

A.	 1.	a	 2. a 	 3. b 	 4. a

B. 	 1.	Insert 	 2. Unmerge cells 	 3. Select all 	 4. Merge & Center 

C.	 1.	F 	 2. T	 3. F 	 4. T 

D.	 1.	Yes, we can unmerge the merged cells by using Unmerge Cells option.

	 2.	Copy command is used to copy the content at new place and also exist its original place.

	 3.	The default column width is 0 to 255 and a row height is 0 to 409.

E.	 1.	To merge cells, follow these steps: 

	 	 Step 1	 Select two or more adjacent cells that you want to merge. 

	 	 Step 2	 Click on Merge & Center command in the Alignment group on Home tab.

		�  The cells will be merged in a row or column, and the cell content will be centered in the 
merged cell.

	 2.	To change the row height and column width, follow these steps:

	 	 Step 1	 Select the column(s) or row(s) whose width or height you want to change. 

	 	 Step 2	 Click on Format command in Cells group from Home tab. 

	 	 Step 3	 �Choose Column Width or Row Heights under Cell Size section from the drop-down list.

		  A Column width or Row height dialog box will appear.

	 	 Step 4	� In the Column Width or Row Height box, type the value that you want your column 
or row to be. 

5.

	 	 Step 2	� Place your mouse pointer over any of the background styles. The background 
style will be reflected on the slide for you to evaluate. 

	 	 Step 3	 Click when you find a background style that you like.

E.	 Aarav can find various theme options for his presentation under the Design tab.
In the lab

Do it yourself.

	Introduction to Excel 2016

Exercise

A.	 1. a	 2. a	 3. c	 4. b

B.	 1.	T	 2. F	 3. T	 4. T

C.	 1. Excel 2016	 2. Calculations	 3. formula	 4. 1048576

D.	 1.	Spreadsheet is a program that allows you to store and analyse numerical data.

	 2.	The vertical divisions on a worksheet are called columns.

	 3.	16,384 columns.

E.	 1.	�The data in the form of numbers or text can be entered by just clicking on a cell and typing 
with the help of a keyboard. You can type data directly into the cell, or you can enter data 
using the Formula bar.

	 2.	�Any three components of  the Excel window are:

	 	 (i)	� File Tab: A green button located at the left top corner that contains the file menu 
commands such as New, Open, Save, etc. 

		  (ii)	 Ribbon: This bar has tabs with group of related commands displayed on it. 

		  (iii)	 Name Box: The address of the active cell is displayed in this box.

	 3.	�In Excel, there are three different types of data. These are- Labels, Values or Numbers and 
Formula.

	 	� Formula: A formula is a mathematical expression used to do simple and complex calculations 
of the numeric data inserted in a cell or a range of cells. A formula always begins with an 
equal to (=) sign e.g. = A2 + B2.

	 4.	You can create a new workbook any time by following these steps: 

	 	 Step 1	 Click on File tab. 

	 	 Backstage view will appear.

4.
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	 	 Step 2	 Click on the New option. 

	 	 Step 3	 Click on Blank workbook option in the Available Templates list. 

	 	 The new workbook file will open and you can start adding your own data. 

	 5.	�A label is an important entry in Excel. The label is used to define the information on the 
spreadsheet, i.e. heading of columns, titles and names. It is any text besides phone numbers, 
numbers, formulas, etc. Labels are aligned on the left side of a cell.

F. 	 �He will use Save command. 
In the lab

Do it yourself.

	Editing in Excel 2016

Exercise

A.	 1.	a	 2. a 	 3. b 	 4. a

B. 	 1.	Insert 	 2. Unmerge cells 	 3. Select all 	 4. Merge & Center 

C.	 1.	F 	 2. T	 3. F 	 4. T 

D.	 1.	Yes, we can unmerge the merged cells by using Unmerge Cells option.

	 2.	Copy command is used to copy the content at new place and also exist its original place.

	 3.	The default column width is 0 to 255 and a row height is 0 to 409.

E.	 1.	To merge cells, follow these steps: 

	 	 Step 1	 Select two or more adjacent cells that you want to merge. 

	 	 Step 2	 Click on Merge & Center command in the Alignment group on Home tab.

		�  The cells will be merged in a row or column, and the cell content will be centered in the 
merged cell.

	 2.	To change the row height and column width, follow these steps:

	 	 Step 1	 Select the column(s) or row(s) whose width or height you want to change. 

	 	 Step 2	 Click on Format command in Cells group from Home tab. 

	 	 Step 3	 �Choose Column Width or Row Heights under Cell Size section from the drop-down list.

		  A Column width or Row height dialog box will appear.

	 	 Step 4	� In the Column Width or Row Height box, type the value that you want your column 
or row to be. 

5.
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	 3.	To rename a worksheet tab, follow these steps:

	 	 Step 1:	 On the Worksheet tab right-click the sheet tab that you want to customize.

		  Step 2: Click Rename to rename the sheet.

		�  Type the name you would like for your spreadsheet. The information will be added to the 
tab at the bottom of the spreadsheet.

F.	 �She can set the column width and row height using Format command in Cells group from 
Home tab.

In the lab

Do it yourself.

Periodic Assessment–2
(Based on chapters 3 to 5)

A.	

Components of Excel 2016

Quick Access Toolbar Title Bar Control buttons

Formula 
bar

Name box

Active Cell

Worksheet Tab

Status bar

Mouse Pointer

B.	 1.	Workbook		  2. Name Box

C.	

Legend

X-axis

Y-axis

Grid lines

Data Labels

Data Series

Plot Area

Chart Title
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Test Sheet–1
(Based on chapters 1 to 5)

Section A

A.	 1.	(i)	 2. (ii)	 3. (i)	 4. (iii)	 5. (ii)

	 6.	(i)	 7. (i)	 8. (i)

B.	 1.	10,48,576	 2. Folder	 3. Subfolder	 4. Design 	 5. Indentation

C.	 1.	T	 2. T	 3. F	 4. T	 5. F

	 6.	F	 7. F	 8. T

Section B

A.	 1.	�A theme is a set of predefined layout that can be used to add a professional touch to your 
presentations.

	 2.	�Slide Master in PowerPoint is used to create the default layout and appearance of all the 
slides in the presentation.

	 3. 	There are three main components of Mail Merge, which are as follow:

		  Main Document, Data Source and Merged Document.

	 4.	Organised files and folders help us find the right files to use when we run a program. 

	 5.	There are two types of orientations in Word 2016: Portrait (Vertical) and Landscape (Horizontal). 

B.	 1.	�To insert a chart in a slide, follow these steps:

	 	 Step 1	� Select the slide on which you want to add a chart and click on the Chart command 
under the Illustrations group of the Insert tab. The Insert Chart dialog box appears.

	 	 Step 2	� Select the type of chart from the left pane and chart format from the right pane.

	 	 Step 3	 Click on OK button.

	 2.	�To delete a file or folder, follow these steps:

	 	 Step 1	 Open the folder that contains the file you want to delete. 

		  Step 2	� Right-click on the contains the file you want to delete. A drop-down menu appears.

		  Step 3	 Click on Delete option.

	 3.	Title Bar, Ribbon and Formula Bar.

	 4.	To change row height or column width, follow the given steps:

	 	 Step 1	 Select the column(s) or row(s) whose width or height you want to change. 

	 	 Step 2	 Click on Format command in Cells group from Home tab. 
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	 	 Step 3	� Choose Column Width or Row Height under Cell Size section from the drop-down 
list. 

	 		  A Column width or Row height dialog box will appear. 

	 	 Step 4	� In the Column Width or Row Height box, type the value that you want your column 
or row to be. 

	 	 Step 5	 Click on OK button to get new row height / column width. 

	 5.	To create New Address List in mail merge, follow these steps:

	 	 Step 1	 �Click on Select Recipients command in the Start Mail Merge group under Mailings 
tab.

	 	 Step 2	� Select the Type New List option from the drop-down list. The New Address List 
dialog box will appear.

	 	 Step 3	 �Enter required details like Title, First Name, Last Name, Address Lines, etc. for all 
the recipients. when the details of all the recipients have been added, click on OK 
button.

	 	 Step 4	� This will open Save Address List dialog box. Enter a name for  the file and click on 
Save button.

	Internet and E-Mail

Exercise

A.	 1. a	 2. a	 3. c	 4. c

	 5. b	 6. b

B.	 1. F	 2. F	 3. F	 4. F

	 5. T	 6. F

C.	 1. Bcc	 2. To	 3. Cc	 4. Attachment	 5. Sent

D.	 1.	�Internet is a network in which millions of computers are connected to one another to share 
information.

	 2.	�Acronym is a word formed from the initial letters of a multi-word name. It may be in the form 
of an abbreviation like HTML or more than one letter from some words like COBOL.

	 	 Two common acronyms are:

	 	 •  LOL	 Laughing Out Loud

	 	 •  F9	 Fine

6.

	 3.	Yes, we can send a video file as attachment in an e-mail.

	 4.	�You can sign out from your e-mail account by following these steps:

	 	 Step 1	� Click on the icon on the Google Account at the top right corner of your browser 
window.

	 	 Step 2	 Click on Sign out button.

E.	 1.	�Logging In or login is the process of accessing your e-mail account by providing the user 
name and password.

	 2.	Advantages of E-mail are: 

	 	 (i)	 An e-mail can be sent anytime and from anywhere in the world. 

	 	 (ii)	 An e-mail can be sent to many people at a time. 

	 	 (iii)	 An e-mail can be easily forwarded to anyone without typing it again.

	 3.	Features of E-mail are: 

	 	 (i)	 Ability to attach the files along the message 

	 	 (ii)	 Ability to store the information such as message and contact list 

	 	 (iii)	 Ability to send Multipurpose Internet Mail Extensions (MIME) type files.

F.	 He should use Bcc feature.
In the lab

Do it yourself.

	Data Processing

Exercise

A.	 1. b	 2. a	 3. c

B.	 1.	�Data refers to the raw input. When this data is processed, the outcome received is known as 
information. 

	 2.	The process of converting a hidden message to a meaningful text is called decoding. 

C.	 1.	Four ways in which we can represent information:

	 	 •  Tables

		  •  Pictures

	 	 •  Pictures

		  •  Pictograms

7.
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	 3.	Yes, we can send a video file as attachment in an e-mail.

	 4.	�You can sign out from your e-mail account by following these steps:

	 	 Step 1	� Click on the icon on the Google Account at the top right corner of your browser 
window.

	 	 Step 2	 Click on Sign out button.

E.	 1.	�Logging In or login is the process of accessing your e-mail account by providing the user 
name and password.

	 2.	Advantages of E-mail are: 

	 	 (i)	 An e-mail can be sent anytime and from anywhere in the world. 

	 	 (ii)	 An e-mail can be sent to many people at a time. 

	 	 (iii)	 An e-mail can be easily forwarded to anyone without typing it again.

	 3.	Features of E-mail are: 

	 	 (i)	 Ability to attach the files along the message 

	 	 (ii)	 Ability to store the information such as message and contact list 

	 	 (iii)	 Ability to send Multipurpose Internet Mail Extensions (MIME) type files.

F.	 He should use Bcc feature.
In the lab

Do it yourself.

	Data Processing

Exercise

A.	 1. b	 2. a	 3. c

B.	 1.	�Data refers to the raw input. When this data is processed, the outcome received is known as 
information. 

	 2.	The process of converting a hidden message to a meaningful text is called decoding. 

C.	 1.	Four ways in which we can represent information:

	 	 •  Tables

		  •  Pictures

	 	 •  Pictures

		  •  Pictograms

7.
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	 2.	�This tabular format represents the data which gives us the information in a neat and clean 
manner. It becomes easier to read the data when it is presented in such a format. 

D.	 1.	It is easier to find data when they are arranged.

	 2.	Doded Data
In the lab

Do it yourself.

Periodic Assessment–3
(Based on chapters 6 & 7)

A.	 1.	E-mails that you have received from others are stored.

	 2.	It is the folder where all e-mails that you send to others are stored. 

	 3.	It is the folder where all outgoing e-mails are temporarily stored. 

	 4.	�It is the folder where all unwanted incoming e-mails are stored so that they stays out of the 
inbox folder. 

	 5.	It is the folder where all deleted e-mails are usually stored for a defined time period.

B.	 1.	Advanced Research Projects Agency Network

	 2.	Control Protocol/Internet Protocol

	 3.	World Wide Web

	 4.	Hypertext Transfer Protocol

C.	 1.	HELLO		  2. FLOWER

	 3. TREASURE		  4. PROGRAM

D.	 1.	Pictograms		  2. Pictures

	Creating Shapes in Scratch

Exercise

A.	 1.	a	 2. c 	 3. c 	 4. b 
B.	 1.	F 	 2. F 	 3. T	 4. T
C.	 1.	Pen block draws a trail as the Sprite moves on the stage. 

8.

	 2.	Steps to draws a line in Scratch: 

	 	
	 3.	Just divide 360 by the number of sides in the shape.

D.	 1.	Polygons are 2D shapes with three or more straight lines and angles.

	 	 Three polygon shapes are triangle, square and pentagon. 

	 2.	�The main difference between drawing a square and a rectangle in Scratch is the number of 
steps used in script. In square we use Repeat 4 Move 100 Steps Turn 90 degrees whereas in 
rectangle we use Repeat 4 Move 200 Steps Turn 90 degrees Move 100 Steps Turn 90 degrees.

E. 	 1.	 Sides 0

	 	 Degree 360 

	 2.	 Sides 8

	 	 Degree 90

	 3.	 Sides 45

	 	 Degree 72

F.	 Vidhi needs to change the turn block to 40 degrees instead of 30.
In the lab

Do it yourself.

	Creating A Game in Scratch

Exercise

A.	 1.	a	 2. b 	 3. a 	 4. b 

B.	 1.	Hat	 2. Sensing	 3. Variables	 4. Ask 

C. 	 1.	T	 2. T	 3. F	 4. F 

9.
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	 2.	Steps to draws a line in Scratch: 

	 	
	 3.	Just divide 360 by the number of sides in the shape.

D.	 1.	Polygons are 2D shapes with three or more straight lines and angles.

	 	 Three polygon shapes are triangle, square and pentagon. 

	 2.	�The main difference between drawing a square and a rectangle in Scratch is the number of 
steps used in script. In square we use Repeat 4 Move 100 Steps Turn 90 degrees whereas in 
rectangle we use Repeat 4 Move 200 Steps Turn 90 degrees Move 100 Steps Turn 90 degrees.

E. 	 1.	 Sides 0

	 	 Degree 360 

	 2.	 Sides 8

	 	 Degree 90

	 3.	 Sides 45

	 	 Degree 72

F.	 Vidhi needs to change the turn block to 40 degrees instead of 30.
In the lab

Do it yourself.

	Creating A Game in Scratch

Exercise

A.	 1.	a	 2. b 	 3. a 	 4. b 

B.	 1.	Hat	 2. Sensing	 3. Variables	 4. Ask 

C. 	 1.	T	 2. T	 3. F	 4. F 

9.
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D.	 1.	ask [ ] and wait, touching color [ ]? and key [space] pressed?

	 2.	�Sensing blocks in Scratch sense the input from the keyboard or the mouse at the time of 
execution of a script. 

E.	 1.	�Variable is an element that stores all the numbers, text, date or pictures that we use in a 
program. 

	 	 To create variables in Scratch, follow these steps: 

	 	 Step 1	 Click on Variables block category. A set of blocks appears in the block palette.

	 	 Step 2	� Click on Make a Variable block. A New Variable dialog box appears. Type a variable 
name in the New variable name box. 

	 	 Step 3	 �Click on the radio button of either of the options. Click on For all sprites if you want 
this variable to appear for all the sprites. 

	 	 	 Or 

	 	 	 �Click on For this sprite only if you want this variable to appear all the sprites only. 

	 	 Step 4	 Click Ok button. 

	 2.	Scratch has two conditional blocks. They are: 

		  a. �If…then block: In this block if the condition is true, the blocks inside conditional block will 
run. If the condition is false, the blocks inside conditional block will not run. Only the blocks 
outside the conditional block will run. 

		  b. �If…then…..else block:  In this block if the condition is true, the blocks inside then condition 
will run. If the condition is false, the blocks inside else condition will run.

	 3.	To add sensing blocks to the script, follow these steps: 

	 	 Step 1	 Click on the Sensing block category in Tabs. 

	 	 Step 2	 Insert a sprite, Penguin2 on the stage. Delete the cat sprite. 

	 	 Step 3	 Add a new backdrop to the stage, Arctic. 

	 	 Step 4	� Now drag the ask block to the script area. Click on the block. A speech bubble 
appears above the penguin with the text, “What’s your name?”. 

		�  You will also see an input box on the stage with a blinking cursor. Type your name. It will 
appear in the input box. Click on the tick button or press the Enter key. You will notice that 
the input box waits for your input.

		  Also, when you type the name and press Enter key, the name disappears.

	 	 Step 5	� To display the typed name also, click on the check box before the answer block. The 
answer appears on the stage.conditions.

F.	 1.	b	 2. c	 3. d	 4. a

	 5.	f	 6. e

G.	 He will use conditional blocks in the game.
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Do it yourself.

Hands-On

In the lab

Do it yourself.

	Robotics

Exercise

A.	 1.	b	 2. c	 3. a	 4. a

B.	 1.	Unimate	 2. Robonaut 2	 3. Underwater	 4. Sophia

	 5.	Zenbo

C.	 1.	T	 2. T	 3. F	 4. F

D.	 1.	Nao

	 2.	�Surgical robots help doctors in performing surgery in healthcare field. Some of the humanoids 
can be a good companion to the recovering patients with serious illness. 

E.	 1.	�In entertainment industries, robots are proving to be a great help in managing the cameras, 
providing special effects, performing stunts in an action movie.

	 2.	�This robot is claimed to have skills of master chef. It would learn new recipes, cook for you, 
and clean up afterwards.  

F.	 1.	Suzumo

	 2.	Z-Machines
In the lab

Do it yourself.

Periodic Assessment–4
(Based on chapters 8 to 10)

A.	 1.	The repeat block is used to run a set of instructions for a specified number of times.
	 2.	The forever block is used to run a set of instructions continuously until stopped.
	 3.	�This block displays a speech bubble with the specified text for the sprite that runs it, which 

appears on the screen for the specified number of seconds.

10.
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B.	 1. d 	 2. c	 3. a 	 4. b

C.	

1.  T-HR3 2.  Nao

3.  Sophia 4.  Paro

Test Sheet–2
(Based on chapters 6 to 10)

Section A

A.	 1.	(iii)	 2. (iii)	 3. (ii) 	 4. (ii)

	 5.	(ii)	 6. (i)

B.	 1.	Hat	 2. Underwater	 3. Cc	 4. Attachment	 5. ask

C.	 1.	T	 2. T	 3. T	 4. F

	 5.	F	 6. T

Section B

A.	 1. �Sensing blocks in Scratch sense the input from the keyboard or the mouse at the time of 
execution of a script.

	 2. Pen block draws a trail as the Sprite moves on the stage. 

	 3. �Emoticons are used to represent your facial expressions. They help in telling your mood to 
others as well as save typing time. 

	 4. Copy command is used to copy the content at new place and also exist its original place.

B.	 1.	Scratch has two conditional blocks. They are:
	 	 a. �If…then block: In this block if the condition is true, the blocks inside conditional block 

will run. If the condition is false, the blocks inside conditional block will not run. Only the 
blocks outside the conditional block will run.
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	 	 b. �If…then…..else block: In this block if the condition is true, the blocks inside then 
condition will run. If the condition is false, the blocks inside else condition will run.

	 2.	�The main difference between drawing a square and a rectangle in Scratch is the number of 
steps used in script. In square we use Repeat 4 Move 100 Steps Turn 90 degrees whereas 
in rectangle we use Repeat 4 Move 200 Steps Turn 90 degrees Move 100 Steps Turn 90 
degrees. 

	 3.	A program is a set of instructions that tell the computer to carry out a task. 
		  To create variables in Scratch, follow the given steps: 
	 	 Step 1	 Click on Variables block category. A set of blocks appears in the block palette. 

	 	 Step 2	� Click on Make a Variable block. A New Variable dialog box appears. Type a variable 
name in the New variable name box. 

	 	 Step 3	� Click on the radio button of either of the options. Click on For all sprites if you want 
this variable to appear for all the sprites. 

	 		  Or 

	 		�  Click on For this sprite only if you want this variable to appear for this sprite only. 
Here we have added the variable fruit. It will be available for all the sprites.

	 	 Step 4	 Click OK button. 

	 	� The variable appears in the list of Variables blocks. Observe that the variable name fruit 
appears in all the blocks.

	 4.	�In entertainment industries, robots are proving to be a great help in managing the 
cameras, providing special effects, performing stunts in an action movie, etc.


