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Answer KeyClass

6

Touchpad PLUS Ver 2.2

 Advanced Features of PowerPoint 2016

Let’s Plug-in  (Page no. 7)

1. T				    2.  T		  3.  F		  4.  F

Let’s Catch Up  (Page no. 11)
1. a	 	 2. a

Test Your Skills

1.	 a.	 (iii)		  b.  (i)		  c.  (ii)		  d.  (iii)		  e.  (i)

2.	 a.  Audio on my PC		 b.  Record 	 c.  Media, Insert 		 d.  Action 

3.	 a.  F		  b.  T		  c.  F		  d.  F

4.	 a.	� If we select the Print All Slides option while printing, it will print all the slides in the 
presentation.

	 b.	� Action buttons are some built in shapes which you can add to your slides. This action happens 
when you either click an object or hover your mouse over in a slideshow. It can open a web 
page, an e-mail, a linked file, slide in presentation, etc.

	 c.	 The two ways of inserting an audio file in the PowerPoint presentation are: 

	 	 • Audio on My PC 

	 	 • Record Audio

5.	 a.	 To insert a video file from the Internet, follow the steps given below:

		  Step 1:	 Click on Video command under the Media group of the Insert tab.

		  Step 2:	 Click on the Online Video option.

		  Step 3:	 Search your video on the website. 

		  Step 4:	 Click on the Insert button.

1.
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	 b.	 The printing options are:

		  i.  Print All slides      ii.  Print Selection      iii.  Print Current Slide

6.	 a.	 To insert a recorded audio file in a presentation, follow the steps given below:

		  To insert an audio file, follow the steps given below: 

		  Step 1:	 Click on the Audio command under the Media group of the Insert tab. 

		  Step 2:	 From the drop-down menu select Record Audio option.

		  Step 3:	� Selecting this option opens the Record Sound dialog box. Type a name for your 
audio. To record your voice, click on the Record button and speak. After recording, 
click on the Stop button to stop the recording. To listen to your recording, click 
on Play button. If you are happy with your audio, click on the OK button. This will 
insert the recorded sound file in the slide. If you are not happy with your recording, 
record again by clicking on the Record button. 

	 	 Step 4:	� An audio icon/speaker icon appears in your slide, indicating that your audio is 
inserted. 

	 b.	 To insert a video file, follow the steps given below: 

	 	 Step 1	� Click on Video command under the Media group of the Insert tab. A drop-down 
menu displays two options. 

	 	 Step 2:	� Online Video:Search and select a video from the Internet (e.g., YouTube). Only the 
URL and thumbnail are inserted.

			   OR

			�   Video on My PC: Opens the Insert Video dialog box to browse and insert a local 
video file.

	 	 Step 3:	 Click on the Insert button. 

	 	 Step 4:	� The video will be added to the slide. Clicking the Play/Pause button will play or 
pause the video file.  

Tech Zone

Let's Solve

	 a.  Record Audio		  b.  Online Video		 c.  Print Selection

	 d.  Print Current Slide 	 e.  Action Button

Let’s Explore

	 Do it yourself.
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 More on Excel 2016

Let’s Plug-in  (Page no. 18)

1.	 4 rows and 4 columns	 2.  300	 3.  109
4.	 B4 and C3		  5.  D4

Let’s Catch Up  (Page no. 29)
1.	 T		  2.  T		  3. F

Test Your Skills

1.	 a.	 (iv)		  b.  (iii)		  c.  (i)		  d.  (ii)		  e.  (i)
2.	 a.	 F		  b.  T		  c.  F		  d.  T		  e.  F
3.	 a.	 Insert		  b.  Cell Styles	 c.  Select All	 d.  Merge & Center	 e.  Operators
4.	 a.	 Yes, we can unmerge the merged cells. Name of command is Unmerge Cells.
	 b.	� Copy command is used to copy the data at the new place while the data also exists at its 

original place.
	 c.	 Wrap Text feature of Excel allows us to display multiple lines of text inside a cell.
5.	 a.	 Steps to wrap the text in a cell:
	 	 Step 1:	 Click the cell in which you want to wrap the text.

		  Step 2:	� Click on Wrap Text command from Alignment group under Home tab. The text in 
your cell will be wrapped.

	 b.	 To change row height and column width follow these steps:
		  Step 1:	 Select the column(s) or row(s) whose width or height you want to change.

		  Step 2:	 Click on Format command in Cells group from Home tab.

	 	 Step 3:	 Choose Column Width or Row Heights under Cell size.

	 	 Step 4:	 �In the Column Width or Row Height box, type the value that you want your column 
or row to be.

	 c.	 To apply cell border follow these steps: 
	 	 Step 1:	� On a worksheet, select the cell or range of cells that you want to add a border to, 

change the border style on, or remove a border from. 

	 	 Step 2:	 Go to the Font group in the Home tab. 

	 	 Step 3:	 Click the arrow next to Borders command. 

		  Step 4:	 Click on the border style you would like.

6.	 a.	� By using the Wrap Text command present on the Alignment group in the Home tab, Sonia 
can make the text visible. 

2.
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	 b.	She can insert a column using Insert command under Home tab.

Tech Zone
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Let’s Explore

	 Do it yourself.

Periodic Assessment–1
(Based on chapters 1 & 2)

A.	 1.	 AutoFill feature automatically fills a series of data in your worksheet.

	 2.	 Action buttons are some built-in shapes which you can add to your slides. Clicking an action 
button can open a webpage, an email, a linked file, another slide in the same presentation 
or a slide in a different presentation.

	 3.	 Combining two or more cells is known as Merging.

	 4.	 Selecting this option opens the Record Sound dialog box. Type a name for your audio. To 
record your voice, click on the Record button and speak. After recording, click on Stop button 
to stop the recording. To listen to your recording, click on Play button. If you are happy with 
your audio, click on OK button.

B.	 3 Select No Border option.

	 1 Go to the Font group in the Home tab.

	 2 Click the arrow next to Borders command.

C.	 1.	 Ritvik can use the Record Audio option.

	 2.	 Vansh can use the AutoFill option.



5Touchpad PLUS (Version 2.2)-VI (Answer Key)

	Formulas and Functions in Excel 2016

Let’s Plug-in  (Page no. 35)
Average marks and percentage is 90.

Let’s Catch Up  (Page no. 45)

1.	 5			   2.  Comp		  3.  7		  4.  4/2/2025
5.	 5			   6.  3

5.	 5	 6.  3Test Your Skills

1.	 a.  (i)			   b.  (i)			   c.  (ii)		  d.  (iii)		  e.  (iv)

2.	 a.  F			   b.  F			   c.  F		  d.  F		  e.  T

3.	 a. Functions		  b.  Concatenate		 c.  if		  d.  dollar($)	 e.  MIN()

4.	 a.	 A cell reference is a cell address that can be used in a formula to denote a specific cell.

	 b.	 TODAY() AND NOW()

	 c.	� Absolute cell referencing is a method in Excel where the cell reference remains constant, 
even when the formula is copied to another cell. This is done by placing a dollar sign ($) 
before the column and row (e.g., $A$1), so the reference does not change when copied.

	 d.	 SUM() adds the values in a range of cells. 

5.	 a.	� Mathematical functions calculates the square root or absolute value of a number, product 
of numbers, etc.

		  The names of two Mathematical functions are SUM(range) and PRODUCT (range).

	 b.	� LEN function is used to return the length of the text string. For example: Input: =LEN(“Touch”)
Output: 5

	 c.	 There are mainly two ways to enter a formula in a worksheet:

	 	 •  �Typing the formula directly in the Cell: After typing an equal sign, enter the formula in the 
cell and press the Enter key. Result of the formula will appear in the cell.

	 	 •  �Typing the formula in the Formula bar: After selecting the cell, type the formula in the 
formula bar starting with equal sign and then press the Enter key.

	 d.	 Rules to enter a function:

	 	 •  All Excel functions must begin with = sign.

	 	 •  Function name must be a valid Excel name.

	 	 •  Function must be followed by opening and closing parenthesis.

	 	 •  Most of the functions must contain an argument within it.

3.
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6.	 a.	 SQRT: It returns the square root of the given number.

	 b.	 DAY: It returns the current day.

	 c.	 MOD: It returns the remainder after a number is divided by the divisor.

	 d.	 INT: It rounds number to an integer value.

	 e.	 MIN: It returns the smallest value in the given range.

7.	 a.	 Nidhi should use formulas in her spreadsheet.

	 b.	 (i)  She forgot to begin the formula with an equal sign.

		      =C2*D2

		  (ii)   After fixing the formula in E2, Anjana can use the Auto Fill handle to copy the formula.

		  (iii)  �Anjana is adding up all the values from E2 to E7 to get the total amount spent on all 
items.

		  (iv)  Anjana should use the MAX() function.

Tech Zone
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Let’s Explore

	 Do it yourself.

	 Introduction to Animate 2024

Let’s Plug-in  (Page no. 50)
Do it yourself.

4.
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Let’s Catch Up  (Page no. 57)

The fill is the inside of the drawn object. 

Test Your Skills

1.	 a.  (i)		  b.  (iv)			   c.  (ii)		  d. (i)

2.	 a.  HTML5		  b.  Symbol		  c.  Stage 	 d.  Lasso	 e.  Enclosed

3.	 a.	� Properties panel is also called Property Inspector, this panel displays the different properties 
of the object, which is selected. We can edit the properties of the selected object by changing 
the settings of the object from the Property Inspector. 

	 b.	 Gradient Fill is a combination of colours where one colour changes into another.

	 c.	 Two main components of every shape in Adobe Animate 2024 are as follows:

	 	 •  �Stroke: The outline or border of a shape. You can change its colour, thickness, and style.

	 	 •  �Fill: The inside area of a shape. It can be a solid colour, gradient, or image.

4.	 a.	 i.  Selection tool is used to select objects on the stage for modification. 

		  ii. � Pen tool is used to draw lines and curves by creating a series of dots that are automatically 
connected.

		  iii.  Free-transform tool is used to move, scale, rotate, skew, or distort objects.

	 b.	 To convert an object into symbol, perform the following steps:

		  Step 1:	 Click on the Selection Tool in Tools panel.

	 	 Step 2:	� Click and select the object on the Stage. Click on the Modify → Convert to Symbol 
option from the menu bar. 

	 	 Step 3:	 �The Convert to Symbol dialog box appears. Enter a suitable name for the symbol 
and click on OK button. The new symbol is listed in the Library panel.

5.	 a.	 Library Panel

	 b.	 Properties Panel

Tech Zone

Let's Solve

	 1.	 a.  Outside the stage 		  b.  Sub – Select
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Let’s Explore

Do it yourself.

Periodic Assessment–2
(Based on chapters 3 & 4)

A.	 1.	 Cell reference	 2. Timeline	 3. Functions 

	 4.	 Logical Function	 5. Instance

B.	

Playhead Timeline

Properties Panel

Library Panel

PasteboardStageMenu Bar

Tools  
Panel

C.	 1.	 1. Movie Clip Symbol	 2. NOW()
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Test Sheet–1
(Based on chapters 1 to 4)

A.	 1.  (iii)	 2.  (i)	 3.  (iv)	 4.  (iii)	 5.  (i)

	 6.  (i)	 7.  (i)	 8.  (iv)

B.	 1.  F	 2.  T	 3.  F	 4.  T	 5.  F

	 6.  F

C.	 1.  Audio on my PC	 2.  Record	 3.  Insert	 4. Cell Styles

	 5.  dollar ($) 	 6.  MIN()	 7. Stage	 8. Lasso

D.	 1.  iv.	 2.  i.	 3. ii.	 4. iii.

E.	 1.	 If we select the Print All Slides option while printing, it will print all the slides in the 
presentation.

	 2.	� Action buttons are some built-in shapes which you can add to your slides. This action happens 
when you either click an object or hover your mouse over in a slideshow. It can open a web  
page, an e-mail, a linked file, slide in presentation, etc.

	 3.	 Yes, we can unmerge the merged cells. Name of command is Unmerge Cells.

	 4.	� Copy command is used to copy the data at the new place while the data also exists at its 
original place.

	 5.	� Relative cell referencing refers to a cell that is above or below and left or right to a number 
of rows or columns.

	 6.	 It is used to return the sum of a range.

	 7.	 Gradient Fill is a combination of colours where one colour changes into another.

	 8.	� There are three types of symbol in Animate CC: Movie Clip Symbol, Button Clip Symbol and 
Graphic Symbol. 

F.	 1.	 To insert a video file, follow the steps given below:

	 	 Step 1:	 Click on Video command under the Media group of the Insert tab.

	 	 Step 2:	 Click on the Online Video option.

	 	 Step 3:	 Search your video on the website. 

		  Step 4:	 Click on the Insert button.

	 2.	 The printing options are:

		  i. Print All slides    ii. Print Selection    iii. Print Current Slide

	 3.	 To change row height and column width follow these steps:

	 	 Step 1:	 Select the column(s) or row(s) whose width or height you want to change.

	 	 Step 2:	 Click on Format command in Cells group from Home tab.
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		  Step 3:	 Choose Column Width or Row Heights under Cell size.

		  Step 4:	� In the Column Width or Row Height box, type the value that you want your column 
or row to be.

	 4.	 To apply cell border follow these steps: 

	 	 Step 1:	� On a worksheet, select the cell or range of cells that you want to add a border to, 
change the border style on, or remove a border from. 

		  Step 2:	 Go to the Font group in the Home tab.

	 	 Step 3:	 Click the arrow next to Borders command. 

	 	 Step 4:	 Click on the border style we would like.

	 5.	 There are mainly two ways to enter a formula in a worksheet:

	 	 • � Typing the formula directly in the Cell: After typing an equal sign, enter the formula in 
the cell and press the Enter key. Result of the formula will appear in the cell.

	 	 • � Typing the formula in the Formula bar: After selecting the cell, type the formula in the 
formula bar starting with equal sign and then press the Enter key.

	 6.	 To convert an object into symbol, perform the following steps:

	 	 Step 1:	 Click on the Selection Tool in Tools panel.

		  Step 2:	 �Click and select the object on the Stage. Click on the Modify → Convert to Symbol 
option from the menu bar. 

	 	 Step 3:	 �The Convert to Symbol dialog box appears. Enter a suitable name for the symbol 
and click on OK button. The new symbol is listed in the Library panel.

	Computer Malware

Let’s Plug-in  (Page no. 65)

Do it yourself.

Let’s Catch Up  (Page no. 69)

1.	 (ii)			  2.  (iii)		  3.  (iv)		  4.  (i)

Test Your Skills

1.	 a.  (ii)	 b.  (iv)	 c.  (i)	 d.  (iv)	 e. (iii)
2.	 a.  Malware 	 b. Antivirus 	 c. Firewall 	 d. Trojan horse
3.	 a. F	 b. F	 c. F	 d. T	 e. T	

5.
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4.	 a.	 The most commonly known categories of computer viruses are:
		   Program File Virus	  Boot Sector Virus
		   Macro Virus	  E-mail Virus
	 b.	 A malware is a type of malicious program designed to damage or carryout other unwanted 

actions on a computer system.
	 c.	 Some well-known antivirus programs are Norton, AVG, McAfee, Symantec, SmartDog, 

Kaspersky, etc.
5. 	 The ways by which we can protect our system from virus attack are as follows:

	 a.	  Download only legal software.

		   Don’t open any unknown e-mail.

		   Don’t open any e-mail attachment from unknown sources.

		   Don’t download music, program or games from unknown sources on the Internet.

		   Install an antivirus program in your computer system.

		   �Scan Pen Drive, CD and any other external storage device for viruses before opening in 
computer.

	 b.	� A firewall is a Software or hardware-based network security system that controls the incoming 
and outgoing network traffic based on applied rule set. A firewall prevents unauthorised 
access to a computer network.

	 c.	 i.   �The purpose of a trojan horse is to conceal itself inside the software that seems legitimate. 
When the software is installed on the system, the trojan gets activated and infects the 
host system.

		  ii.  �Ransom is the money demanded to release the hostage kidnapped for the purpose. 
Similarly, ransomware is malicious software used to access the data of the host system 
illegally by encrypting it. The victim has to pay a huge amount of money to the attacker 
to get back access to data. 

6.	 a.	� Dinesh may face risks like cyberbullying, identity theft, and malware due to unsafe online 
behaviour.

		  He should avoid clicking unknown links and sharing personal information to stay safe online.

	 b.	� Ryan’s computer is likely infected with malware that came bundled with the unverified 
software he downloaded.

		�  Since his computer is acting strangely and sensitive information is compromised, it's most 
likely a Trojan Horse virus.
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Let’s Explore

	 Do it yourself.

Let’s Get Better

	 Do it yourself.

	 Introduction to HTML5 and CSS3

Let’s Plug-in  (Page no. 74)

1.	 Homepage 	 2.  Website	 3.  Hyperlink	 4.  URL

Test Your Skills

1.	 a.  (i)	 b.  (ii)	 c.  (i)	 d.  (ii)
2.	 a.  Markup	 b.  Head	 c.  Block	 d.  Empty	 e.  Nesting 
3.	 a.	� HTML stands for Hypertext Markup Language. It is a markup language that describes the 

structure of the web page. It allows us to create web pages that contain paragraphs, headings, 
links and block quotes.

	 b.	 The tags that include both opening and closing tags are called Container Tags.

	 c.	 CSS handles and describes how a HTML web page will be presented on a web browser. 

	 d.	� The <Head> tag defines header area of your web page. The information given in <Head > 
tag tells the computer that this information is not to be shown on the web page.

	 e.	� To apply a rule to multiple pages, an external style sheet is used. You need to include a reference 
to the external style sheet file within the <LINK> element inside the <HEAD> element.

6.
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4.	 a.	 The rules for writing HTML tags are:

		   Container tags should always be closed properly.
		   Values given to the attributes should be enclosed within the double quotes.
	 b.	� HTML editors are software which are used to write and edit HTML codes. There are mainly 

two types of HTML editors, WYSIWYG editor and Text Editor. The most commonly used 
HTML editors are Notepad and Notepad++. 

	 c.	 An inline style is used to apply a unique style for a single element. The style attribute an element 
allows you to create and apply a style on the element. Syntax to create an inline style is:

	 	 <element style = "property1:value1; property2:value2; … ….">

5.	 a.	 <HEAD> Tag

		�  HTML provides six heading tags: <h1> (largest) to <h6> (smallest). Ajit can choose one 
based on the importance and size of the heading.

	 b.	 <TITLE> Tag

Tech Zone

Let's Solve

1.	 a.	 <Hn> tag		  b.  <Title> tag
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Let’s Explore

	 Do it yourself.

Let’s Get Better

	 Do it yourself.

Periodic Assessment–3
(Based on chapters 5 & 6)

A.	 TITLE	 </HEAD>	 </HTML>

B.	 1.  T	 2.  F	 3.  T	 4.  T	 5.  F

C.	 5 Click on Save button to save the file.

	 2 Click on Save to open Save As dialog box.

	 3 Choose the location where you want to save the file. In this case, Desktop is selected.

	 4 Enter name for the file as ‘First Web Page.html’.

	 1 Click on File menu.

D.	 1.	 Computer Virus or malware		  2. Antivirus software

	Algorithm and Flowchart

Let’s Plug-in  (Page no. 87)

ALERT MAJOR CYCLONE 

Let’s Catch Up  (Page no. 92)

	 a.	 Precision		  b. Uniqueness		  c. Finiteness

Test Your Skills

1.	 a.  (iii)		  b.  (ii)			   c.  (ii)		  d.  (i)		  e.  (i)

2.	 a.  F		  b.  T			   c.  F		  d.  T		  e.  T

3.	 a.  Algorithm	 b.  Connectors		  c.  Logical	 d.  Two		  e.  Flowchart

7.
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4.	 a.	� An Algorithm is a set of steps in a sequential and ordered manner to solve any problem. 
Algorithms are the building blocks of computer programs. They are important to programming 
as recipes are for cooking.

	 b.	 A flowchart is a type of graphical diagram that represents an algorithm.

	 c.	� (Start/Stop), Process, Decision, Input/Output, Flow Line (Arrow), Connector (Inspection)

	 d.	� An algorithm is commonly used for performing data processing, computer and mathematical 
operations, manipulating data, and searching for a particular data.

5.	 a.	 You must follow these basic rules while drawing a flowchart:

		   The flowchart should be clear, neat and easy to follow.

		   Maintain the direction of the flow from left to right or top to bottom.

		   Only one flow line should come out from a process symbol. 

		   �Ensure that only one flow line should enter a decision symbol, but two flow lines should 
leave the decision box.

		   Ensure that the flowchart has a logical start and end.

	 b.	 The main characteristics of a good algorithm are:

		   Precision: Each step is precisely defined.

		   �Uniqueness: Result of each step should be uniquely identified and only depend on the 
result of the preceding step.

		   Finiteness: It should stop after a finite number of instructions are executed.

		   Input: It should have well-defined input.

		   Output: It should have well-defined output.

		   Effective: It is measured in terms of time and space.

	 c.	� Process symbol: It is used to show a process or action step. This is the most common symbol 
used in flowcharts.

		  Input/Output: It is used to represent the material or information entering or leaving the 
system, i.e., input and output.

6. 	 a.	 (i) Input	 (ii)   Process	 (iii)  Output

	 b.	�Before drawing the flowchart, Richa should first create an algorithm to outline the logical 
steps required to find the smallest of the four given numbers. The algorithm helps break 
down the problem into clear steps and provides a logical flow of operations, making the 
flowchart easier to design.
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Let’s Explore

	 Do it yourself.

Let’s Get Better

	 Do it yourself.

	 Introduction to Programming

Let’s Plug-in  (Page no. 97)

1. T				    2. T			   3. T

Let’s Catch Up  (Page no. 106)

	

Roll no = 201        Student Name = "Chirag"        Section = 'A'

8.
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Test Your Skills

1.	 a.  (ii)			   b.  (i)			   c.  (iv)		  d.  (iv)		  e.  (iv)

2.	 a.   Guido van Rossum	 b.  Assignment		  c.  String	 d.  input()	 e.  false	

3.	 a.  T	 b.  F	 c.  F	 d.  T	 e.  T

4.	 a.	 The value 8 is stored in the memory location named a.

	 b.	� Variables are memory reference points where we store values which can be accessed or 
changed later.

	 c.	 A data type specifies the type of value a variable can contains.

	 d.	� Operator precedence determines the order in which operators are evaluated in an expression, 
with parentheses having the highest precedence, followed by exponentiation, multiplication, 
division, addition, and subtraction, assignment and logical operators (AND, OR) having the 
lowest precedence.

	 e.	 Integrated Development and Learning Environment.

5.	 a.	 Following are the relational operators provided by Python:

	 	 ==	 Equal to

	 	 !=	 Not equal 

	 	 >	 Greater than 

	 	 <	 Less than 

	 	 >=	 Greater than or equal to

	 	 <=	 Less than or equal to

		�  For example, ==  operator: It checks if the values of two operands are equal or not. If yes, 
then the condition becomes true.

	 b.	� Comments in Python can be used to explain parts of the code. It can also be used to hide 
the code as well. Comments enable us to understand the way a program works. In python, 
any statement starting with # symbol is known as a comment.

		�  Single Line Comment: In case, a user wants to specify a single line comment, then comment 
must start with the symbol #.

	 	� Multiple-line Comment: Python does not have a syntax for multiline comments. To add a 
multiple line comment, you could insert a # for each line. However, the text written inside 
triple quotes (''' or ''"") is also considered as comment. You can use the triple quotes to write 
multiline comments.

	 c.	 Modes of Python IDLE are: Interactive Mode and Script Mode. 

	 	 Interactive Mode is a command line shell which gives immediate result for each command.

	 	 The Script Mode saves the commands entered by the user in the form of a program.
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	 d.	 (i)  Arithmetic operators perform arithmetic operations between two operands.

	 		  Example: Addition x+y (x=7 and y=3) Output 10 
	 	 (ii)	 Comments in Python can be used to explain parts of the code. It can also be used to hide 

the code as well.
	 	 (iii)	 A data type specifies the type of value a variable can contains.
	 	 (iv)	 Variables are memory reference points where we store values which can be accessed or 

changed later.
		  (v)	 Logical operators are used to evaluate and decide. It returns the output as TRUE or False. 

Example: AND, OR and NOT

	 e.	 (i)	 AND returns true, if both operands are true.
			   Here x = 2
			   Example: (x < 5) and (x < 10). Output: TRUE.
			   OR returns true, if one of the operands is true.
			   Example: (x < 5) or (x < 2). Output: TRUE.

		  (ii)	 Modulus Operator divides left hand operand by right hand operand and returns remainder.
			   Here x=7  y= 2,
			   Example: x % y. Output: 1
			   Division Operator divides left hand operand by right hand operand.
			   Here x=7  y= 2,

			   Example: x / y. Output: 3.5

		  (iii)	 In case, a user wants to specify a single line comment, then comment must start with the 
symbol #.

	 		  Example:	 Program:		  Output:
	 			   # printing a string		  Hello World
				    print(“Hello world”)
			   The text written inside triple quotes (''' or ''"") is also considered as comment. You can 

use the triple quotes to write multiline comments. 
'''This is 
Multiline 

Comment'''
	 		  Example:	 Program :		  Output :
	 			   # printing a string		  Hello World
	 			   #print five names		  Rachna
	 			   print(“Hello World”)		 Sambhav
	 			   print(“Rachna”)		  Akshat
	 			   print(“Sambhav”)		  Tushar
	 			   print(“Akshat”)
				    print(“Tushar”)
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6.	 a.	� Compiler converts the entire high-level language program into machine language at once. 

		  It displays the errors for the whole program together. 

		�  Interpreter translates and executes one statement at a time. It displays the errors one line 
at a time and it goes to the next line only after the error is corrected. 

	 b.	 '''

		  This program asks for the user's name and class, then prints a welcome message.

		  '''

		  name = input("Enter your name: ")

		  class_name = input("Enter your class: ")

		  print("Hello", name, "welcome to class", class_name + "!")

Tech Zone

Let's Solve

	 1.  2.0	 2.  12	 3.  10 20 30	 4.  6	 5.  4 TRUE

Let’s Explore

	 Do it yourself.

	 Intelligence and AI Approaches

Let’s Plug-in  (Page no. 118)
	 Do it yourself.

Let’s Catch Up  (Page no. 120)
	 Do it yourself.

Let’s Catch Up  (Page no. 122)
	  	 Love singing and playing musical instruments

	  	 Good at thinking in patterns, rhythms and sounds 

	 	Recognise musical patterns and tones easily

	  	 Good understanding of musical rhythm 

9.
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Test Your Skills

1.	 a.  (iv)	 b.  (ii)	 c.  (i)	 d.  (ii)

2.	 a.   Interpersonal	 b. Virtual Assistants	 c. Intelligence	 d. Howard

3.	 a. T	 b. F	 c. T	 d. T

4.	 a.	� Bodily-Kinesthetic Intelligence is being good at dancing and sports along with love creating 
things with their hands, tends to remember by doing, rather than hearing and seeing, and 
excellent hand-eye and physical coordination Flexible in different body movements and 
performing actions.

	 b.	� A rule-based system uses rules as knowledge representation. These rules are coded in the 
system in the form of if-then-else statements which help the computer in taking decisions. The 
idea behind a rule-based system is to use the knowledge of a human expert in a specialised 
domain and embody it within the computer system.

	 c.	� Intelligence refers to the ability to think, to learn from previous experience, to solve complex 
problems and to adapt new things and environment.

5.	 a.	� A computer system that achieves AI through a machine learning technique is called a learning-
based approach. This approach is often referred to as black boxes as it is not entirely clear 
how these systems take decisions. 

		�  Machine learning is a way of achieving AI. It is a branch of AI and is based on the idea that machines 
can be built to process data and learn on their own. Machine learning is a subset of AI.

	 b.	 Verbal-Linguistic Intelligence people possess the following qualities:

		   Good at using words	  Can remember written and spoken information
		   Love reading and writing 	  Good debaters 
		   Explain things well	  Use humour while telling stories

	 c.	 Naturalistic Intelligence people possess the following qualities:
		   Nature lover
		   Love exploring the environment and learning about other species
		   Enjoy camping, gardening, hiking and exploring outdoors

6.	 a.	 Naturalistic Intelligence

	 b.	 Verbal-Linguistic Intelligence
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Tech Zone

Let's Solve

	 1.  a. 64 		  b. 141 		  c.  A plant.

	� This riddle is related to Logical-Mathematical Intelligence. It involves problem-solving and 
pattern recognition to come up with a solution based on reasoning. ​

2.	 Visual-Spatial Intelligence is being used here.

Let’s Explore

	 Do it yourself.

Periodic Assessment–4
(Based on chapters 7 to 9)

A.	 1. Start/Stop	 2. Process	 3. Decision	 4. Input/output

B.	 1.	� Variables are memory reference points where we store values which can be accessed or 
changed later. The names given to the variables are known as identifiers.

	 2.	� Operators can be defined as special symbols which perform arithmetic and logical 
computation.

	 3.	 The input() function takes the user’s input while a program executes.

	 4.	� The print() function prints or sends the output to the standard output device, which is usually 
a monitor. This function auto converts the items to strings.

C.	 1.	 Existential Intelligence people possess the following qualities:

		   Look at things from different point of view.

		   Make connections between what is being learned and the world outside.

		   Have a deep and comprehensive understanding not just of the universe, but of the self.

	 2.	 Naturalistic Intelligence people possess the following qualities:

		   Nature lover

		   Love exploring the environment and learning about other species

		   Enjoy camping, gardening, hiking and exploring outdoors
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D.	 sub1 = int(input(‘Enter marks of the subject 1: ‘))

	 sub2 = int(input(‘Enter marks of the subject 2: ‘))

	 sub3 = int(input(‘Enter marks of the subject 3: ‘))

	 sub4 = int(input(‘Enter marks of the subject 4: ‘))

	 sub5 = int(input(‘Enter marks of the subject 5: ‘))

	 avg = (sub1 + sub2 + sub3 + sub4 + sub5)/5;

	 print(‘Average of marks is :’, avg)

E.	 Naturalistic Intelligence

Test Sheet–2
(Based on chapters 6 to 9)

A.	 1.  (iii)	 2.  (i)	 3.  (i)	 4.  (ii)	 5.  (ii)

	 6.  (i)	 7.  (iv)	 8.  (iv)	 9. (i)

B.	 1.  Firewall	 2.  Trojan horse	 3.  Empty	 4.  Nesting

	 5.  Connectors	 6.  Logical	 7.  false

C.	 1.  F	 2.  T	 3.  T	 4.  F	 5.  T

	 6.  T	 7.  T	 8. T

D.	 1.	� A computer virus is a ‘piece of code’ or program developed to corrupt the data or program 
files stored on the computer system.

	 2.	 The first widespread computer virus was BRAIN, created in 1986 in Pakistan.

	 3.	� HTML stands for Hypertext Markup Language. It is a markup language that describes the 
structure of the web page.

	 4.	 The tags that include both opening and closing tags are called Container Tags.

	 5.	� (Start/Stop), Process, Decision, Input/Output, Flow Line (Arrow, Connector), Connector 
(Inspection)

	 6.	� An algorithm is commonly used for performing data processing, computer and mathematical 
operations, manipulating data, and searching for a particular data.

	 7.	 A data type specifies the type of value a variable can contains.

	 8.	 Precedence of operators determines the order in which the operators are executed.

E.	 1.	A malware is a type of malicious program designed to damage or carryout other unwanted 
actions on a computer system. In Spanish, 'mal' is a prefix that means 'bad,' making the term 
'badware,' which is a good way to remember it.
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	 2.	HTML editors are software which are used to write and edit HTML codes. There are mainly 
two types of HTML editors, WYSIWYG editor and Text Editor. The most commonly used HTML 
editors are Notepad and Notepad++. 

	 3.	This tag is commonly used to add heading to the content of the webpage. There are six levels 
of headings <H1>, <H2>, <H3>, <H4>, <H5>, <H6>. 

	 4.	You must follow these basic rules while drawing a flowchart:
		   The flowchart should be clear, neat and easy to follow.
		   Maintain the direction of the flow from left to right or top to bottom.
		   Only one flow line should come out from a process symbol. 
		   �Ensure that only one flow line should enter a decision symbol, but two flow lines should 

leave the decision box.
		   Ensure that the flowchart has a logical start and end.
	 5.	The main characteristics of a good algorithm are:
		   �Precision: Each step is precisely defined.
		   �Uniqueness: Result of each step should be uniquely identified and only depend on the 

result of the preceding step.
		   �Finiteness: It should stop after a finite number of instructions are executed.
		   �Input: It should have well-defined input.
		   �Output: It should have well-defined output.
		   �Effective: It is measured in terms of time and space.
	 6.	Following are the relational operators provided by Python:
		  ==	 Equal to
		  !=	 Not equal
		  >	 Greater than 
		  <	 Less than 
		  >=	 Greater than or equal to
		  <=	 Less than or equal to
		�  For example, == operator: It checks if the values of two operands are equal or not. If yes, 

then the condition becomes true.
	 7.	� Comments in Python can be used to explain parts of the code. It can also be used to hide 

the code as well. Comments enable us to understand the way a program works. In python, 
any statement starting with # symbol is known as a comment.

	 	� Single Line Comment: In case, a user wants to specify a single line comment, then comment 
must start with the symbol #.

		  Multiple-line Comment: Python does not have a syntax for multiline comments. To add a 
multiple line comment, you could insert a # for each line.

		  However, the text written inside triple quotes (''' or ''"") is also considered as comment. You 
can use the triple quotes to write multiline comments.


