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1PRIME (Ver. 2.2)-VI (Answer Key)

	Advanced Windows

Rapid Fire

1.	 a.	 (i)	 b.	 (ii)	 c.	 (i)	 d.	 (i)

2.	 a.	 T	 b.	 T	 c.	 F	 d.	 T

Evaluation Time

1.	 a.	 Communications		  b.	 Programs

	 c.	 Control Panel			   d.	 Disk Cleanup 

2.	 a.	 Buttons, Pointers

	 b.	 The Disk Cleanup tool is used to search and delete files on the hard disk, that can be deleted 
from your computer without affecting the computer’s functions or your personal files.

3.	 a.	 To open Control Panel window, follow these steps: 

	 	 Step 1:	 Click on the Start button. The Start menu appears. 

	 	 Step 2:	� Click on the Windows System → Control Panel option from the Start menu. The 
Control Panel window opens.

	 b.	 It deletes files like:

	 	 •  Temporary Internet files

	 	 •  Recycle Bin if it is not empty 

	 	 •  Windows temporary files

4.	 a.	 Ashish can open the Mouse Properties dialog box from the Control Panel, go to the Buttons 
tab, and select the option to switch primary and secondary buttons to suit left-handed use.

	 b.	 Naveen can use the Disk Cleanup tool from Start menu → Windows Administrative Tools 
to quickly remove junk and unnecessary files from the hard disk.

1.
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Activity Time
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Find Out

Do it yourself.

In The Lab

Do it yourself.

	Advanced Features of PowerPoint 2016

Warm
Up! 	 1. a	 2. a

Rapid Fire

1.	 a.	 (iii)	 b.	 (i)	 c.	 (ii)	 d.	 (ii)	 e.	 (i) 
2.	 a.	 F	 b.	 T	 c.	 F	 d.	 F

Evaluation Time

1.	 a.	 Audio on My PC			  b.	 Record
	 c.	 Media, Insert			   d.	 Action

2.



3PRIME (Ver. 2.2)-VI (Answer Key)

2.	 a.	 Choosing Print All Slides option will print all the slides in the presentation.
	 b.	 Action buttons are some built-in shapes which you can add to your slides. This action happens 

when you either click an object or hover your mouse over in a slideshow. 
	 c.	 Two ways to insert an audio file in a PowerPoint presentation:
	 	 1.	 Insert → Audio → Audio on My PC – to insert an existing audio file from your computer.
	 	 2.	 Insert → Audio → Record Audio – to record your voice and insert it directly into the slide.
3.	 a.	 To insert a video file, follow the steps given below:
	 	 Step 1:	 Click on Video command under the Media group of the Insert tab.
	 	 Step 2:	 Click on the Online Video option. 
	 	 Step 3:	 Search your video on the website. 
	 	 Step 4:	 Click on the Insert button.
	 b.	 The printing options are:
	 	 •  Print All Slides: Choosing this option will print all the slides in the presentation. 
	 	 •  Print Selection: This option will print only the selected slides from the presentation. 
	 	 •  Print Current Slide: This option prints only the currently open slide.
4.	 a.	 To create a PowerPoint presentation with recorded audio, follow these steps:
	 	 Step 1:	 Go to the Insert tab.
	 	 Step 2:	 Click on Audio → choose Record Audio.
	 	 Step 3:	 Give your recording a name, then click the Record button (red circle).
	 	 Step 4:	 Click Stop when done, then click OK to insert it into the slide.
	 b.	 To add a video to the presentation, follow these steps:
	 	 Step 1:	 Go to the Insert tab.
	 	 Step 2:	 Click on Video → choose either Video on My PC or Online Video.
	 	 Step 3:	 Select the video file or paste the video link.
	 	 Step 4:	 Click Insert to add the video to your slide.

Activity Time

	 a.	 Record Audio			   b.	 Online Video			   c.	 Print Selection 
	 d.	 Full Page Slides 			  e.	 Action Buttons

Find Out

Do it yourself.

In The Lab

Do it yourself.



4 PRIME (Ver. 2.2)-VI (Answer Key)

(Based on chapters 1 & 2)
Periodic Assessment 1

A.	 1.	 Control Panel			   2.	 Mouse option

	 3.	 Buttons tab			   4.	 Playback

	 5.	 Disk Cleanup

B.	 1.	 We can insert a video from YouTube in our PowerPoint presentation.

	 2.	 We can delete an audio or video from the PowerPoint presentation after inserting it.

	 3.	 We can create customized action buttons. 

	 4.	 The recorded sound can be inserted in the PowerPoint presentation using the Insert > Audio 
option.

C.	 1.	 (ii)	 2.	 (iv)	 3.	 (i)	 4.	 (iii)

	More on Excel

Warm
Up! 	 1. T	 2. T	 3. F

Rapid Fire

1.	 a.	 (iv)	 b.	 (iii)	 c.	 (i)	 d.	 (i)	 e.	 (i)

2.	 a.	 F	 b.	 T	 c.	 F	 d.	 T	 e.	 F

Evaluation Time

1.	 a.	 Insert			   b.	 Cell Styles			   c.	 Select All

	 d.	 Merge & Center			  e.	 Operators

2.	 a.	 Yes, we can unmerge the merged cells. Name of command is Unmerged Cells.

	 b.	 Copy command is used to copy the data at the new place and also exists in its original place.

	 c.	 Wrap Text feature of Excel allows us to display multiple lines of text inside a cell.

3.	 a.	 Steps to wrap the text in a cell are:

	 	 Step 1:	 Click the cell in which you want to wrap the text.

	 	 Step 2:	� Click on Wrap Text command from Alignment group under Home tab. The text in 
your cell will be wrapped.

3.



5PRIME (Ver. 2.2)-VI (Answer Key)

	 b.	 To change row height and column width follow these steps:

	 	 Step 1:	 Select the column(s) or row(s) that you want to change.

	 	 Step 2:	 Click on Format command in Cells group from Home tab.

	 	 Step 3:	 Choose Column Width or Row Heights option.

	 	 Step 4:	� In the Column Width or Row Height box, type the value that you want your column 
or row to be.

	 c.	 To apply cell border follow these steps: 

	 	 Step 1:	� On a worksheet, select the cell or range of cells that you want to add a border to, 
change the border style on, or remove a border from. 

	 	 Step 2:	 Go to the Font group in the Home tab. 

	 	 Step 3:	 Click the arrow next to Borders command. 

	 	 Step 4:	 Click on the border style you would like.

Activity Time

1.	 a.	 �By using the Wrap Text command present on the Alignment group in the Home tab, Sonia 
can make the text visible.

	 b.	 By inserting a column, Anaya can create space to enter the marks.
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6 PRIME (Ver. 2.2)-VI (Answer Key)

	Formulas & Functions in Excel

Warm
Up! 	 1. 5	 2. Comp	 3. 7

			   4. 4/5/2025	 5. 5	 6. 3

Rapid Fire

1.	 a.	 (i)	 b.	 (i)	 c.	 (ii)	 d.	 (iii)

2.	 a.	 F	 b.	 F	 c.	 F	 d.	 T	 e.	 T

Evaluation Time

1.	 a.	 Functions			   b.	 equal

	 c.	 square root			   d.	 Dollar ($)

	 e.	 ABS()

2.	 a.	 A cell reference is a cell address that can be used in a formula to denote a specific cell.

	 b.	 Text Functions is used to perform number of operations on strings (i.e. a collection of 
characters like ‘hello’, ‘friend’, ‘computer’, etc.) such as finding the length of a string, joining 
two strings, searching for one string inside another etc.

	 c.		 Output: 4/5/2025

3.	 a.	 LEN function is used to return the length of the text string. For example: Input: =LEN(“Touch”)
Output: 5.

	 b.	 Rules to enter a function are:

	 	 1.	 All Excel functions must begin with = sign.

	 	 2.	 Function name must be a valid Excel name.

	 	 3.	 Function must be followed by opening and closing parenthesis.

	 	 4.	 Most of the functions must contain an argument within it.

	 c.	 concatenate() function joins together two or more different text strings.

	 	 Input: =CONCATENATE(“Touch”, “pad”) Output: Touchpad

4.	 a.	 Ridhi could use IF() AND AVERAGE() functions to do the task.

	 b.	 Nidhi can use NOW() function.

4.
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Activity Time
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Find Out

Do it yourself.

In The Lab

Do it yourself.

	Introduction to Animate CC

Warm
Up! 	 1. Stroke		  2. Fill

Rapid Fire

1.	 a.	 (i)	 b.	 (iv)	 c.	 (ii)

2.	 a.	 T	 b.	 F	 c.	 T	 d.	 T

5.



8 PRIME (Ver. 2.2)-VI (Answer Key)

Evaluation Time

1.	 a.	 Animation	 b.	 HTML5	 c.	 Stage	 d.	 Lasso	 e.	 Lines
2.	 a.	 Properties Panel displays the different properties of the object which is selected. 
	 b.	 Gradient Fill is a combination of colours where one colour changes into another. 
	 c.	 There are three types of symbol in Animate CC: Movie Clip Symbol, Button Clip Symbol and 

Graphic Symbol. 
3.	 a.	 (i)	 Selection tool is used to select objects on the stage for modification. 
	 	 (ii)	� Pen tool is used to draw lines and curves by creating a series of dots that are automatically 

connected. 
	 	 (iii)	 Free-transform tool is used to move, scale, rotate, skew, or distort objects. 
	 b.	 To create a symbol, perform the following steps: 
	 	 Step 1:	� Click on the File → Open option from the menu bar. Select the desired file and 

click on the Open button. 
	 	 Step 2:	 Select the Rectangle Tool from the Tools panel. 
	 	 Step 3:	� Use the Stroke Color and Fill Color in the Properties panel to select the required 

outline and fill color from the color picker for the object. 
	 	 Step 4:	 Click on the drawing mode in the Tools panel to select the Object Drawing mode. 
	 	 Step 5:	 On the stage, draw a rectangle, holding down the left mouse button. 
	 	 Step 6:	 Click on the Selection Tool in Tools panel.
4.	 a.	 She can place those objects on a Hidden Layer.
	 b.	 She can view the features of the selected tool in the Properties Panel.

Activity Time
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Find Out

Do it yourself.

In The Lab

Do it yourself.

(Based on chapters 3 to 5)
Periodic Assessment 2

A.	 1.	 Click on the first cell to be selected then hold the Control Key and continue selection of the 
unrelated cells while holding on the Control key.

	 2.	 A cell reference is a cell address that can be used in a formula to denote a specific cell. 

	 3.	 Auto Fill is a feature that automatically fills data in cells based on a pattern.

B.	 1.	 ROUND()	 2.	 CONCATENATE()	 3.	 IF()	 4.	 COUNT()

C.	 1.	 Brush Tool			   2.	 Free Transform Tool

	 3.	 Paint Bucket Tool		 4.	 Zoom Tool

	 5.	 Text Tool			   6.	 Rectangle Tool

(Based on chapters 1 to 5)

Test Sheet  1

A.	 1.	 (i)	 2.	 (ii)	 3.	 (i)	 4.	 (i)	 5.	 (i)

	 6.	 (i)	 7.	 (i)

B.	 1.	 Modern			   2.	 Control Panel			   3.	 Media group

	 4.	 Audio from File			   5.	 Merge & Center		  6.	 Stage

	 7.	 Lasso

C.	 a.	 (iv)	 b.	 (iii)	 c.	 (i)	 d.	 (v)	 e.	 (ii)

D.	 1.	 T	 2.	 F	 3.	 T	 4.	 T	 5.	 T

E.	 1.	 The Disk Cleanup tool is used to search and delete files on the hard disk, that can be deleted 
from your computer without affecting the computer’s functions or your personal files. 

	 2.	 Action buttons are some built- in shapes which you can add to your slides. This action 
happens when you either click an object or hover your mouse over in a slideshow. 
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	 3.	 Yes, we can unmerge the merged cells. Name of command is Unmerged Cells. 

	 4.	 Wrap Text feature of Excel allows us to display multiple lines of text inside a cell. 

	 5.	 Gradient Fill is a combination of colours where one colour changes into another. 

	 6.	 There are three types of symbol in Animate CC: Movie Clip Symbol, Button Clip Symbol and 
Graphic Symbol. 

F.	 1.	 It deletes files like: 

	 	 •  Temporary internet files

	 	 •  Recycle Bin if it is not empty 

	 	 •  Windows temporary files 

	 2.	 To insert a video file, follow the steps given below: 

	 	 Step 1:	 Click on Video command under the Media group of the Insert tab. 

	 	 Step 2:	 Click on the Online Video option. 

	 	 Step 3:	 Search your video on the website. 

	 	 Step 4:	 Click on the Insert button. 

	 3.	 Steps to rename worksheet tab are: 

	 	 Step 1:	 Right-click the sheet tab that you want to customise. 

	 	 Step 2:	 Click on Rename. 

	 	 Step 3:	 Type the name. 

	 4.	 Steps to wrap the text in a cell are: 

	 	 Step 1:	 Click the cell in which you want to wrap the text. 

	 	 Step 2:	� Click on Wrap Text command from Alignment group under Home tab. The text in 
your cell will be wrapped. 

	 5.		  (i)	 Selection tool is used to select objects on the stage for modification. 

	 		 (ii)	� Pen tool is used to draw lines and curves by creating a series of dots that are automatically 
connected. 

	 		 (iii)	 Free-transform tool is used to move, scale, rotate, skew, or distort objects. 

	HTML—An Introduction

Rapid Fire

1.	 a.	 (i)	 b.	 (ii)	 c.	 (iii)	 d.	 (ii)	 e.	 (iv)

2.	 a.	 F	 b.	 F	 c.	 T	 d.	 F	 e.	 T

6.
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Evaluation Time

1.	 a.	 Markup	 b.	 Empty	 c.	 Body	 d.	 Inline	 e.	 Background-image

2.	 a.	 The latest version of HTML is HTML5.

	 b.	 The selector signify to an HTML tag to which a style will be applied.   For example, selector 
{Property1: value1...};.

	 c.	 A combination of opening tag, content, and a closing tag is called an HTML element.

	 d.	 Attribute is a property that provides some additional information about a tag.

3.	 a.	 HTML stands for Hypertext Markup Language. It is a markup language that describes the 
structure of a web page.

	 b.	 The code to include the reference of the mystyle.css file  in an HTML web page is:

		  <head> 

		      <link rel=”stylesheet” type=”text/css” href=”style.css”>

		  </head> 

	 c.	 An internal style sheet is commonly used when one web page has a unique style.

4.	 a.	 The ALIGN attribute and CENTER tag are used for text alignment. ALIGN is more flexible, 
allowing left, right, centre, and justify options, while CENTER only centres everything inside 
it to the center.

	 b.	 Follow these steps to edit an HTML document: 

	 	 Step 1:	 Right-click on the HTML file. 

	 	 Step 2:	 Click on the Open with option. 

	 	 Step 3:	 Click on the Notepad option.

	 	 This will open your HTML document in Notepad so that you can make changes to the file.

Activity Time
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In The Lab

Do it yourself.

	Internet

Warm
Up! 	 1.  Advanced Research Project Agency Network

	 		  2.  World Wide Web	 3.  Uniform Resource Locator

Rapid Fire

1.	 a.	 (i)	 b.	 (iii)	 c.	 (iv)	 d.	 (D)	 e.	 (d)

2.	 a.	 F	 b.	 F	 c.	 F	 d.	 T

Evaluation Time

1.	 a.	 E-mail			   b.	 ARPANET

	 c.	 Web document			   d.	 Website

2.	 a.	 The Internet is a computer network that connects hosts and end systems throughout the 
world. 

	 b.	 Online Education has enhanced the teaching and learning process by making education 
very friendly and interesting. Education on the Internet is also called e-learning. 

	 c.	 E-mail stands for electronic mail. You can send messages and files from your computer to 
your friend’s computer and vice-versa using e-mail service. 

3.	 a.	 The World Wide Web (www) is a large information system where you can surf and get 
information. Web is a service (a system for accessing information) that is supported by the 
Internet, a system of interconnected networks. 

	 	 While the Internet is a computer network that connects hosts and end systems throughout 
the world.

	 b.	 An e-greeting is just like a paper greeting card. The only difference is that it is created 
with the help of digital text and effects. Some of the popular e-greetings websites are 
www.123greetings.com, www.egreetings.com, www.e-cards.com, etc.

4.	 a.	 Sumit can use an e-greeting card to greet his friend.

	 b.	 Shushant can use email to send the message to the entire class.

7.
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Activity Time

1.	 a.	 E-greeting			   b.	 E-mail
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Find Out

Do it yourself.

In The Lab

Do it yourself.

(Based on chapters 6 & 7)
Periodic Assessment 3

A.	 1.	 <header>	 2.	 <p>	 3.	 <div>	 4.	 <sub>

B.	 1.	 text-indent					     2.	 text-decoration

	 3.	 background-repeat			   4.	 font-weigth

C.	 1.	 Advanced Research Projects Agency Network.

	 2.	 Transmission Control Protocol/Internet Protocol.

	 3.	 HyperText Transfer Protocol.

	 4.	 National Center for Supercomputing Applications.

	 5.	 Uniform Resource Locator.
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	Problem Solving and Programming Languages

Warm
Up! 	 1.  SQL	 2.  Perl	 3.  Python

Rapid Fire

1.	 a.	 (iii)	 b.	 (ii)	 c.	 (ii)	 d.	 (ii)	 e.	 (i)	 f.	 (iii)

2.	 a.	 F	 b.	 T	 c.	 F	 d.	 T	 e.	 T

Evaluation Time

1.	 a.	 Natural			   b.	 Connectors			   c.	 Finiteness

	 d.	 Instructions			   e.	 Programming

2.	 a.		 An Algorithm is a set of steps in a sequential and ordered manner to solve any problem.

	 b.	 People who write the programs are called programmers. 

	 c.	 An assembler is a program used to translate assembly language into machine language.

	 d.	 BASIC and PASCAL

	 e.	 A computer language is the medium by which instructions are transmitted to the computer 
to perform a specific task.

3.	 a.	 The main difference between HLL and LLL is that the LLL is machine dependent and HLL is 
machine independent.

	 b.	 The advantages of High-level languages are:

	 	 •  High level language is user friendly.

	 	 • � High level language is similar to English with vocabulary of words and symbols, therefore 
it is easier to run.

	 	 •  High level language requires less time to write.

	 	 •  High level language is easier to maintain.

	 c.	 Process symbol: It is used to show a process or action step. This is the most common symbol 
used in flowcharts.

	 	 Input/Output: It is used to represent the material or information entering or leaving the 
system, i.e., input and output.

	 d.	 A compiler is a software that converts the entire source program into machine language 
before executing it. It converts the entire high-level language program into machine language 
at once. It displays the errors for the whole program together. 

8.
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	 	 An interpreter is also a software that converts the entire source program into machine 
language before executing it. It translates and executes one statement at a time. It displays 
the errors one line at a time and it goes to the next line only after the error is corrected.

4.	 a.	 (i)	 Input/Output		  (ii)	 Process			   (iii)	 Input/Output 

	 b.	 Richa should make an algorithm before drawing a flowchart 

	 c.	 Jiya should use a fourth Generation Language to develop the program quickly.

Activity Time
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	Introduction to Python

Warm
Up! 	 Roll no = 201        Student Name = “Chirag”        Section = ‘A’

Warm
Up! 	 1. F	 2. F	 3. T

Rapid Fire

1.	 a.	 (i)	 b.	 (iii)	 c.	 (i)	 d.	 (iv)	 e.	 (iv)

2.	 a.	 T	 b.	 T	 c.	 F	 d.	 F

Evaluation Time

1.	 a.	 Guido Van Rossum, 1991	 b.	 interactive, script		  c.	 variable

	 d.	 string			   e.	 letter, underscore

2.	 a.	 The type() function in Python is used to determine the data type of a given value. 

	 b.	 A list is a collection of data elements separated by comma(,) and enclosed within square 
brackets. 

	 c.	 Two separator that can be used with the print() function are: \t and \n. 

3.	 a.	 In interactive mode, each line of code is executed, and the output is displayed on the next 
line. Interactive mode provides output line by line, making it ideal for testing code for errors.

	 	 In contrast, in script mode, Python does not automatically process and display the results. 
Script mode is used to write longer Python codes and allows you to save the programs for 
later use.

	 b.	 you can change a string to a float like this: number_float = float(“3.14”)

	 c.	 The input() function allows users to enter a value during program execution, which can then 
be stored in a variable.

4.	 a.	 Eklavya should use an integer for age and strings for name and favourite colour. He can use 
integer for age and string for name and favourite_colour.

	 b.	 Simran should use a list data structure in Python to store her shopping items. A list will help 
her keep adding items using Python.

9.
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Activity Time

1.	 a.	 Hello, World!
	 b.	 15
2.	 a.	 a = “Hello”
	 	 print(a)
	 b.	 a = “Hello!”
	 	 b = “Friends”
	 	 print(a,b)

In The Lab

Do it yourself.

	Intelligence and AI Approaches

Warm
Up! 	 Do it yourself.

Warm
Up! 	 1. b	 2. b	 3. b

Rapid Fire

1.	 a.	 (i)	 b.	 (ii)	 c.	 (iv)	 d.	 (ii)

2.	 a.	 T	 b.	 T	 c.	 F	 d.	 T

Evaluation Time

1.	 a.	 Artificial Intelligence	 b.	 Linguistic	 c.	 Rule-based	 d.	 Machine Learning

2.	 a.	 Intelligence refers to the ability to think, to learn from previous experience, to solve complex 
problems, and to adapt to new things and environment. 

	 b.	 The qualities of a person having musical intelligence are:

	 	 •  Love singing and playing musical instruments 

	 	 •  Good at thinking in patterns, rhythms and sounds 

10.
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	 	 •  Recognise musical patterns and tones easily

	 	 •  Good understanding of musical rhythm

3.	 a.	 The AI approach used in this expert system is the Rule-based Approach.

	 b.	 A learning-based AI approach refers to a computer system that utilises machine learning 
techniques to achieve artificial intelligence. This approach is characterized by its ability to learn 
and make decisions, although the exact decision-making process may not be transparent 
or easily interpretable, often likened to a “black box”.

4.	 a.	 Rashi possesses Spatial Intelligence

	 b.	 Ram is using Logical-Mathematical Intelligence.

Activity Time

	 a.	 Logical-Mathematical Intelligence		 b.	 Naturalistic Intelligence

	 c.	 Spatial Intelligence			   d.	 Linguistic Intelligence

	 e.	 Interpersonal Intelligence

(Based on chapters 8 to 10)
Periodic Assessment 4

A.	

Stop

Start

Yes No

Read n

Print "Number 
is Even."

Print "Number 
is Odd."

Is
n % 2==0
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B.	 •	 Python allows semicolons, but mainly when you want to write multiple statements on a 
single line:

	 	 a = b = c = 20;
	 •	 Missing closing quotes
	 	 print(“lets print other values)
C.	 1.	 Ruled-based approach			   2.	 Learning-based approach
	 3.	 Learning-based approach			   4.	 Learning-based approach

(Based on chapters 6 to 10)

Test Sheet  2

A.	 1.	 (iii)	 2.	 (ii)	 3.	 (iii)	 4.	 (i)	 5.	 (iv)
	 6.	 (i)	 7.	 (i)
B.	 1.	 algorithm	 2.	 assembler	 3.	 Web document			  4.	 E-mail
	 5.	 interactive, script		  6.	 Rule-based
C.	 1.	 F	 2.	 F	 3.	 F	 4.	 T	 5.	 F
D.	 1.	 An Algorithm is a set of steps in a sequential and ordered manner to solve any problem. 
	 2.	 A Flowchart is a graphical representation of the sequence of operations in an information 

system or program. 
	 3.	 The Internet is a computer network that connects hosts and end systems throughout the 

world. 
	 4.	 Online Education has enhanced the teaching and learning process by making education 

very friendly and interesting. Education on the Internet is also called e-learning. 
	 5.	 Two separators that can be used with the print() function are: \t and \n. 
	 6.	 The qualities of a person having musical intelligence are:
	 	 •  Love singing and playing musical instruments. 
	 	 •  Good at thinking in patterns, rhythms and sounds.
	 	 •  Recognise musical patterns and tones easily. 
	 	 •  Good understanding of musical rhythm. 
E.	 1.	 The main difference between HLL and LLL is that the LLL is machine dependent and HLL is 

machine independent. 
	 2.	 The advantages of High-level languages  are: 
	 	 •  High level language is user friendly. 
	 	 • � High level language is similar to English with vocabulary of words and symbols, therefore 

it is easier to run. 
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	 	 •  High level language requires less time to write. 

	 	 •  High level language is easier to maintain. 

	 3.	 An e-greeting is just like a paper greeting card. The only difference is that it is created 
with the help of digital text and effects. Some of the popular e-greetings websites are 
www.123greetings.com, www.egreetings.com, www.e-cards.com, etc.  

	 4.	 In interactive mode, each line of code is executed, and the output is displayed on the next 
line. Interactive mode provides output line by line, making it ideal for testing code for errors.

	 	 In contrast, in script mode, Python does not automatically process and display the results. 
Script mode is used to write longer Python codes and allows you to save the programs for 
later use.

	 5.	 A learning-based AI approach refers to a computer system that utilizes machine learning 
techniques to achieve artificial intelligence. This approach is characterized by its ability to learn 
and make decisions, although the exact decision-making process may not be transparent 
or easily interpretable, often likened to a “black box”.


