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	Safeguarding your Computer

  (Page no. 7)

2

byte Quest  (Page no. 16)

1. (d)		 2. (b)	 3. (a)	 4. (c)

TeCh Ready

A.	 1. (iii)	 2. (i)	 3. (ii)	 4. (iii)	 5. (ii)	 6. (i)	

B.	 1. Malware	 2. Biometric	 3. Disk Cleanup 	 4. Retina biometrics 
	 5. Password

C.	 1. F	 2. F	 3. T	 4. T	 5. T

D.	 1.	� Authentication is the process of verifying a user’s identity before granting him or her 
access to a computer system. In private and public computer networks (including the 
Internet), authentication is commonly done through the use of login passwords. Some of 
the authentication procedures as follows: 

		  i.	 Password Protection 
		  ii.	 Biometric Authentication 
		  iii.	 Voice Recognition 

	 2.	� A computer virus is a program that is able to copy itself when it is run. It gets activated 
each time the program or file to which it is attached is opened or executed. It is the most 
common type of malware. It can spread itself by infecting other programs or files. 

	 3.	� a.	� Trojan Horse: A trojan horse is a dangerous virus. It represents itself as helpful software 
program. Once the user clicks on it to agree to run it, it gains access to sensitive data 
and then modifies, blocks, or deletes the data. 

1.
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		  b.	� Adware: An adware tracks user’s browser and download history and keeps popping 
advertisements on the screen.

	 4.	� An infected computer system will: 
		  i.	 start displaying unusual messages on the screen 
		  ii.	 take more time to load the programs 

	 5.	� Ways to protect our computer: 
		  i.	 Download only legal software 
		  ii.	 Use the original version of Windows 
		  iii.	� Scan Pen drive, CD and any other external storage device for viruses before opening 

in computer 

	 6.	 Different malwares will affect your computer in different ways: 
		  i.	 They can crash your hard disk. 
		  ii.	 They can destroy all or some of your data. 
		  iii.	 They decrease the processing speed of the computer. 
		  iv.	 They can reduce or block the memory of the computer or hard disk. 

A.	 1. AVG 	 2. Norton 	 3. McAfee 

B.

Some tips to 
safeguard from  

Hacking

Don’t 

plug in to devices you 
are not sure about. 

Always download trusted

 Apps from Internet and 
check permissions and 

authentication. 

1. He should scan the pen drive before using it, to protect his computer.

2. I’ll suggest him to neither open these emails nor reply to them.
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	Formulas and Functions in Excel

  (Page no. 21)

Total marks obtained = 95 + 85 + 90 = 270
Maximum marks can be obtained = 100 + 100 + 100 = 300
Average marks = 270/3 = 90
Percentage = (270/300) x 100 = 90%

byte Quest  (Page no. 28)

1. -500	 2. 1250	 3. 2400	 4. 2

byte Quest  (Page no. 34)

1. 5	 2. Comp	 3. 7	 4. 5	 5. 3

TeCh Ready

A.	 1. (i)	 2. (i)	 3. (ii)	 4. (iii)

B.	 1. Functions	 2. Equal to 	 3. square root	 4. Dollar ($)

C.	 1. F	 2. F	 3. F	

D.	 1.   �A cell reference is a cell address that can be used in a formula to denote a specific cell.

	 2.	� It returns the length of the text string. Example:
		  Input: =LEN(“Touch“)
		  Output: 5

	 3.	� Rules for using functions are:

		  (i) All Excel functions must begin with = sign

		  (ii) Function name must be a valid name.

		  (iii) Function must be followed by opening and closing parenthesis.

2.



Digicode AI-VI (Answer Key)4

IMPRINT 1

1 2
C T 4

3 O P E R A T O R S
L D U

 L A M
U P P E R Y

E
F
E
R 6
E F
N U

7 C O N S T A N T
8 L O W E R C

T
I

9 P R O D U C T
N

5

1.	 =SUM(range)

2.	 (This question was printed incorrectly in the book. Please correct it in your textbook.)

	� Question: Your friend Alisha was using Excel and wants to add the current date and time in it. 
She doesn’t know how to do this. Tell her the appropriate function she can use to do so.

	 Ans. =NOW()

	Charts in Excel
  (Page no. 38)

1. Deepak	 2. Anurag

byte Quest  (Page no. 43)

1. Column Chart	 2. Pie Chart 	 3. Area Chart 	 4. Line Chart 

3.
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TeCh Ready

A.	 1. (ii)	 2. (i)	 3. (iii)

B.	 1. column	 2. Scatter charts 	 3. Plot area

C.	 1. F	 2. F	 3. F	 4. T

D.	 1. (b)	 2. (c)	 3. (d)	 4. (a)

E.	 1.	� a. �Data series is related to the set of values. It is represented by the bars or slices that 
represent the data values.

		  b. �Legend is a key which shows the meanings of symbols and colours used in the chart.

	 2.	� Excel can arrange the selected data in either ascending or descending order. This is called 
sorting of data. 

		�  Custom Sorting is used when more than one column is to be sorted in such a way that the 
first column is in ascending order and if some data is the same for more than one row, 
then the second column of such rows gets sorted in descending order.

	 3.	 To create a chart, follow the given steps: 

		  Step 1: Select the range of cells. 

		  Step 2: Click on the Insert tab. 

		  Step 3: Click on the Insert Column or Bar Chart command. 

		  Step 4: Select the 2-D Column Chart option.

A.	 Do it yourself.

B.	 1. Bar Chart		  2. Sorting		  3. Ascending Order

1. Sorting data

2. Sort A to Z 

Periodic Assessment 1
(Based on chapters 1 to 3)

A.	 1. Code Red Worm 	 2. Zeus 	 3. Emotet 	 4. Pegasus 
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B.	

1  Select 
the data to 
be sorted.

3  Click on the Sort & Filter command.2  Click on Home tab.

4  Select Sort A to Z (for text) or Sort Smallest to 
Largest (for numbers) to sort the data in ascending order.

C.	 1. �It is used to show trends over a period of time. It is similar to plotting a graph on graph 
paper with its values on the X and Y axes.

	 2. �The bar chart displays the data in the form of long rectangular rods, also called bars. These 
bars can be placed horizontally on the chart area.

	 3. �It is used to display the quantitative magnitude of the data graphically. These charts are 
based on the features of the line chart.

	 4. �Scatter charts are also known as XY scatter plot charts. They show the correlation between 
the two sets of values.

	 5. �It is a circular chart divided into sectors where each sector shows the relative size of each 
value. It always shows only one data series.

	Advanced Features of PowerPoint 2016

  (Page no. 49)

1. From Beginning	 2. Present Online	 3. Shapes 	 4. WordArt

code Quest   (Page no. 54)

1. Normal View	 2. Slide Sorter View	 3. Notes Page View	 4. Reading View

4.
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code Quest   (Page no. 60)

	 1. AIFF Audio (.aiff), AU Audio (.au) 

	 2. (This question was printed incorrectly in the book. Please correct it in your textbook.) 

	 Question: Find the odd one out. 

	 i. .mpeg 	 ii. .swf 	 iii. .asf 	 iv. .mp3 

	 Ans.  iii. .mp3

TeCh Ready

A.	 1. (ii)	 2. (iv)	 3. (iii)	 4. (iii)	 5. (ii)

B.	 1. Insert 	 2. Slide 	 3. Text	 4. object 

C.	 1. F	 2. F	 3. F	 4. T	 5. T

D.	 1. Slide Show view allows to view the presentation in full screen mode.

	 2. �Slide transition determines how presentation moves from one slide to next whereas Animation 
is the addition of special visual/sound effects to the text and graphics in a slide.

	 3. �To insert an audio file, follow the given steps: 

	 Step 1: Click on the Insert tab. 

	 Step 2: Click on the Audio command. 

	 Step 3: Choose the desired option. 

	 Step 4: Select the file. 

	 Step 5: Click on the Insert button. 

	 Step 6: Click on Play/Pause button to play or pause the audio.

	 4. An action button can be used to move from one slide to another and play media files.

	 5. Four views in PowerPoint are: 
	 a. Normal View
	 b. Slide Sorter View 
	 c. Notes Page View 
	 d. Reading View
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1. He can add Action buttons to do so.

2. She can apply Animation to do so.

	Algorithmic Intelligence

  (Page no. 66)

1 12 5 18 20 27 13 1 10 15 18 27 3 25 3 12 15 14 5

A L E R T M A J O R C Y C L O N E

code Quest   (Page no. 68)

3. web browser
4. www.google
5. who developed first code? 
6. Enter key

5.
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code Quest   (Page no. 71)

	 Step 1: Start

	 Step 2: Take triangle’s height and base

	 Step 3: Calculate, area of triangle = 1/2(Base x Height)

	 Step 4: Print area of triangle

	 Step 5: Stop

TeCh Ready
A.	 1. (iii)	 2. (ii)	 3. (iv)

B.	 1. F	 2. T	 3. T	 4. T	 5. F

C.	 1.	� An algorithm is a set of steps in a sequential manner to solve a problem or to complete a task.

	 2.	� A Mind Map is a also a problem-solving technique that allows us to organise ideas, thoughts 
or concepts and their relationship in a graphical manner.

	 3.	� Two symbols used in flowchart are:
	 a. �Oval- It is used to show the start and stop points of the flowchart. It usually contains 

the words ‘Start’ or ‘Stop’.
	 b. �Rectangle- It shows a process or action step.

	 4.	 Step 1: Start

		  Step 2: Select the paragraph that you want to copy in Word.

		  Step 3: Click on the Copy command from the Home tab.

		  Step 4: Click the mouse where you want to paste the selected paragraph.

		  Step 5: Click on the Paste command from the Home tab.

		  Step 6: End

Yes

No

Stop

Start

Read marks

Print "Fail"

Print "Pass"Is 
marks > 40?
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1. (i) Parallelogram 	 (ii) Rectangle 	 (iii) Parallelogram

2. She should write an algorithm before making a flowchart.

Periodic Assessment 2
(Based on chapters 4 & 5)

A.	 1. Insert tab	 2. Animations tab	 3. Transitions tab 	 4. Slide Show 
tab 	 5. View tab

B.	

C.	

(Based on chapters 1 to 5)
Test Sheet 1

A.	 1. (ii)	 2. (iii)	 3. (iv)	 4. (iv)	 5. (i)	 6. (iii)	 7. (ii)	 8. (ii)

B.	 1. column	 2. Slide	 3. text	 4. Biometric	 5. Dollar
	 6. Scatter charts	 7. Plot area	 8. object

C.	 1. F	 2. F	 3. T	 4. F	 5. T

D.	 1. (b)	 2. (c)	 3. (d)	 4. (a)
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E.	 1.	� Ways to protect our computer: 

	 i. Download only legal software 
	 ii. Use the original version of Windows 
	 iii. �Scan Pen drive, CD and any other external storage device for viruses before opening in 

computer

	 2.	� To create a chart, follow the given steps: 

		  Step 1: Select the range of cells. 

		  Step 2: Click on the Insert tab. 

		  Step 3: Click on the Insert Column or Bar Chart command. 

		  Step 4: Select the 2-D Column Chart option. 

	 3.	� An action button can be used to move from one slide to another and play media files.

	 4.	 Step 1: Start

		  Step 2: Select the paragraph that you want to copy in Word.

		  Step 3: Click on the Copy command from the Home tab.

		  Step 4: Click the mouse where you want to paste the selected paragraph.

		  Step 5: Click on the Paste command from the Home tab.

		  Step 6: End

	 5.	� a. �Trojan Horse: A trojan horse is a dangerous virus. It represents itself as helpful software 
program. Once the user clicks on it to agree to run it, it gains access to sensitive data 
and then modifies, blocks, or deletes the data.

		�  b. �Adware: An adware tracks user’s browser and download history and keeps popping 
advertisements on the screen.

	 6.	 It returns the length of the text string. Example:
		  Input: =LEN(“Touch“)
		  Output: 5

	 7.	 To insert an audio file, follow the given steps: 

		  Step 1: Click on the Insert tab. 

		  Step 2: Click on the Audio command. 

		  Step 3: Choose the desired option. 

		  Step 4: Select the file. 

		  Step 5: Click on the Insert button. 

		  Step 6: Click on Play/Pause button to play or pause the audio. 
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	Using MakeCode Arcade

  (Page no. 78)

Step 1: Start

Step 2: Take first alphabet of the name of the book

Step 3: Go to the that alphabetical section of the library

Step 4: Search the book in that section and take it out

Step 5: Stop

code Quest  (Page no. 81)

1. Syntax

2. Coding

code Quest  (Page no. 84)

(This question was printed incorrectly in the book. Please correct it in your textbook.) 

	 Question: 

	 Answer the following questions:

	 1. Which book contains words and phrases in an alphabetical order, with their meanings?

	 2. �What is used to describe the steps of an algorithm in a human-understandable language?

	 Ans. 

	 1. Dictionary

	 2. Pseudocode

code Quest  (Page no. 100)

1. AND operator 	 2. NOT operator 	 3. Continue statement 	 4. Break statement

TeCh Ready

A.	 1. (ii)	 2. (i)	 3. (i)	 4. (iv)

B.	 1. instruct 	 2. dictionary 	 3. true 	 4. nesting

C.	 1. T 	 2. F 	 3. T 	 4. F

D.	 1. (c)	 2. (e)	 3. (b)	 4. (a)	 5. (d)

6.
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E.	 1.	� Python, Java
	 2.	�  Bar code scanner, Thermostat
	 3.	� Pseudocode is used to describe the steps of an algorithm in a human-understandable language. 

It has no syntax and can be easily understood by a layman. 
	 4.	� AND operator is used to check if two or more conditions are TRUE or Yes whereas NOT 

operator is used to reverse or negate a condition.
		  5.	 •  Equal to (==) operator is used to check whether two values are equal.
	 	 •  �Less than (<) operator is used to check whether left operand is less than right operand 

or not.

�
1. Pencil 	 2. Eraser 	 3. Rectangle 	 4. Fill
5. Circle 	 6. Line

1. By creating a sprite using the image editor.

2. NOT operator

	Introduction to Python

  (Page no. 104)

1. True	 2. 84	 3. 8 2 20	 4. True	 5. 22

code Quest  (Page no. 110)

1. Python	 2. Interactive Mode	 3. Script Mode	 4. Save option
5. Run Module option

code Quest  (Page no. 111)

	 Roll no = 201 

	 Student Name = “Chirag” 

	 Section = ‘A’

7.
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TeCh Ready

A.	 1. (iv)	 2. (iv)	 3. (ii)	 4. (i)

B.	 1. Prompt	 2. Guido van Rossum	 3. Variables	 4. print( )	 5. line by line

C.	 1. T	 2. F	 3. F	 4. T

D.	 1.	� The Features of Python are: 
		  a. Open Source 
		  b. Object-oriented 
		  c. Easy to code

	 2.	� On execution, a Python code is immediately converted into an intermediate form. This is 
known as byte code.

	 3.	� (This question was printed incorrectly in the book. Please correct it in your textbook.) 
		  Question: Write an example of declaring and initializing a variable. 
		  Ans. a = 10 
		  b = 20 
		  print (“a=”, a) 
		  print (“b=”, b) 
	 4.	� Four variable naming conventions are: 
	 	 • A variable name must start with a letter or underscore character. 
	 	 • A variable name cannot start with a number. 
	 	 • �A variable name can only contain alphanumeric characters (all the letters of the alphabet 

and numbers) and underscores ( _ ). 
	 	 • Variable names are case-sensitive. 
	 5.	� There are two components of Python IDLE window: 
	 	 • �Menu Bar: The Menu Bar of Python IDLE window is similar to the Menu Bar of other 

programs. It has various menus such as File, Edit, Shell, Debug, Options, Window and 
Help. 

	 	 • �Prompt: You will see a blinking cursor after the symbol (>>>) in the window. This is 
known as the Prompt. The Prompt allows the user to enter commands directly into 
Python and get an output instantly by pressing the Enter key. 

	 6.	� The input( ) function takes the user’s input while a program executes. On the other hand, 
the print( ) function prints or sends the output to the standard output device, which is 
usually a monitor. 

1. 2.0	 2. 12	 3. 10 20 30
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1. Script Mode 
2. Interactive Mode 

Periodic Assessment 3
(Based on chapters 6 & 7)

A.	 1.	� Bar code scanner	 2.	 Booking tickets	 3.	� Printer

B.	 Menu bar

Prompt

C.	 1.	 Sum of 2 and 3 is 5

	 2.	 Student Name: Shikha

		  Subject: Computer

		  Marks obtained: 86

	Human vs Machine Intelligence

  (Page no. 115)

Do it yourself.

code Quest  (Page no. 117)

1.	 The ability to understand and use spoken and written language.

2.	� Emotions, self-awareness, passion and motivation enable us to accomplish complex cognitive 
tasks. 

TeCh Ready

A.	 1. (iii)	 2. (ii)	 3. (iv)

B.	 1. F	 2. T	 3. T	 4. F

8.
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C.	 1. � S.No. Human Intelligence Artificial Intelligence

1. Created by nature Created by human intelligence

2. Processes information slower Process information with high speed

	 2. �Two capabilities of human brain are as follows: 

	 • Learn from different experiences 
	 • Understand complex concepts 

Do it yourself.

1. Do it yourself.
2. Do it yourself.

	AI Technologies

  (Page no. 121)

Do it yourself.

 Quest   (Page no. 124)

Siri, Alexa

TeCh Ready

A.	 1. (ii)	 2. (iv)	 3. (i)	

	 4. (This question was printed incorrectly in the book. Please correct it in your textbook.) 

	 Question: Which of the following does not uses the speech recognition technology? 

	 (i) Google Assistant 	 (ii) Cortana 

	 (iii) Siri 	 	 (iv) None of these  

	 Ans. (iv)

9.
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B.	 1. Voice 	 2. Google Assistant 	 3. Speech recognition
	 4. Face recognition

C.	 1. T	 2. T	 3. F	 4. T	 5. F

D.	 1.	� It is used in criminal identification, in phones to unlock them. 

	 2.	 Two areas where AI-powered OCR is being used are as follows: 

	 	 • Document are scanned using OCR. 

	 	 • Robots use OCR to scan barcodes in the warehouses and find stock. 

	 3.	� Face recognition is a technology which is used to identify an individual’s face.

	 4.	 Two benefits of AI-powered speech recognition systems are as follows: 
	 	 • They can capture speech much faster than we type. 
	 	 • They save time and effort as the user needs to spend less time in typing. 

1. Cortana	 2. Google Assistant	 3. Siri	 4. Alexa

1. Optical character recognition 
2. Face recognition

	  Types of Robots 

  (Page no. 129)

1. Zenbo: It is a low-cost robot capable of rolling around freely. 
2. Z-Machines: It is a music-band.

 Quest   (Page no. 137)

A.	 1. Kitchen Robots and Ironing Robots
	 2. A-PUFFER and The BRUIE
	 3. Furby and Aibo
B.	 �Robots are changing agriculture beyond recognition, from cobot-assisted milking to cow-

herding drones, they are there to help in every steps of farming.

TeCh Ready

A.	 1. (iii)	 2. (ii)	 3. (iv)	 4. (i)	 5. (ii)

10.
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B.	 1. Marimba-playing	 2. Service	 3. Furby	 4. Humanoid	 5. Robots

C.	 1. T	 2. F	 3. F	 4. F	 5. T

D.	 1.	� Industrial robots, Collaborative robots and Service robots.

	 2.	� A collaborative robot, or Cobot, is a type of robot intended to physically interact with 
humans in a shared workspace. These robots are supposed to work along with the humans 
and provide safety and flexibility.

	 3.	� Industrial robot is a robot system which used for manufacturing purposes. These robots 
are automated, programmable and capable of movement in three or more axes.

	 4.	� These robots either allow surgical operations to be carried out with better precision than an 
unaided human surgeon or allow remote surgery where a human surgeon is not physically 
present with the patient.

	 5.	� Some of the reasons for using Robots in space and research are as follows:

•	 They are sent to space because sending a robot in space is much cheaper than sending 
a human. 

•	 They don’t need to sleep. Hence, they can work for long hours.

•	 They don’t need to eat. Hence, they can survive in space for many years and can be left 
out there for further research. 

•	 They can withstand harsh conditions, like extreme temperatures or high levels of 
radiation.

C S H I M O N F E A

C U R I O S I T Y I

X B S V F H Y H B B

J L S S A F F I R O

Y E J N V L Z A U D

U G S C J J D S I Z

D O T W U R I S E S

J S D Y Z N I N U L

N U F P S W X V A Q

L K F U R B Y L P Y



IMPRINT 1

19� Digicode AI-VI (Answer key)

1. Service robots 
2. The BRUIE

Periodic Assessment 4
(Based on chapters 8 & 10)

A.	 2. Process information with high speed
	 3. Less accurate
	 4. Capable of adapting changes
	 5. Performs single task more efficiently
	 6. Has social skills

B.	 1. �Cortana 	 2. �Google Assistant 	 3. �Siri 	 4. �Alexa

C.	 1. �Rotimatic	 2. Knightscope	 3. Aibo 	 4. Humanoid

(Based on chapters 6 to 10)
Test Sheet 2

Section A

A.	 1. (iv)	 2. (iv)	 3. (iv)	 4. (iv)	 5. (i)	 6. (i)	 7. (iii)	 8. (iv)

B.	 1. Speech recognition	 2. Face recognition	 3. Marimba-playing
	 4. Humanoid	 5. Guido van Rossum	 6. instruct
	 7. dictionary	 8. Prompt

C.	 1. T	 2. T	 3. T	 4. F	 5. T	 6. F	 7. T	 8. F

D.	 1. (c)	 2. (e)	 3. (b)	 4. (a)	 5. (d)

E.	 1. (This question was printed incorrectly in the book. Please correct it in your textbook.) 

	 Question: Write an example of declaring and initializing a variable. 

	 Ans. a = 10 

	 b = 20 

	 print (“a=”, a) 

	 print (“b=”, b) 

	 2. Industrial robots, Collaborative robots and Service robots.
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	 3. �Two areas where AI-powered OCR is being used are as follows: 
	 •  Document are scanned using OCR. 
	 •  Robots use OCR to scan barcodes in the warehouses and find stock.

	 4. �Some of the reasons for using Robots in space and research are as follows:
	 •  �They are sent to space because sending a robot in space is much cheaper than sending 

a human. 
	 •  They don’t need to sleep. Hence, they can work for long hours.
	 •  �They don’t need to eat. Hence, they can survive in space for many years and can be left 

out there for further research. 
	 •  They can withstand harsh conditions, like extreme temperatures or high levels of radiation.

	 5. S.No. Human Intelligence Artificial Intelligence

1. Created by nature Created by human intelligence

2. Processes information slower Process information with high speed

	 6. �Pseudocode is used to describe the steps of an algorithm in a human-understandable 
language. It has no syntax and can be easily understood by a layman. 

	 7. 
	 •  Equal to (==) operator is used to check whether two values are equal.
	 •  �Less than (<) operator is used to check whether left operand is less than right operand or 

not.

	 8. �A collaborative robot, or Cobot, is a type of robot intended to physically interact with 
humans in a shared workspace. These robots are supposed to work along with the humans 
and provide safety and flexibility.


